Unable to Mount CD/DVD Drives

Hello -

I am a relative beginner to the linux community. I installed openSUSE 11.1 this past week and haven’t had any problems so far with installing and compiling packages and whatnot. But as of two nights ago, my onboard cd drive stopped working and I am getting a sort of dbus error and saying that its unable to mount the device. Its saying it’s a timeout issue…

Has anyone else had this issue?

Thanks in advance

Have you added your user(s) to the ‘disk’ group?

no i haven’t tried that yet. I’ll give that a go then. its confusing now tho because it was working before and all of a sudden it just won’t mount. I also tried adding a line to fstab to mount my external usb dvdrw drive but i can’t save my changes because i don’t have the right permissions even though im added to the root group…

you will want to take yourself out of the root group–the only member of the root group, should be the user “root”. The closest thing to an “administrator” group in linux would be the “wheel” group…

to do something that requires root privilages (like editing /etc/fstab), add sudo before the command you are trying to execute.

So if you wanted to edit /etc/fstab, the command would be

sudo vi /etc/fstab

it will prompt you for the root password (or your own, depending on how sudo is configured–by default, it will ask for the root password)
and then execute your command!

You don’t need to change anything in fstab as detecting and mounting non-permanent media is handled separately. Start by making sure that every user is in the ‘disk’ group. You don’t need to make any change other than that in the first instance.

Hello, I am curious if anybody has found a solution to this problem. I am seeing the exact same thing - cannot mount a CD/DVD. Also get the same message when trying to mount a USB thumb drive. I have to assume it is something within openSuSE 11.1 because I also have SuSE Linux Enterprise Desktop 10.0 installed on the same machine and when I boot to SLED, the CD/DVD and USB thumb drives mount just fine. Adding my user to the disk group in open SuSE did not make any difference, plus, none of my user accounts belong to the disk group under SLED and everything works just fine.

Any help would be appreciated. I seem to remember as the orignal poster mentioned that this did work fine when I first installed openSuSE but it stopped working shortly thereafter. I am in a position where I can totally reload openSuSE from the installation media because I have no critical data on openSuSE yet. If/when I do this, I will report back to inform this forum of my results.

Thanks!

John.

First You need to rule out if it is software or hardware problem. For example, i had problem with a DVD, it turned out it was borked by the KDE4 version of K3b. When i put another DVD it worked great. There WAS a problem with doing anything with CD/DVDs but it was fixed with an update.

Also You weren’t too specific, you will get the same answer as Your question. The more details you provide the more detailed answer will be.
People just need to learn how to troubleshoot things.

> and I am getting a sort of dbus error

today some kind of update to the dbus-something was installed by the
“openSUSE Updater”…maybe yours too…maybe it works now??


MultiplePersonality

I also was just notified of the dbus update. I installed it and that seems to have corrected my problem. Both my DVD/CD and USB thumb drives mount as they should.

Hello, I am having this problem as well. In previous versions of Suse, if I put in a blank CD, it would auto start k3b and let me burn. Under Suse 11.1, it does not auto start. If I manually start k3b, it won’t find any suitable device. If I then become root and:

chmod 666 /dev/sd0 (/dev/cdrom links to it) it will let me burn.

Similarly, audio CDs won’t play. If I try to use kscd, I get an error:

CD-ROM access error (or error in startup of audio system).
Please make sure you have access permissions to cdrom device:
device ‘[DVDRW - PHILIPS - DVD±RW SDVD8820]’(), audio system ‘cdin’

I’ve seen various posts where people recommend adding the users to ‘disk’ group. Isn’t this a MAJOR security risk? I mean, look at the permissions of a hard drive partition:

brw-rw---- 1 root disk 8, 3 2009-03-18 10:59 /dev/sda3

I suspect if users were member of ‘disk’, they could (or some malicious software) could trash a system. This would defeat the security which makes linux so great.

What has changed in Suse 11.1? I was trying to find out where the permissions are defined in the autofs, and thought if I modified the /etc/auto.misc (which has some settings for mounting the cdrom) I could make it work. But apparently this is not the right place. Also, I tried adding users to group ‘cdrom’, but this group doesn’t appear to have any function.

Any help would be great.

Thanks!