Unable to make Leap 15.1 a RMT Client

Hello - I’m sorry if I’ve posted this in the wrong place but it involves both RMT and openSUSE. I’m trying to learn about disconnected installs and using RMT repositories when the SCC is not available or not an option.

I’ve got a SLES 15 SP1 Server running RMT. I’ve successfully enabled and synced several repos from the SCC to my RMT server (FQDN: nsi-rmt.netsysint.net). I installed an openSUSE Leap 15.1 on the same subnet as the nsi-rmt box. My goal was to make the Leap box be an RMT Client so it would get updates from nsi-rmt.

This is the procedure I followed:

  1. First attempted to use YaST on the Leap machine and add https://nsi-rmt.netsysint.net/
    as a repository but I got an error regarding certificates. 1. So further research led me to the rmt-client-setup
    script. Followed the instructions in the RMT docs for SLE 15 using curl to get the **rmt-client-setup **script from the nsi-rmt box down to the Leap box. 1. Ran **rmt-client-setup **
    on the Leap box and it immediately exited with a “SUSEConnect not available” error. 1. Checked the script and the error occurred when checking for the existence of /usr/sbin/SUSEConnect
    . 1. Used ssh to get SUSEConnect
    from the nsi-rmt box over to the Leap box. 1. Re-ran rmt-client-setup
    and it got past accepting and storing the nsi-rmt certificates and seemed to get all the way to the end only to through the following error:

Start the registration now? [y,n] y
/usr/sbin/SUSEConnect --write-config --url https://nsi-rmt.netsysint.net/
Traceback (most recent call last):
2: from /usr/sbin/SUSEConnect:23:in ‘<main>’
1: from /usr/lib64/ruby/2.5.0/rubygems.rb:308:in ‘activate_bin_path’
/usr/lib64/ruby/2.5.0/rubygems.rb:289:in ‘find_spec_for_exe’: can’t find gem suse-connect (>= 0.a) with executable SUSEConnect (Gem::GemNotFoundException)

Not knowing a thing about ruby I’m not sure how to troubleshoot this.

Any advice would be GREATLY appreciated!


Hi and welcome to the Forum :slight_smile:
I’m guessing you ran the client install via this?


Likely you have the wrong version of SUSEConnect (and associated dependencies) , this should be installed from the openSUSE Leap 15.1 repository, not from the SLE system.

Thanks a ton for the advice Malcolm! Installing the SUSEConnect-0.3.16-1p151.1.1.x86_64.rpm package on the openSUSE box and then re-running rmt-client-setup corrected the problem.

Here’s a question on RMT registration: Assuming that rmt-client-setup works you get a message stating that the client machine is registered with the RMT server. But is there any way to tell from the perspective of the RMT server what devices have been registered? I couldn’t find any version of the rmt-cli command that provides that info and I couldn’t locate any file on the RMT server containing information on “registered” devices. It seems that the only way to tell a device is “registered” with the RMT Server is to go to “Software Repositories” in YaST on the client and see URL(s) for the RMT Server listed there. Is that the case?

Thanks Again!

I’m not sure, I see a features list here, no client management;

You can also use the zypper command (eg zypper -lr d). I would suggest asking over at the SUSE forums (same username/password) since RMT is more applicable there than here;

Hello, Rich.

Just FYI, HTTP access is enabled on RMT by default and you can add RMT repos to openSUSE machines without SUSEConnect (as it isn’t present on openSUSE installations by default) like so:

zypper as http://your.rmt.server/services/1929/ rmt

(rmt-client-setup handles HTTPS certificate import, but it requires SUSEConnect)

rmt-cli systems list” command is available in more recent versions of RMT.

HTH, Ivan.