Unable to login using kde after upgrade to 12.1

Hello,

Finally I decided to upgrade my system to openSUSE 12.1 from 11.4.
I updated the repositories urls, did zypper ref, zypper dup, zypper verify

After the upgrade process was done, I rebooted my system and got my opensuse 12.1 running,
BUT now, when I’m trying to login to kde using kdm, the screen blanks for a second and then I get kdm_greeter login screen again.

  1. I tried to use xdm as login screen (changed DISPLAYMANAGER in /etc/sysconfig/displaymanager) and got the same result.
  2. I tried choosing failsafe as a window manager, this one brings a xterm and when I run startkde I get my desktop back but this is not a good solution, maybe a fair workaround.

where should I look for a hint ??
couldn’t find nothing in /var/log/messages or /var/log/Xorg.0.log

Thanks,
Sagi.

So, you could use your solution to get in and then use YaST to create a new user. Then, try to login as the new user normally. If that works, then the actual problem is that KDE is blowing up when you log in as your old self and not that the password does not work. Not sure just what part might be wrong, but you can remove the hidden file .kde4 in your /home folder (/home/username/.kde4) and make KDE restart all of its settings for that user name. Then try to log in as yourself again.

Thank You,

Hi,

Actually I did it.
And this issue happens for root as well.
I removed ~/.kde4 directory and all kde temp files from /tmp /var/tmp and rebooted my machine.
but it didn’t help.

Thanks.

Just out of curiosity what version of KDM are you using?

sudo rpm -qa | grep kdm

rpm -qa | grep kdm
kdm-branding-openSUSE-12.1-15.3.9.noarch
kdm-debuginfo-4.7.2-6.4.1.x86_64
kdm-4.7.2-6.4.1.x86_64

And yes, I was able to solve this issue.
It is not enough to delete ~/.kde4
I also had to rename ~/.config ~/.local and more …
I removed almost all the dot files in my home dir … and now I’m getting them back from my backup

So its good news to hear you have found a solution but creating a new user would not have had such a problem in the first place you would think.

Thank You,

Yes, setting up a new user would be much easier, but I didn’t want to lose all my configurations.

But you know what, KDE sucks !!!
I’m using KDE since 2004 and if after every upgrade I need to reset all my configuration files and start from scratch, something is wrong !!!

After I removed almost all my configuration file (dot files, etc…) I decided not to bring them from the backup and to set everything again,
but while setting my wallpaper to be solid color, kde crashed and guess what ?!

YES, RIGHT, I CAN’T LOGIN AGAIN !!! >:(>:(>:(>:(

So this is a bummer for sure. If creating a new user and not loading up all of your old config files does not work for you, then one might wonder what else might be wrong. Let me tell you that the last time I had such oddities, it turned out to be a bad place on my hard disk which was creating the crazy operation of KDE in openSUSE. You might want to consider such a possibility.

Thank You,