unable to login as root

Good afternoon,

I’ve been using suse/opensuse since version 9.3.

At the moment I have opensuse 11.4 installed on my main machine, this has been a very good little box & ive only had little niggles that Ive found fixs for on the net.

I personally dont interact with the machine very often but this morning I became alarmed when I tried to login to the machine using root /password and it wouldn’t let me logon.

I was able to login as my standard users. however when I type “su” then the password it gave me incorrect password messages.

I then went to my other machine and sshed to my suse box this allowed me to root into the machine.

at which point I changed the password using Yast2 from the ssh point all looked well but I rebooted the machine and ssh is no longer running I only turn it on when I want to interact with the machine but has i cant access root how do i start the service?

Does anyone have any ideas. I know what the password should be… I don’t understand why it allowed me access via ssh from my other machine. but not locally?

If anyone has any thoughts I need to try and get the machine up and running again asap.

I may just leave it till opensuse 12.2 comes out 5days yay :slight_smile:

On 08/31/2012 03:06 PM, kungfu wrote:
> I
> don’t understand why it allowed me access via ssh from my other machine.
> but not locally?

perhaps the local keyboard has a hardware malfunction…or the system is
setup to use a different keyboard layout (thus sending different
characters than the ones typed)…or, the shift-lock is on and the
keyboard’s LED light telling you that is not working…or, the
keyboard’s controller circuity (on the motherboard) is frazzled…or
there is a fault in the keyboards cord…or, the plug in point to the
computer, or . . . maybe the keyboard is wireless and has lost its
mind… or needs new batteries or or or . . .

so: try a different cord, keyboard, keyboard layout, batteries etc etc etc…

if the keyboard feeds more than one device through a switch–take the
switch out of the path (maybe the switch has a wiring fault)

if you don’t have spares easy to find, just shut everything down, unplug
the keyboard and plug it back in…and see if it starts working again
(there could be a speck of corrosion in a connection point that just
un/replugging will remove)

oh, and if the keyboard is not connected via USB and you have ever
plugged/unplugged it while the machine is powered up: you may have so
damaged the keyboard controller that that is the problem…

dd http://tinyurl.com/DD-Caveat

thanks dd but its not the keyboard I am able to login via a normal user. keyboard is a trusty ps2 keyboard not usb as I have had issues with usb keyboards in the past…



You have a long story which contains a lot things that are irrelevant to your problem IMHO. Is it correct when I recap your problem as follows:
. When you are loged in as end-user sitting at the system (using it’s keyboard) and then want to become Superuser with su - , your root password is rejected.
. When you log in with that same end-user using SSH from another system and then try the same su - as above, there is no problem.
. You are sure your keyboard is not the problem because you use it as end-user without any problems.

Please confirm when this is a correct description, or change it to a better technical description.

And regarding to your keyboard: are you sure you do not have any less often used characters in your root password, characters that are normaly not used when working as end-user?

hi HVC,

The above was correct after i got home from work i tried to login again using ssh from my other machine and i got password incorrect. after 3 attempts it kicked me off.

However because the machine is mine and i know the password i was typing was correct copy & paste still didnt work. i have physical access to the machine so i reset root password now i am back in my system.

i found a way to circumvent the security to change the root password.

Please can you close this thread now as i am back onto my machine



This is now all working.

The below is linked to one of the ip addresses that has been logged on my machine that is why my root account was trashed
http://www.xtronic.net/[FONT=Courier New]

Kred Krew:[/FONT]
Waging the war against burnout SysAdmins

got root?
sh-2.05b$ whoami
uid= 0 (root) gid= 0 (root)

New found Disorder, Day of darkness has arrived
Are You Ready ?


Greetz to all of DARPANET
[LEFT]**“Krashed, Founder of Kred Krew” **[/LEFT]

To Both,

you where correct about keyboard left shift sometimes didnt press correctly but still have the above…

Thank you for your help

Raving again

On 09/01/2012 03:06 PM, kungfu wrote:
> ip addresses that has been logged on
> my machine that is why my root account was trashed

you really need to closely examine your security procedures!
close your open gates…
otherwise you just operate a spambot!