Unable to locate buildservices-drivers in webcam repo !

I am unable to locate the ‘buildservice-drivers’ package in the webcam repo (/repositories/drivers:/webcam/openSUSE_11.1). I have got this repo in Enabled & Autorefresh mode and at 99 priority.

I reinstalled openSuse 11.1 recently and before i started the reinstallation process i had documented the packages from various repos clearly. Before the reinstall ‘buildservice-drivers’ came from the webcam repo. Now i don’t seem to get it. I have even switched over my installation UI to qt and searched for the package ; but no success. Am i not searching in the right repo or this package has moved to some other repo now!?

My webcam is not working properly and i reckon it’s because this package is missing. It used to work fine earlier.

Please help !!

Ok let me restate my problem. I just found that i am unable to view my webcam through Cheese but i am able to see everything when i use aMSN. And yes, i am not trying to use both together. This is starting to get frustrating now.

Any ideas?

There is a page on Webcams here:
HCL/Web Cameras - openSUSE

The repo you are after is here I think: Index of /repositories/drivers:/webcam/openSUSE_11.1

I am going to try preload as proposed in the HCL/Web Cameras link. I already have libv4l from packman.
Webcam works fine for aMSN but not for Cheese or Skype.

Ok this is what i did.
> followed caf’s advice (he has been my savior during my intoduction to openSuse) on HCL/webcam at HCL/Web Cameras - openSUSE
> got the point on LD_PRELOAD over there
> just that didn’t work; so i did the following
Create a new file: /usr/local/bin/skype using touch command. Put the following into the file

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype 

You will need to make it executable.

sudo chmod a+x /usr/local/bin/skype

> Skype webcam was up and running- i still need to test it on a real call though

> My Cheese did not show anything on cam either. So i did exactly the same as above ; but replaced all “skype” with “cheese” and i was all set

> I could not follow instructions “If this works for you, you can add the LD_PRELOAD-command to the startup command of your menu entry/desktop shortcut via menu editor or with right-clicking the desktop icon => properties => application => command respectively.” at HCL/Web Cameras - openSUSE and add something to the command of the desktop shortcut - probably someone can help me there so that i can avoid the above 2 files.

I’m not sure I was much help really. I have never used a webcam. The instruction to edit the launcher on the desktop: Is like this shot, edit the highlighted area for the application launch Command

I use GNOME and only have - Basic, Emblems, Permissions & Notes tabs. No application tab per your screenshot.
I right clicked on my desktop shortcut and did properties. Am i missing something?

Odd. I can’t say for sure, because I don’t have gnome. You are doing it the correct way. Try the Menu Editor route
Right click Menu - Editor
Navigate to the Application
You can add the info this way too.

I managed to locate the application dropdown (it’s a dropdown on properties of the shortcut) and inserted the command “#!/bin/bash
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype” but it says “Could not launch application. Failed to execute child process “LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so” (No such file or directory)”.

Then i tried inserting the command “LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype” without the bash part ; but same error.

Have you installed video for linux? (v4l)

If you type: skype in a terminal, does skype start?

Yes i do have libv4l and skype does start from the terminal.

Found this
How to install Skype VoIP client in openSUSE | SUSE & openSUSE

I have got all pre-requisites that the susegeek location talks about except “libqt4-dbus-1”. I googled a bit and found that many others have the same problem - even some on this forum. Although i have been able to locate the package at Software.openSUSE.org ; i first want to try and see if skype works and then try and install “libqt4-dbus-1”.

Any directions on adding the command to the skype application correctly?

Did you install skype with the .rpm from the skype website?

I went there and it’s not very helpful IMO but what you could do is uninstall skype.
rpm -e skype

Then reinstall
rpm -ihv packagename

you can use the TAB key to auto complete the package name

I installed it with the .rpm from the skype website. I removed and reinstalled with -ivh ;but same error.

Did it refresh the menu entry and if so what does that do when you launch it from there? And what is the launch command in there now, is it the same as you edited it previously?

Also, if it doesn’t start from a terminal - what if any errors show there when you try?

Below is what i get if i run it from terminal: Skype does start fine with audio & video. But when i use the same LD_PRELOAD in the command box it throws an error (same as before):

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype
ALSA lib pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi

RtApiAlsa: underrun detected.

A workaround that ‘works’ is point to the skype script file in the command box. Executes just fine. Cannot avoid the terminal errors as above with that though.