unable to load Windows 8 properly after installation of opensuse leap 42.3

Hi I am Rupesh from India and I have Toshiba satellite c55 b894 laptop. I have installed Windows 8.1 after that installed opensuse leap 42.3. I am able to boot into Linux properly but not into Windows.

I think that grub is not working properly. From yast I have entered into bootloader I have tried various resolutions and tried to boot into Windows but none worked fine I mean when I try to boot into Windows the login screen is not displayed properly and half of the screen is filled with blank screen and remaining screen is filled with login screen of Windows. Due to the above issue I am not able to enter my username and password. Finally making changes in the bootloader which is present in yast I am able to boot into Windows properly and everything is working fine. The changes I have made is I have removed tick mark called use graphical mode while booting using grub I mean using console mode.

In Windows I have installed amd graphics driver and in Linux I have not installed any other graphics driver on my own.

I don’t know what’s the exact problem. Please try to suggest how to boot properly into Windows using grubs graphical mode.

Is there any necessity to install the latest version of amd graphics driver other than the one provided default by opensuse for proper functioning of Linux.


Graphics driver should play no part on chaining to another OS. That happens before the driver is even loaded.

Odd that it works in Grub text mode and not in Grub GUI mode???

Be sure that you have turned off fast boot in Windows.

Also perhaps things are not pointing to the right Windows partition. Maybe show fdisk -l

EFI or legacy booting???

Again with this? Same laptop you’ve asked about on Linuxquestions, where you lead off with “windows 8 doesn’t work right on this laptop”??? There are hundreds of dual-booting how tos you can find, and all of them are basically saying the same things:

  1. Load Windows first
  2. Resize your disk partition
  3. Load Linux
  4. Modify Grub

In that order. Lots of them even walk you through each step. Can you tell us which one you followed? What order you went in?

I have examined BIOS settings in that boot mode is CSM boot not uefi boot.

I am providing the output of fdisk -l below

linux-ps66:~ # fdisk -l
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x93925dca

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1  *         2048   1026047   1024000   500M 83 Linux
/dev/sda2         1026048   1742847    716800   350M  7 HPFS/NTFS/exFAT
/dev/sda3         1742848  65230847  63488000  30.3G  7 HPFS/NTFS/exFAT
/dev/sda4        65230848 976771071 911540224 434.7G  f W95 Ext'd (LBA)
/dev/sda5        65232896  70043647   4810752   2.3G 82 Linux swap / Solaris
/dev/sda6        70045696  83683327  13637632   6.5G 83 Linux
/dev/sda7        83685376 111988735  28303360  13.5G 83 Linux
/dev/sda8       111990784 890230783 778240000 371.1G  7 HPFS/NTFS/exFAT
/dev/sda9       890232832 976771071  86538240  41.3G  7 HPFS/NTFS/exFAT

linux-ps66:~ # 

No one asked you for/needs that. You were told what to do, and asked questions. You didn’t answer the questions and aren’t following advice that’s given. If you’re not going to do either, why post?

Cool down, please. Leave moderation of the forums threads to the forums team. If you cannot provide help, refrain from posting or report the post if you think it needs to be moderated.

Sorry to mention that I have followed what gogalthorp suggested ie., I have disabled fast boot in Windows 8 and after that I have enabled graphical mode in boot loader section related to grub and even no use. Actually I must content this during my last post but forgotten.

I can’t follow what other people suggest i mean people who are saying you are an idiot etc.,. I can’t understand any matter which contains the word idiot.