Unable to load autoyast file in 10.3

I’ve created an XML autoyast file and placed it on a USB drive. I’ve then inserted the USB drive into the server I’m trying to build and, once I’ve booted to the installation DVD I add “autoyast=usb://file.xml” to the boot options line. It isn’t recognized.

I’ve tried just passing "autoyast=“usb://” and removing everything from the thumbdrive except the file. I’ve tried with “autoyast=usb://file.xml” with everything removed except the file and I’ve tried it with other files on the thumbdrive. Nothing works. I keep getting an error saying that the file cannot be found on the device.

Is this a problem with 10.3 that it can’t recognize the files? I recall having to deal with RNG files but when I create the file in the YaST Autoinstallation module XML is generated. Do I need RNG? If so, how do I create it and why isn’t it created by default.

Any help with this will be greatly appreciated.

I found out how to make this work. According to the autoyast documentation at AutoYaST there are several options for loading up the autoyast file. All methods are prefixed with “autoyast=”. One method listed is, indeed “usb://<path>”. However, this consistently failed as did “floppy://<path>”. Instead of using those methods, I used "device://<usb_dev_number>/<path>. My autoinstallation is now underway.

so do you mean, for example:


Pretty much. But don’t use the dev. When using the “device://” prefix you’re setting it to know that /dev/ is in the path.

For instance, if you know the USB drive will be the only serial device it would be “device://sda1/root/something.xml”. That assumes that you have a directory called root on the drive and the profile is within it, of course.

Looks like you’ve found some documentation that is somewhat useful. I can’t seem to find any relevant info on what I’m trying to do.

You look like you’re accessing the install media on DVD. What I did was copy the contents of the DVD to a USB stick.
So what I’m trying to do is find the right syntax to add to the boot options line.
So when suse boots up the install( the blue screen with install options) I have tried typing about 101 different variations of the syntax.
I want it to automatically start installing from /dev/sda/install But it as soon as I hit enter, it fails back to the text mode and I have to step thru the manual setup

I’ve tried:
I’ve also tried 50 different combinations and permutations of that line. Still it fails

I wish they’d document this syntax. I actually came across a document that listed a couple of options and then said that there are many more options but I’ll never need to use them so there was no need to list them!!!


what happens if you try install=hd://install?device=://sda1&autoyast=://sda1/<path> ?

It fails. Setup cannot figure out what device and what folder contain the setup files
Even if I forget about the autoyast file for a while, just to boot it and have the install start automatically. The install files are in the /install/ folder on the USB stick.

and a few the combos still don’t work.
Very frustrating.


Where are you getting the formatting for the boot options? I’ve been doing a search for installing from USB but the only thing I’ve found is information on making the USB stick bootable.

it’s horribly undocumented.
I’ve been breaking to another console (CTRL_ALT F2,F3) and seeing what the stupid OS is doing.
Also I put a video camera on the setup to capture the dialog boxes which have some of this formatting, but none of it is working for me … :slight_smile:

I also went thru a setup and had it generate an autouyast file. This file seems to have some of these tags that don’t seem to work in the real world.

I had thought that I was the only person on the planet trying to do this, it’s nice to know there are at least a couple of others…

I would recommend making the USB stick bootable (assuming your BIOS supports booting from USB) following this guide. Once you are able to boot to the USB stick you should simply have to pass the autoyast= directive telling it to look at device=/sda1/<path>

theillien, now the biggest problem I’m having is that the install process will not boot off of the Hard Disk. It configures everything to boot from the USB stick, no matter how many times I change the boot loader options.
Are you having this problem?

Now I’m confused. You have an installation on your HD already and the boot loader is now looking for boot media on your USB drive?

exactly. I just figured I’d let suse generate the autoyast and then I’d modify it like I needed. so I just installed a basic SLES10 and generated the autoinst.xml
Somewhere along the way, something keeps confusing the setup and it won’t boot off the HDD. I’m going to try to modify the xml file and adjust the boot information and then use that on the boot options to do the install.

I have a server I can play with for a couple weeks so I’ll see what I can work out.

Just so I’m clear (I’m sure you’ve mentioned it before but I’m tired), you are booting to another media (cd, floppy, etc) and simply keeping the installation media on the USB drive yes?

Here’s what I did, or trying to do :slight_smile:

I used this process to make the bootable USB stick:
SuSE install from USB drive - openSUSE

As the process states, I copied the install media to the stick.

At this point I am not using any autoyast files (I have a bunch, but I wanted to do a clean install with this way and use that autyast it generates)

So I go through the install, taking defaults.
At the end of the install when SUSE reboots, if I remove the stick and boot from the HDD, I get an error “operating system missing” If I boot from the stick, it looks like SUSE had written the boot info to the stick.

Now I have been trying to change the boot loader info to try to get it to boot off the HDD, but no matter what I try, the install doesn’t seem to listen to me.
Thanks for your help. I’m continuing my testing on this, and I’ll post if I make a breakthrough


I wasn’t able to get the server I’m working with to boot from the USB drive even though such a method is supported and it is listed as the first boot device in the BIOS. I’ll have to play more with that before I look any further into this.

HA! finally found it

install=hd://dev/sda1/<install dir>
same goes for the autoyast.

Now I just need to convince the installer that while I am booted off of /dev/sda1 and yes it is like a HDD, I really need to boot off /dev/hda2. So far all the tinkering hasn’t convinced it…