Unable To List User on Login Screen in openSuse 12.1

Hi - After adding a second user via command ‘useradd jane’ I can’t seem to add it to the Login Screen. I have KDE installed. The Login Screen only shows the root user’s name and when I change it to user jane I get the following message:

Cannot enter home directory. Using /.
When I select OK I get the following message:
Call to lnusertemp failed (temporary directories full?) Check your installation.

Any help with this will be appreciated.
Linux linux-d7xx 3.1.9-1.4-desktop #1 SMP PREEMPT Fri Jan 27 08:55:10 UTC 2012 (efb5ff4) i686 i686 i386 GNU/Linux
Running Win 7 & numerous Linux Distributions on 2 hard drives using a Dell Inspiron 530S Desktop.

Use Yast - Security, Groups and Users to

  1. Remove jane, if present at all,
  2. Readd jane.

Before that: check whether there’s a folder “jane” in /home. I think the homedir has not been created.

On 2012-03-14 22:56, Knurpht wrote:
>
> Use Yast - Security, Groups and Users to
> 1. Remove jane, if present at all,
> 2. Readd jane.

Use YaST.

> Before that: check whether there’s a folder “jane” in /home. I think
> the homedir has not been created.

Quite possible, as you have to specify that in the command line.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Thanks Knurpht & robin_listas. There wasn’t a listing for ‘jane’ in /home so using root I “mkdir /home/jane”. I then went to Yast ‘users & groups’ and deleted ‘jane’. I went back to terminal and entered ‘useradd jane’ and then ‘passwd jane’. I then rebooted and there was no login screen. It logs in automatically to the ‘root user’s’ account. What am I missing here? Thanks for your help.

I rebooted and now ‘jane’ appears in login screen but, after entering password and hitting ‘enter’. I get this message:

Call to lnusertemp failed (temporary directories full?). Check your installation.
Where do I find the ‘temporary directories’ and how do I determine if they’re full?

When you create a new user with YaST, the user folder is created for you with the correct permissions. If for instance, as root, I create a /home/jane folder, jane the user could not write to it because it belongs to root. Try creating a new user as jane2, but do not create a jane2 folder and see if that is not done for you automatically. You may even want to once again remove jane, delete the jane folder as root and then recreate jane again, but this time, without a preexisting folder. When jane logs in next, that folder will be created for you as jane and not as root.

Thank You,

On 2012-03-15 00:16, gdawg65 wrote:
>
> Thanks Knurpht & robin_listas. There wasn’t a listing for ‘jane’ in
> /home so using root I “mkdir /home/jane”. I then went to Yast ‘users &
> groups’ and deleted ‘jane’. I went back to terminal and entered ‘useradd
> jane’ and then ‘passwd jane’. I then rebooted and there was no login
> screen. It logs in automatically to the ‘root user’s’ account. What am I
> missing here? Thanks for your help.

Why don’t you stop using useradd, and use YaST to create users? It is plain
simple. Othwerwise, read the man page for useradd and find out.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Thank you both for your excellent advice. I originally created user jane using Yast but thought I would see the new user listed in the boot login screen. When it wasn’t, I attempted to use the command line. I did not know that all users’ would not be listed in login screen.

Kind regards,

Glen

Use Yast, like suggested, That does all the things needed to creste a “normal” user. You missed something in my post: I told you to first remove jane, than re-add jane both through Yast,. To determine which users are to be shown in the login screen, use Yast - System - Sysconfigeditor, search for “KDM_USERS”, add jane there if she’s still not there after creating jane through Yast

In order to list the Users and make a selection you need to use the KDE branding instead of the default SuSE version. I don’t understand why they took out the User selections in the first place.

In the Forums #84 message from Tyler_K, we find how to change the Logon so that we get back our “User” selections. Use:
kdm-branding-upstream instead of kdm-branding-openSUSE

This is what I did and it works fine.
Chuck

On 03/15/2012 11:56 AM, chucktr wrote:
>
> In order to list the Users and make a selection you need to use the KDE
> branding instead of the default SuSE version. I don’t understand why
> they took out the User selections in the first place.

It is a security feature. Listing all the valid user names on the login screen
tells someone who wants to break in part of the info they need.

Hi - many thanks to all for helping me with this. I have no problem with entering user’s’ name in log-in box. I understand that it is a security feature. In addition to the original ‘root’ user I have now added 2 users using Yast and have no problem booting them. Apparently ‘Yast - System - Sysconfigeditor’ has been changed to ‘Yast - System - /etc/sysconfig Editor’. A search for ‘KDM_USERS’ took me to a page with no names listed which is apparently the default setting. Thanks again and this has been a wonderful learning experience.

Kind regards,

Glen

For openSUSE 12.1 users that would like to have a user name listing, please see this blog on the subject: openSUSE 12.1 SUSE KDM Login Screen User Listing - Blogs - openSUSE Forums

Thank You,

Message Invalid Forum specified. If you followed a valid link, please notify the administrator

So after doing an update on my single-user (me) 12.1 x64 machine, I can no longer log in except as root. Before the option appears to log in, I get the by-now famous message:
“call to lnusertemp failed, (temporary directories full?). Check your installation.”

If I check “okay” then I can get to the login screen but only root can actually log in.

I have lots of space on my vanilla installations in both root and home partitions. I tried chmod o+r /etc/passwd as was suggested in another thread. I checked the disks. Is this a bug? It just sorta came out of nowhere on an otherwise well-running machine. I also get the message when I start in failsafe mode.

Thanks in advance…

There was a recent change that removed the word /forums from the link. I have fixed it and thank you for letting me know of the problem.

Thank You,

Why not give us the terminal output from:

su -
password:

fdisk -l

cat /etc/fstab

Thank You,

On 2012-10-14 04:36, jdmcdaniel3 wrote:

> Why not give us the terminal output from:
>
>
> Code:
> --------------------
> su -
> password:
>
> fdisk -l
>
> cat /etc/fstab
> --------------------

and “df -h”, please.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Thank you for the offer of help! (I can only log in a root)

OS121:~ # fdisk -l

Disk /dev/sda: 1500.3 GB, 1500301910016 bytes
255 heads, 63 sectors/track, 182401 cylinders, total 2930277168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x6ffe6ffe

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048   245762047   122880000    7  HPFS/NTFS/exFAT
/dev/sda2      1490806784  2930277167   719735192    7  HPFS/NTFS/exFAT
/dev/sda3   *   245762048  1490804735   622521344    f  W95 Ext'd (LBA)
/dev/sda5       245764096   249970687     2103296   82  Linux swap / Solaris
/dev/sda6       249972736   426192895    88110080   83  Linux
/dev/sda7       426194944  1490804735   532304896   83  Linux

Partition table entries are not in disk order

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x4827e7b1

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048  1953519615   976758784    7  HPFS/NTFS/exFAT
OS121:~ # cat /etc/fstab
/dev/disk/by-id/ata-WDC_WD15EARS-00MVWB0_WD-WCAZA2794880-part5 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-WDC_WD15EARS-00MVWB0_WD-WCAZA2794880-part6 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-WDC_WD15EARS-00MVWB0_WD-WCAZA2794880-part7 /home                ext4       defaults              1 2
/dev/disk/by-id/ata-WDC_WD15EARS-00MVWB0_WD-WCAZA2794880-part1 /windows/C           ntfs-3g    defaults              0 0
/dev/disk/by-id/ata-WDC_WD15EARS-00MVWB0_WD-WCAZA2794880-part2 /windows/D           ntfs-3g    defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
OS121:~ # 
OS121:~ # df -h
Filesystem      Size  Used Avail Use% Mounted on
rootfs           83G   24G   56G  30% /
devtmpfs        7.9G  4.0K  7.9G   1% /dev
tmpfs           7.9G  1.1M  7.9G   1% /dev/shm
tmpfs           7.9G  712K  7.9G   1% /run
/dev/sda6        83G   24G   56G  30% /
tmpfs           7.9G     0  7.9G   0% /sys/fs/cgroup
tmpfs           7.9G  712K  7.9G   1% /var/lock
tmpfs           7.9G     0  7.9G   0% /media
tmpfs           7.9G  712K  7.9G   1% /var/run
/dev/sda1       118G   63G   55G  54% /windows/C
/dev/sda7       500G  156G  340G  32% /home
/dev/sda2       687G  278G  409G  41% /windows/D
OS121:~ # 

So we wonder if there is anything wrong with this partition?

/dev/disk/by-id/ata-WDC_WD15EARS-00MVWB0_WD-WCAZA2794880-part7 /home                ext4       defaults              1 2

Carlos requested a terminal df -h command be posted which would give us more info:

df -h

My immediate thought is to add a new user, while root, that would use /home and see if your user self is just corrupted or something worse with the partition.

Thank You,