Unable to Install

My computer is a msi gp72 6qf leapord pro brand new, i made an installation disk which works fine but when i boot it up and select install it stays stuck at the green loading bar indefinitely. Im brand new to linux and dual booting please help.

Could be a video card issue? What GPU do you have. Also what processor (CPU)

How do I check that?

Doesn’t there come any description with the hardware you bought? Either on paper or on the manufacturer’s web site?

How do you know that the installation disk works fine?
Maybe press “esc” and see where the process is stuck.

I checked on my computer and found this out about it:
Processor: Intel(R) Core™ i7-6700HQ cpu @ 2.60 GHz
GPU: Intel(R) HD Graphics 530

the process is stuck at the green horizontal loading bar after pressing install

And what when you press Esc as suggested by someone here?

(Please do read all answers to your thread carefully. And do answer all questions asked, or explain why you are not able and/or willing to answer them.)

loading basic drivers… ok
starting hardware detection… ok
(if a driver is broken for you, try booting with brokenmodules=driver_name.)

Intel sunrise point-h sata controller [ahci mode]
drivers: ahci*
activating usb devices… ok
msi epf usb

drivers: usbhid*

Razer mamba tournament edition
drivers: rtsx_usb*
intel dual band wireless ac 3165
drivers: iwlwifi*
Qualcomm atheros ethernet controller
drivers: alx*

I would try adding “verbose noapic” without the quotes to the boot parameters.

I dont know how to do that.

At boot menu press e find line starting linux or linux-efi go to the end of that line (it wraps) add a space and verbose noapic press F10 to continue boot

When installing from the DVD, press “Installation”.
The next screen will show a “Boot Options” field.

In the “Boot Options” field type: verbose noapic

Then follow the rest of the installation steps.

Good Luck!

I did what you suggested and still not getting bast the loading line.

OP - your symptom sounds like mine whenever I do an install or upgrade.

When you get to boot selection screen (Install, Upgrade etc), press F5 to change kernel in use from Default Kernel to Safe Mode. Then choose your install option. That loads a “minimal” driver set and the install UI will load after the progress bar completes. In my case, this does not affect the installation, after installation boot as normal and away you go.

Suspect that the standard install kernel does not support/understand my older graphics card, but once the kernel is complied during install, everything works.


F5 does nothing at the boot selection screen, it asks like the ESC button at the install loading screen though. I even tried disabling fast boot in bios which has something to do with minimal drivers none of which worked.

That depends on if you are installing in EFI or Legacy mode (MBR boot) if the install is booted in legacy you see the options with EFI boot you have to edit the boot script

press e then find line starting linux or linuxefi go to the full end of that line (it wraps) add a space and the new kernel parameters.

TO use fall back graphics add nomodeset

try also noapic this can be the problem on some notebooks

Did you check the hash sum on the ISO you downloaded? Do the numbers match?
Band ISOs give all sorts of problems.

Can you install in legacy mode? For the installation try safe mode and make sure that you have the CD/DVD as first boot in your bios.

If Leap doesn’t install, try downloading and installing Tumbleweed. It could be the kernel.

I got the installation working, using legacy boot and the verbose noapic command and safe mode in the installer, but i dont know how to configure my network…

It’s very easy.

Remember that the Yast Control Center is your friend.

Navigate to Yast->System->Network Settings
Click on the Global Options tab
Under Network Set Up Method, click on the dropdown arrow and select Wicked Service


Select the Overview tab, choose your device and click on the Edit button
Select the General tab

Under Assign Interface to Firewall Zone, select External
Under Set MTU, select 1500 (Ethernet, DSL broadband)

Click on the Next button and choose the Host/DNS tab
Type leap or whatever name you like in the Hostname field

Select Global Options tab and change Wicked Service to NetworkManager Service
Click on the OK button

You should see the NetworkManager appear in the systray.

If you right-click on the NetworkManager icon you can select Configure Network Connections to further tweak your settings.
However, Yast2 Network Settings is the main set up tool.

Follow Up

Back in Yast select Security and Users and **Firewall
**Click on Interfaces

You should see your ethernet or wifi device.
Ensure that they are configured for** External Zone**.
Sometimes the Interface Zone is set as No Zone Assigned

This can be easily changed by clicking on the Change button and selecting External Zone.

Additional support may be found on the openSUSE Support wiki

See: https://en.opensuse.org/Portal:Support


and https://doc.opensuse.org/