Unable to install Tumbleweed ("No data" screen)

Hi all,

I’m trying to install Tumbleweed but in any moment the screen turn black and it shows me the “No signal, entering the power saving mode” message.

I’ve tried with latest snapshots (20190201, 20190124, 20190108) and it’s always the same…

My graphics card is an NVIDIA 1060, could this be related to the ussue?


It might be. When the first openSUSE menu appears, with the highlight on “Installation”, strike the e key. Then move down where you see “quiet”, and append a space and nomodeset, then proceed and see if the black screen and no signal are avoided. If you see a green bar moving across the bottom of the screen, hit the escape key to see more information.

Thanks for the answer mrmazda.

When I edit the Installation entry, I get this. Do you mean I must append nomodeset after splash=silent in the linuxefi line?

setparams 'Installation'

  set gfxpayload=keep
  echo 'Loading kernel ...'
  linuxefi /boot/x86_64/loader/linux splash=silent
  echo 'Loading initial ramdisk ...'
  initrdefi /boot/x86_64/loader/initrd

Yes. It used to be that that line ended with splash=silent quiet. I didn’t realize it was changed. That’s the line to append nomodeset to.

Great!! It worked fine!!!

I just added nomodeset to de linuxefi line, as mrmazda said. and the installation ran perfect.

Thank you mrmazda for your help!!!

Now that the installation is complete, you should examine /etc/default/grub. You’ll probably find nomodeset included on the GRUB_CMDLINE_LINUX_DEFAULT= line. That will severely handicap performance of whichever desktop you are using, as it is intended to be a troubleshooting parameter. It blocks use of all competent FOSS DDX drivers appropriate for NVidia gfx hardware by disabling KMS (kernel modesetting). FOSS DDX drivers are named “modesetting”, provided by the xorg-x11-server package, and “nouveau”, provided by the xf86-video-nouveau package, and not to be confused with the nouveau driver provided by the kernel.

You should test by striking the e key at the boot menu as you did when installing, but this time, remove nomodeset before proceeding. If boot proceeds normally, excellent. After you login, open YaST bootloader, remove nomodeset, then save, to make the change permanent.

If it doesn’t, as when you got the black screen trying to install, we will need information to determine why.

I tested the system boot editing the Installing item and it was everything fine.

After that I edited the YAST bootloader to remove the nomodeset parameter and rebooted the system and I am now writing from Opensuse without problems.

Thanks again mrmazda for your help.

Excellent! And you are welcome!