Unable to Install Tumbleweed / Leap on Macbook Pro

Hi all,

This is a cross-post from the Install / Boot / Login forum, as I’ve been unable to fix the problem.

I’ve been unable to install both Tumbleweed & Leap on my Macbook Pro (mid 2010).

Process :

  • tried both NET installs & DVD
  • checksums verified ok
  • booting from USB (but also tried from DVD)
  • Choose install from the initial menu
  • Press Esc during install to show boot messages
  • Last message that I see is “Found a Linux console terminal on /dev/console”
  • Then a blank screen with a non-blinking cursor top left

The Macbook Pro currently has Fedora installed, and the iso’s work fine if run in Gnome Boxes.

The freeze seems to be just before it goes from a text to graphical environment, so it may be graphics related??

I’ve been doing some searching, and tried adding “nomodeset” to the install parameters, without success.

If any more information is needed, please ask.

Any help would be much appreciated.

Hi
I would guess so, just tried here with a MacBook3,1 (late 2007), this has an Intel X3100 GPU, booting openSUSE Leap 42.1 via USB proceeds to the graphical install (didn’t go any further as have SLED 11 SP4 installed) which is past the point you get too.

What is the system GPU?

Hi - thanks for the response.

So it’s got an NVIDIA GT216M [GeForce GT 330M].

(Currently working fine using the standard Nouveau drivers in Fedora).

Hi
Instead of nomodeset, have you tried;


nouveau.noaccel=1

I hadn’t - but just tried, and unfortunately no go.
(I appended it to the end of the linuxefi line - is this correct?)

My default installation parameters are :


set gfxpayload=keep
echo 'Loading kernel ...'
linuxefi /boot/x86_64/loader/linux splash=silent
echo 'Loading initial ramdisk ...'
initrdefi /boot/x86_64/loader/initrd

On Thu 10 Dec 2015 12:56:01 PM CST, vidlew wrote:

I hadn’t - but just tried, and unfortunately no go.
(I appended it to the end of the linuxefi line - is this correct?)

My default installation parameters are :

set gfxpayload=keep
echo ‘Loading kernel …’
linuxefi /boot/x86_64/loader/linux splash=silent
echo ‘Loading initial ramdisk …’
initrdefi /boot/x86_64/loader/initrd

Hi
Yes that’s correct. If you press the ctrl+alt+Fx (1-12) when it goes
black, do you get to a tty? Esp 10 which should show some kernel
messages?


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.51-52.31-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Hi,

No response with those keys, or various combinations thereof.

In fact the keyboard seems unresponsive.
For example - if I turn on the caps-lock earlier during the installation (which turns on its little light), it goes off when the black screen is reached, and doesn’t turn back on.
Not sure if that’s relevant.

Hi
The only other thing I can think of is acpi and maybe the backlight? Maybe try acpi=off as a boot option.

Success!! … Well partial anyway.

The graphical interface now loads and reaches the first screen : Language, Keyboard & License Agreement.

But the keyboard, trackpad and mouse are now all unresponsive.
Is there a way around this?

Many thanks for your help so far.

Hi
Try;


acpi_osi=Linux

and maybe add

acpi_backlight=vendor

Hi,

Adding one or both of those didn’t change anything.
(They were to be used in addition to acpi=off, correct?)

Still just getting to the first graphical screen with no mouse / trackpad / keyboard input.

Hi
No, instead of :wink: either one by itself or both…

Aahh I see.

Unfortunately If I use either of these, or both in combination, it stops at the same original black screen of death.

On Tue 15 Dec 2015 12:56:01 AM CST, vidlew wrote:

Aahh I see.

malcolmlewis;2742283 Wrote:
>
>
> >
Code:

> >
> acpi_osi=Linux
>
> and maybe add
>
> acpi_backlight=vendor
>

> >

Unfortunately If I use either of these, or both in combination, it stops
at the same original black screen of death.

Hi
OK, so lets try the following boot options (as in these only or
combinations);


noapic irqpoll acpi=force


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.51-52.31-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

No success with these unfortunately.
I tried individually and combinations.
Also combined with earlier options - no go.

Hi
Do you have the latest Tumbleweed iso image, maybe one of the live versions?

Else I think a bug report may be the best option.
https://en.opensuse.org/openSUSE:Submitting_bug_reports

Ok thanks for trying Malcolm - appreciate the help.