Unable to install sound.

Hello, I have installed suse linux 11.0 and I cannot seem to get the driver for my sound card install.

I have fixed several issues in regards to the kernel but there seems to be a problem with something else and I think this is the installer as right at the bottom is says

line 496: command not found
line 497: command not found

Both of these are related to the installer.

This comes up after the licence agreement so I know the commands I am using are correct as I am using the ones supplied with the driver.

Everything else seems to be ok, what can I do/check to fix this problem please?

I have looked all the way through the install software menu and can’t find anything there. Is there anything I can use to configure my sound card to with with suse linux?

If it helps I use a Sound Blaster xfi xtreme music sound card by creative.

Thanks

Hi
Open a console/konsole and ook at those lines in the installer file to
see what commands it’s trying to run?


less <full_path_to_install_file><name_of_install_file>

Page down to the line number indicated above (will be on the right,
bottom) and see what it is…


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 1 day 2:26, 1 user, load average: 0.10, 0.21, 0.31
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Hi there

On them lines its coming up as

make
make install

Thanks for the reply :slight_smile:

That sound device is not compatible with Linux:
Audio incompatibility list (with Linux)

not compatible :frowning:

Creative X-FI

I have just been looking through the link you sent me and it says that creative will be making a driver for linux so although I have the driver is it a case of yes I have the driver for my sound card but linux won’t be able to use it?

I’m just puzzled why creative would make a driver for a sound card that linux doesn’t support :frowning:

Although now I do have some good news, I should of tried this before I posted but I also have on-board sound aswell, I have just plugged this in and I can hear things :slight_smile: I would prefer it through my card but if thats not possible its not possible :slight_smile:

I’m new to linux so I am hoping I can teach my-self all the basics with a few books.

Thanks for the help, really appreciated.

Hi
You need to install the ‘make’ file which is part of the development
base.


sudo zypper in make

Now it could also ask for other files when installing, please accept
them. Now if there are still issues you may need to install the whole
development base;


zypper in -t pattern devel_basis

You can also do the above via YaST->software->software management, just
set the filter to ‘pattern’.


Cheers Malcolm °¿° (Linux Counter #276890)
opezypper in -t pattern devel_basisnSUSE 11.0 x86 Kernel
2.6.25.11-0.1-default up 1 day 4:22, 1 user, load average: 0.21, 0.24,
0.20 GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Cheers malcolmlewis

It came up with this

make: *** [all] Error 2
make: *** [install] Error 2

I know its not compitable with linux as oldcpu said but I know in odd times I have got none compatible devices to work with other operating systems so I gave this ago, I don’t know if the same rule applies to Linux though.

I think i’m out of options and will have to use my onboard sound :frowning: at least its sound of some sort though lol!

No, you are not out of options yet. (That link that you pointed to
says they expected to have it working late last year. So, maybe it
DOES work now.)

In all probability, your ‘error 2’ was because of missing prerequiste source
software. Try this in Yast->software:

Set filter to ‘pattern’ and go down and check ‘base development’ and
install all that, and then try your ‘make’ again.

Thanks for that, I gave it a go and it came up with the same error.

I don’t know if this will help but here is a log so you can see what I am seeing.

checking for built-in ALSA… no
checking for existing ALSA module… yes
checking to modify of kernel linux/kmod.h… no
checking for kernel linux/compiler.h… yes
checking for kernel linux/pm.h… yes
checking for kernel linux/spinlock.h… yes
checking for kernel linux/irq.h… yes
checking for kernel linux/threads.h… yes
checking for kernel linux/rwsem.h… yes
checking for kernel linux/gameport.h… yes
checking for kernel linux/devfs_fs_kernel.h… no
Creating a dummy <linux/devfs_fs_kernel.h>…
checking for kernel linux/highmem.h… yes
checking for kernel linux/workqueue.h… yes
checking for kernel linux/dma-mapping.h… yes
checking for kernel asm/hw_irq.h… no
Creating a dummy <asm/hw_irq.h>…
checking for kernel linux/device.h… yes
checking for kernel linux/platform_device.h… yes
checking for kernel linux/jiffies.h… yes
checking for kernel linux/compat.h… yes
checking for kernel linux/adb.h… yes
checking for kernel linux/cuda.h… yes
checking for kernel linux/pmu.h… yes
checking for kernel linux/moduleparam.h… yes
checking for kernel linux/syscalls.h… yes
checking for kernel linux/firmware.h… yes
checking for kernel linux/err.h… yes
checking for kernel linux/bitmap.h… yes
checking for kernel linux/mutex.h… yes
checking for kernel module symbol versions… yes
checking for PCI support in kernel… yes
checking for I2C driver in kernel… module
checking for firmware loader… module
checking for input subsystem in kernel… yes
checking for directory to store kernel modules… /lib/modules/2.6.25.11-0.1-default/kernel/sound
checking for ISA support in kernel… yes
checking for processor type… i586
checking for ISA DMA API… yes
checking for SMP… yes
checking for Video device support in kernel… yes
checking for strlcpy… no
checking for snprintf… no
checking for vsnprintf… no
checking for scnprintf… no
checking for sscanf… no
checking for vmalloc_to_page… no
checking for old kmod… yes
checking for PDE… no
checking for pci_set_consistent_dma_mask… no
checking for pci_dev_present… no
checking for msleep… no
checking for msecs_to_jiffies… no
checking for tty->count is the atomic type… no
checking for video_get_drvdata… no
checking for io_remap_pfn_range… no
checking for new io_remap_page_range… no
checking for kcalloc… no
checking for kstrdup… no
checking for kzalloc… no
checking for create_workqueue with flags… no
checking for saved_config_space in pci_dev… no
checking for register_sound_special_device… no
checking for RTC callback support in kernel… no
checking for HPET support… yes
checking for Procfs support… yes
checking for class_simple… no
checking for old driver suspend/resume callbacks… no
checking for removal of page-reservation for nopage/mmap… no
checking for nested class_device… no
checking for new unlocked/compat_ioctl… no
configure: creating ./config.status
config.status: creating Makefile.conf
make: *** [all] Error 2
make: *** [install] Error 2

Thats the last thing I come to in the installation process, also make is installed as I installed this.

Hi
Can you supply the download link for the file?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 1 day 6:25, 1 user, load average: 0.17, 0.11, 0.13
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

I certainly can, here you are :slight_smile:

Home - Open Source

Hi
Ok, as I don’t have a supported card it wouldn’t run the installer.
However I just bunzipped the file and ran configure, which completed ok.

Can you try that?


su -
mkdir build
cd build/
{copy XFiDrv_Linux_US-1.18.tar.gz to here}
tar zxvf XFiDrv_Linux_US-1.18.tar.gz
cd XFiDrv_Linux_US-1.18/
bunzip2 XFiDrv_Linux_US-1.18.tar.bz2
tar xvf XFiDrv_Linux_US-1.18.tar
cd drivers/
../configure


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 1 day 8:22, 3 users, load average: 0.12, 0.11, 0.09
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Hello

it says it cannot find the copy command so where would the build directory be located so I could just copy and paste into there.

thanks

Hi
Copy in linux is cp. If you did the commands it should be /root/build;


cp <from_wherever_you_have_the_file> /root/build/

The other way if you change to the build directory created is to use a
period (as in “.”) at the end, in that case it would be;


cp <from_wherever_you_have_the_file> .


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 1 day 19:44, 2 users, load average: 0.00, 0.01, 0.07
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Hello malcolmlewis

I did all that you have requested and I still have no sound though the card.

Will I need to re-run the installer again?

Thanks