Unable to install package - missing requisite

Running TW KDE Plasma with the very latest updates. I need to install the official get-flash-videos package but it fails with


Problem: get-flash-videos-1.25.92-1.3.noarch requires perl(:MODULE_COMPAT_5.26.1), but this requirement cannot be provided
 Solution 1: do not install get-flash-videos-1.25.92-1.3.noarch
 Solution 2: break get-flash-videos-1.25.92-1.3.noarch by ignoring some of its dependencies

I do have perl 5.26 installed but cannot find anything which satisfies the requirement. For now I have selected option 1.

Any ideas please?

Stuart

I have been trying to run the get-flash-videos version downloaded from github but that fails as well and am unable to install the needed perl packages via zypper. It seems like not all the perl packages are at the correct level. I have 5.26 installed but some packages will only install if I downlevel to 5.24 and that in itself is an issue as it either downlevels or removes a whole bunch of stuff. I’ll try to give some examples later when I have time. For now I have the downloaded version of get-flash-videos from github running now on my 42.3 laptop.

Stuart

File a bugreport agains the TW version.

On Mon 16 Oct 2017 09:26:02 AM CDT, broadstairs wrote:

I have been trying to run the get-flash-videos version downloaded from
github but that fails as well and am unable to install the needed perl
packages via zypper. It seems like not all the perl packages are at the
correct level. I have 5.26 installed but some packages will only install
if I downlevel to 5.24 and that in itself is an issue as it either
downlevels or removes a whole bunch of stuff. I’ll try to give some
examples later when I have time. For now I have the downloaded version
of get-flash-videos from github running now on my 42.3 laptop.

Stuart

Hi
Well the planned outage is probably part of the reason (and perl
rebuild), signers on OBS weren’t fixed till a short time ago so anything
in rebuild state (like the above package) doesn’t get published out to
the repos… give it another day or so and it should come right.

If you look at the build result here;
https://build.opensuse.org/package/binaries/openSUSE:Factory/get-flash-videos?repository=standard
The version is at 1.25.92-1.4

If you look here at the build result (the right hand list) and hover
over the icon (it’s a cog) on standard, it means a build job exists and
has succeeded. But still not published out to the repos…
https://build.opensuse.org/package/show/openSUSE%3AFactory/get-flash-videos

If you have an OBS account you can actually download direct (or via the
osc command).


Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.2|GNOME 3.20.2|4.4.87-18.29-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

I’ll give it a few days and see what happens. I now have a working version on my Leap Laptop which I can use.

Stuart

If you have continued problems, FYI I run JDownloader to download YouTube videos (mostly flash)
JDownloader also gives me full access to select from the various versions of the video that might be available, so for example the America’s Cup races generally provide approx 5 different video formats and an audio only file for each video.

TSU

Having done the very latest TW update this morning this issue still exists plus I am unable to install the package perl-Class-MethodMaker as it has not been updated for the latest perl level 0f 5.25.

I will create some bugs in buzilla for this.

Stuart

Done some more on this and I obviously had a ‘senior moment or two’ because I had a couple of repositories enabled which were causing me problems. I now have the downloaded version of get-flash-player working here on Tumbleweed as I was able then to install perl-Class-MethodMaker without any issues.

However that is not the end of the story as the official openSUSE package for TW will not install because nothing provides perl(Data::AMF) in the standard repositories. Adding devel:languages:perl will provide the required AMF but then I get another missing requisite of perl(:MODULE_COMPAT_5.26.1) which cannot be provided.

So the official package for get-flash-player will not install.

Stuart

Hi
So you have a few options, ping the get-flash-player maintainer with the issue and you and the maintainers look at getting the dependency into Factory/Tumbleweed?

Or just install the missing perl package only with a zypper in and let it switch and then disable the repo.

Just one question - how do I fin the repo which contains perl(:MODULE_COMPAT_5.26.1)? As I said the AMF thing is easy.

Stuart

Hi
The zypper command is your friend (it’s a pretty clever tool)…


zypper se --provides 'perl(:MODULE_COMPAT_5.26.1)'

S  | Name | Summary              | Type   
---+------+----------------------+--------
i+ | perl | The Perl interpreter | package

perl --version

This is perl 5, version 26, subversion 1 (v5.26.1) built for x86_64-linux-thread-multi

So your perl is 5.26.1?

Yes indeed that is my installed perl package. So why is it complaining it cannot be provided?

Stuart

Hi
Looks like it’s gone… and the ones there are only built against perl 5.24.1.

https://build.opensuse.org/package/show/devel:languages:perl/perl-Data-AMF

You need to ping the maintainers to find out why…