Unable to Install openSUSE 13.1 -- System freezes on first reboot

I’ve been trying to install 13.1 on a clean computer – by which I mean, no existing data or OS. This is the basic hardware:

  • AMD Phenom 9950 X4 Black Edition Agena 2.6GHz Socket AM2+ 140W Quad-Core Processor
  • G.SKILL 8GB (4 x 2GB) 240-Pin DDR2 SDRAM DDR2 1066 (PC2 8500) Dual Channel
  • Western Digital Caviar SE16 WD5000AAKS 500GB 7200 RPM SATA 3.0Gb/s 3.5" Internal Hard Drive
  • MSI K9A2 Platinum AM2+/AM2 AMD 790FX ATX AMD Motherboard
  • SAPPHIRE 100243L Radeon HD 4870 512MB 256-bit GDDR5 PCI Express 2.0 x16 HDCP Ready CrossFire Supported Video Card
  • SoundBlaster Audigy 2 ZS sound card
  • Asus DVDR
  • Hauppage WinTV HVR 1600 MC Model 1388

I’ve successfully installed 13.1 on two or maybe three other machines without problem, but this one fails in some way I don’t understand. The install process seems to run okay up to the point where you are supposed to reboot the system and let it finish up the installation routines. It cannot reboot. It gets as far as the green lizard screen and stops dead.

On the console, it seems to be running at least one maybe more traceback routines, but most of it scrolls off the screen. The last interesting line is:
9.214457 Fixing recursive fault but reboot is needed!

If left long enough it sometimes adds something about a USB port.

Another strange thing it does: if I boot into a rescue session from the install disk – and I haven’t been able to figure out how to do anything useful from there – when I attempt to shut down it goes into this strange looping behavior where it seems to be saying something about a USB port number X shutting down, followed immediately by several lines that seem to indicate that USB X+1 is now loading the Logitech optical mouse that’s plugged into the system. This sits for a long time, then that number shuts down and the next one (+1) registers the mouse. Over and over, I’ve seen the count go as high as a hundred and something.

I would give you the exact messages, but they’re a little tedious to copy in longhand.

I’ve seen some references to problems with this distribution related to the Radeon graphics driver, but I never get far enough in this process to do anything about that.

I would appreciate and suggestions to get this working,



I had the exact same issue. I ran out of time trying to figure it out, so I just went with OpenSuse 12.3. My hardware configuration is similar to yours:

ASUS M4A785TD-V EVO motherboard
AMD Phenom II X4 955 3.2 GHz Processor

Like you, I was doing a fresh install onto an empty hard drive.

Good luck - if you figure it out, let me know! :slight_smile:


Sounds like a video problem.

At reboot type a e to go to grub edit mode find line starting with linux. go to the true end of the line. it will be wrapped. (press end key is easiest) enter a space and nomodeset. press F10 to continue boot

If that works you will be using a generic driver so you will probably want to install the propritary driver for the video card/chip

If Intel video chip then run updates the driver that ships may be buggy for some cards the update correct that.

not sure if its related but on a clean openSUSE13.1-32bit-liveCD kde install
a similar event occurred

kdm was failing to load correctly

problem solved by changing the font, it had been set to sans serif by default,
booted 100% of the time after selecting DeyaVu Sans (preferred)
font changed in
-System Settings
–System Administration
—Login Screen
----General tab,
-----Fonts, all changed

NB 1. at first, a cold start was found impossible, warm start only successful after 3 or 4 attempts,
NB 2. failsafe start used a totally unreadable font in the terminal messages so could not be used

Thanks for the info on how to invoke the grub2 editor, I hadn’t known that.

Unfortunately, it doesn’t seem to work.

The last two lines of the boot sequence info read:

[number] Fixing recursive fault but reboot is necessary!
[number] usb 3-1: USB disconnect, device number 4

Does this mean anything helpful?


ALSO, is there anyway to capture the steam of console messages that are produced when I try to boot this system and it fails? There’s no obvious way to get them when the system freezes part way through. I’ve attempted to immediately reboot the machine using a USB live system (Linux Mint), and then mount the original root drive and, e.g. try to find a useful file in /var/log/ but nothing seems to be helpful. Is there any way to capture all the info that streams past the screen when I’m trying to start it?


Should be in the logs

On 2014-08-05 01:16 (GMT) gogalthorp composed:

> Should be in the logs

I don’t remember if this was new for 13.1, or since, but most logging is or
will be hiding in a binary blob that IIUC requires a running system to access
via journalctl (either booted or chrooted).

“The wise are known for their understanding, and pleasant
words are persuasive.” Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/

AFAIK 13.1 installs rsyslog by default, which will write all log messages to /var/log/messages and other (text) files in /var/log/.

the boot log is viewable with key sequence CTL-Alt-F10

key sequence CTL-Alt-F7 to return to the current display

key sequence CTL-Alt-F1, CTL-Alt-F2, … for terminal login

Yast in terminal mode will run from there with root login

if Yast can be run, select ‘Traditional Method with ifup’ in Network Settings,
if not already set, to get the network running before trying any updates/changes

The problem is that there are no key sequences that will do anything because the system is at this point frozen. Dead. Shuffled off this mortal coil and joined the choir invisible. Sort of thing. Which is why I was trying to access the boot log from outside, so to speak, using a LiveUSB system.


MSI motherboards (and mainly their BIOS) are notoriously bad with ACPI on non-Windows systems.

Have you tried booting with noacpi (add it to the linux line in the grub boot as you were suggested earlier to do something else)

Or try to boot to recovery mode (“Advanced Options” in the boot menu) for a start.

Btw, as I wrote, the kernel log messages should be in /var/log/messages, you should be able to look at that when booting from a Live system.
But be careful to not open the Live system’s log… :wink:

I had previously disabled ACPI in the BIOS in case of that. Would it make any difference to the kernel?


I will try that. If I recall correctly, the /var/log/messages file was some unreadable binary when I used the Live system’s text editor, but I can double check.


/var/log/messages should be a normal text file.
Maybe you opened one of the rotated files (/var/log/messages-yyymmdd.xz)? Those are compressed, and cannot be opened in a text editor directly.

No, I’m fair certain it was just “messages”. But I could be wrong, I’ll check at first opportunity.

I should have mentioned this to start, in case it’s a clew for someone. This exact system ran for a year or so without real trouble on an older Ubuntu release – Pangolin, as I recall – before I made the rookie mistake of trying to update it to maintain support.


Have you tried the “noacpi” boot option or recovery mode already?
If one of those would work, you could try to update your system, maybe the problem is already fixed.
There have been 3 kernel updates already for 13.1 f.e.

One thing I did try was to boot from a 13.1 network install CD and select update system – would that have the same effect?