Unable to install openSuse 11.0

Complete Linux newbie here so be gentle.

I have tried to install the latest OpenSuse 11.0 and have been unable to because when I get to the first “welcome” page, the install has not detected my usb mouse or ps2 keyboard. The system has an AMD x2 4600, a Winfast(Foxconn) motherboard (can’t remember what model), a Maxtor 160Gb sata drive and 2Gb of RAM.
Does anyone have any ideas as I have rebooted the system and not had any luck so far in getting past the “Welcome” screen

That’s a rare problem as far as I know. As a first make sure BIOS settings are not causing a problem & also make sure your BIOS has the latest flashed version.

Have you tried running the text install mode? (i think it’s under F3 at the first openSUSE boot screen).

Maybe others here have a better clue of what to do…


P.s. you might want to try to install using the LiveCD?

When you boot up the system there is key depending of you,re system when you hit it you get the boot up message of the BIOS.
Did it show you the keyboard and the mouse ?


Your first step is to check the BIOS settings. When the computer boots, there is a key to depress (usually DEL or an F key) that takes you into the BIOS setup program. Look for entries for the mouse and see if there is something like “legacy.” With the keyboard, make sure in the BIOS it is set to ps2 rather than usb. Also, are either of these devices non-standard, like wireless?

As a general (and gentle) newbie note, when it comes to diagnostics and repair, it is a very good idea to have a Live CD. I haven’t yet played with openSUSE’s, but I have used Knoppix for years. Knoppix is sort of the gold-standard for Live CD’s because of it’s superb hardware detection and because it includes just about every piece of software you might ever need. So . . . taking your problem, if you booted Knoppix and your mouse and keyboard work, you know that SuSE is having a detection or configuration issue that Knoppix is not. You can then look at what Knoppix did, and apply that information to SuSE. A handy tool to have around. Just fwiw . . . (it’s conceivable the SuSE Live CD could play the same role, but since Knoppix uses a different detection methodology and must be able to load a very wide variety of drivers, I’ve found Knoppix best for this particular purpose).

May I add some experience to that recommendation?

I recently upgraded my laptop (a several-years-old pre-Lenovo IBM ThinkPad) to openSUSE 11.0. I’d installed 10.2 from downloaded CDs on it a while ago with only one glitch (I had to make sure that I’d specified “acpi=off” when I ran the install program), but once I got past that everything went great.

openSUSE 11.0? Not so much. The laptop absolutely refused to install from the downloaded DVD (and there was no problem with the DVD–I’d used it a few hours before to update my desktop to openSUSE 11.0), even when I specified “acpi=off”. Playing a hunch, I downloaded and burned the LiveCD .iso, and it installed on the laptop just fine. The only “issue” I had was that I could only find a KDE 4 LiveCD image (and I prefer KDE 3.5 for now), so after installation I had to download and install KDE 3.5, but even that process went just fine (thank Ghod for fast 'net connections!).

Greetings from my new OpenSuse 11 box, wow, how much easier than m$ is that to install, a c.ouple of basic questions and BAM it just works, now time to play.

Thanks so much for all the help, great call Mingus, there was a setting in the BIOS that enabled usb keboard and/mouse.

So, much happier bunny now, as I said above, just going to play a while and see what I can do with this and about making the braek from uncle Bill (the wife may take some convincing though).:smiley:
Take care and see you guys around the next time I need help.


Congratulations for getting it all set up!

Just fwiw, my wife has been using openSUSE 99.999% of the time for abt two years now.

And one last comment since you’re new to openSUSE: If you installed with KDE 4.0, you might want to consider upgrading to 4.1beta. It has a lot more functionality and flexibility. There is a one-click install which will do the whole thing for you. There final 4.1 release will be late in the month.

Good to hear you’ve set it up! :slight_smile:

I second mingus725 in using KDE 4.1, check here for an easy upgrade : KDE/KDE4 - openSUSE ( Look at : UNSTABLE KDE Project (KDE 4.1.x) It’s called unstable as they are still developing 4.1 but you’ll have a better experience already compared to the 4.0.4 thats installed by default.

Cheers & hope you enjoy!