Unable to install Nvidia drivers

Hi guys, I’m new here. I decided it had to be done with Windows Vista, always the same boring desktop, always having to buy or download my software, and some ppl told me Suse was the best choice if you wanted to be able to play games under Linux (for me, mainly WoW).

I did a clean install, and immediately found my first challenge:

Installing my graphics driver. I have a Geforce 8800GTS with 2 screens connected, one HP L2045w 20" Widescreen, 16801050, and a secondary one, a Philips 190x 19" Normal screen, 12801024.

I am able to give the first screen its native resolution, but the 19" keeps acting as a clone, while I want an extended desktop. Ofcourse, for this and to play WoW, I need graphics drivers.

I downloaded some .pkg2.run file from the Nvidia site, which should be the driver package I need, but I cannot figure out how to install it.

Also, I found (on this site) a ‘one click install’ for Nvidia cards, but that install won’t work. During the install it comes up with a fault saying it needs a dependancy (or sth) which can’t be provided, see screenshot below. I can choose either of 3 options, but it won’t work anyway, it will revert to the package manager and when I want to close that it warns me that changes won’t be saved - only, it won’t show the ‘apply’ button so there is nothing to be saved!

It’s been 2 days now and I haven’t got the slighest clue what to do. Please help :frowning:



I already tried removing the Nvidia repository before install, which results in the ‘one click install’ just reinstalling the same repository again. Also, the resolution icon in the bottom left corner of the screen keeps reporting that my screen is running 12801024, even though it’s actually running both screens at 16801050, which is evident by the fact that the right screen is only displaying a part of what the left one is showing.

Have you installed the nvidia driver via 1-click? If not I recommend
the hard way, else follow the easy way here;

This is my canned response for doing it the ‘Hard Way’ :slight_smile:

If you have installed nvidia rpms via the easy way, I suggest removing
the downloaded rpms, and disabling the nvidia repository first.

You can download the driver for your arch from;
Nvidia Unix Drivers

On the download page, check that your card is supported by the driver
your about to download by using the following command;

/sbin/lspci -nv |grep VGA |cut -f4 -d ":"

From the above output use the four numbers from the output to look
at the Supported Products List (on the left) to verify your card is
supported by the driver.

For downloading the current version 177.80 (Note the wget and url are
all on one line)

for 32bit;


for 64bit;


You may wish to ensure your system is up to date. The first command
refreshes the repositories, the second lists any updates, the third
will apply the updates.

sudo zypper ref
sudo zypper lu
sudo zypper up

NOTE: If the kernel updated, please reboot before continuing :slight_smile:

If you don’t have the kernel source and tools etc installed then

sudo zypper in kernel-source linux-kernel-headers kernel-syms
sudo zypper in -t pattern devel_basis devel_C_C++

Press ctrl+alt+F1 and login as your user :slight_smile:

su -
init 3

cd to the Nvidia Unix Driver you downloaded

sh NV*.run -q
sax2 -r -m 0=nvidia
init 5 && exit

The ctrl+alt+F7 gets you back to the GUI (X session).

Now after a kernel update, you don’t need to run the sax2 command, just
the others to get to run level 3, rebuild the driver and exit.

PS, this should probably have been posted in the hardware forum…

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 16:05, 1 user, load average: 0.18, 0.06, 0.07
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Ok first of all, a big thanks. I hadn’t the slightest clue (and now slightly less of no clue at all) on what you proposed, but it worked and it seems to have installed my graphic driver. I think the fact that my windows can now get ‘squishy’ while moving them around and the checkbox ‘use 3d acceleration’ has become available and activated.

Now for the dual screen setup.

When I want to use the xinerama config, I get the following:


It effectively activates the dualhead config, but crams it all into my first display, making me having to scroll from left to right to view 2 screens on one. The second display is on standby, not receiving any signals.

Also, when I do that, the main screen reverts to 12801024 resolution, making everything big and stretched. When running just a one screen config, which I have right now while typing this, I get a normal native resolution of 16801050 on this display.

Also, I keep getting the occasional fault, like this:


I don’t know if that has anything to do with it. For clearance: I have a 20" and a 19" normal TFT, in normal mode it uses the native resolution for the 20" wide, in dualhead Xinerama config it forces 2x 1280*1024 to both screens but displays them both on the 20", not using the 19". I hope I’m making this a bit understandable for you guys :slight_smile: Is there another way besides Xinerama to do this? I would very much like to use the second display, as I like to browse or watch tv on that display while playing WoW on the first.

As you can probably notice am quite a newbie at this, that is, I think I understand a bit what Linux is about, but I grew up with Dos & Windows and didn’t know any better for the larger part of my life :slight_smile:

See there is a checkbox to “Activate Dual head Mode” Select that
checkbox and configure your second monitor.

Note you need to do this from the init 3 command (runlevel 3) and re
run sax2 -r -m 0=nvidia command again.

You might also try just using the default resolution for each monitor
eg LCD 1280x1024@60Hz and don’t forget to set the aspect ratio, refresh
rates (see your monitor manaul) and physical screen size.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 21:37, 4 users, load average: 0.42, 0.12, 0.05
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

When I select that checkbox, and press configure, all the settings are allready filled in. It says my second monitor will be driven at 1280*1024, nevertheless it sends both signals to my first screen, making me have to scroll from left to right :slight_smile: as seen in my first screenshot in my previous post. It does do dualscreen, only it won’t actually display it across both screens :slight_smile:

I have to find some way to tell Suse that I actually have 2 physical displays and that he has to drive them both at their own respective resolutions, but ever since I installed the Nvidia driver it won’t use the second one anymore. (previously it would just automatically clone them)

If I go to runlevel 3 and then reconfigure, run the sax command again, and back to runlevel 5, how will this change that?