Unable to install megasync

HI,
I tried to install MEGASYNC on my Tumbleweed in every way.
By downloading the app from the official website.
By downloading the package from “openSUSE Software”.
But it doesn’t start.
When I start from the terminal I get the error:
megasync: error while loading shared libraries: libicuuc.so.73: cannot open shared object file: No such file or directory.
Some libraries are missing that I can’t find.
Help.
Thanks in advance.

Megasync depends an outdated libraries which are no longer available. The package is broken and does not build for any actual openSUSE distributions.
But Megasync is available via flatpak…

thanks Hui,
I installed Megasync from flatpak and everything went fine.
But after starting it it crashes if I try to change the settings.

Hm, on my pc running Tumbleweed Megasync works just fine. I got it from

It requires no longer available libraries on an up to date Tumbleweed…

tumblevb@test:~> LANG=C wget https://mega.nz/linux/repo/openSUSE_Tumbleweed/x86_64/megasync-openSUSE_Tumbleweed.x86_64.rpm && sudo zypper in "$PWD/megasync-openSUSE_Tumbleweed.x86_64.rpm"
--2024-06-14 21:35:01--  https://mega.nz/linux/repo/openSUSE_Tumbleweed/x86_64/megasync-openSUSE_Tumbleweed.x86_64.rpm
Resolving mega.nz (mega.nz)... 31.216.144.5, 31.216.145.5, 2a0b:e46:1:145::5, ...
Connecting to mega.nz (mega.nz)|31.216.144.5|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 122410380 (117M) [application/x-rpm]
Saving to: 'megasync-openSUSE_Tumbleweed.x86_64.rpm.1'

megasync-openSUSE_Tumbleweed.x86_64.rpm.1                           100%[=================================================================================================================================================================>] 116.74M  6.98MB/s    in 17s     

2024-06-14 21:35:18 (6.87 MB/s) - 'megasync-openSUSE_Tumbleweed.x86_64.rpm.1' saved [122410380/122410380]

[sudo] password for root: 
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: 1: nothing provides 'libicudata.so.73()(64bit)' needed by the to be installed megasync-5.2.1-4.1.x86_64
 Solution 1: do not install megasync-5.2.1-4.1.x86_64
 Solution 2: break megasync-5.2.1-4.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c/d/?] (c): 


https://software.opensuse.org/package/libicu73

Responsible and experienced users don’t recommend (potentially unsafe) home repos with outdated libraries…

Thanks to tos4ever.
Installed megasync app+libicu73 now everything works.
Problem solved.

I only gave a possible solution to the problem. It is up to the OP to decide whether he/she wants to take the risk (if any) of using possible unsafe repos.

1 Like

https://software.opensuse.org/package/megasync

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.