unable to install Java

Hi all,

I’m an absolutely new user.

I use openSuse 11.1 64 bit with FireFox and want to install Java.
I go tho the Sun-site and have the choice between :

two Linux RPM files and two non-RPM files.

I can download them onto /usr/java

Then I want to use the YAST-software installer, but I do not know how to install it from Sun nor to install it from the software-manager.

Surely there must be a relatively simple way to do it .

Any help would be greatly appreciated.


There are already pre-packaged versions available via YaST Software
management. Just search on Java, 1.6 is there…

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 7 days 2:35, 2 users, load average: 0.07, 0.08, 0.05
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

> Any help would be greatly appreciated.

as malcolm said already, but let me expand…as “an absolutely new
user” you need to try to FORGET how it worked in another system…

that is, do NOT go to Sun and download…instead always open YaST and
search in Software Management first…if you can’t find it there, then
ASK…it is much easier to tell you where to go next than try to fix
what you might kill by experimenting…

lets face it, you have a LOT of learning to do if you are gonna make
it here…

so, read some basic info like:

and do not assume that anything will magically be fixed just by
rebooting, or reinstalling–yes, i know that is routine with some game
systems on the market…the thing is that Linux is pretty stable and
predictable and if it was broke a reboot is not likely to fix it…

also, don’t think something will by magic be ok if you log into
KDE/Gnome/etc as root…do not do that, it causes more problems than
it ever fixes…read more on that here:

oh, WELCOME to freedom, and Have a lot of fun!


I tried to do it via YAST. Apparently the JAVA that has been packed with openSuse 11.1 seems to be outdated. In fact I have to use it with my internet banking.

I always get the message : you are using Java version 1.6.0_0. Please upgrade to Java 6 update 7 or newer. So this is what I want to do.

I tried it with the URL on which these Linux versions have been placed, but to no avail. I downloaded the RPM.BIN’s (32 bit version and 64 bit version) to my hard disk and then tried to install via YAST software updater, but this does not work either (or I do not know how to do it). I followed the Sun How-to even to chmod the files, but this does not help me.

So I get stuck …

Thanks for your answer,


By the way, I use GNOME.

I’m assuming on web pages? Have you installed the sun java plugin? Or
what do you get in firefox about:plugins?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 7 days 3:45, 2 users, load average: 0.06, 0.10, 0.13
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

What is the output when you enter these commands in a terminal?

java -version
ls -l /usr/bin/java
ls -l /etc/alternatives/java
ls -l /etc/alternatives/javaplugin

Indeed, it happens on the login page, so I can’t login under Linux.

Have I installed the Java plug-in ? Where should I do it ? I’ll verify FireFox for its plug-ins and come back to you.


java-version :
bash: java-version: command not found

ls -l /usr/bin/java:
no such map

ls -l /etc/alternatives/java:
lrwxrwxrwx 1 root root 41 nov 28 16:43 java -> /usr/lib64/jvm/jre-1.6.0-openjdk/bin/java

ls -l /etc/alternatives/javaplugin :
lrwxrwxrwx 1 root root 59 nov 28 16:44 javaplugin -> /usr/lib64/jvm/jre-1.6.0-openjdk/lib/amd64/IcedTeaPlugin.so


Hello sir,

I indeed find this pages very interesting, but is there a way to print them so I can read this very important information at ease ?

Thank you,


java -version :

java version “1.6.0_0”
OpenJDK Runtime Environment (IcedTea 1.6.2) (suse -0.1.1-x86_64)
OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)

Try this:

  1. Go to Yast
    2.In search type “java” without the quotes
    3.In the Pane on the right scroll through the list until you get to 2 items that read as such:
    4.check the box on both click Accept
    Let yast do its thing & if all has gone well you will have Java!
    Let us know how this works for you OK!?!

Thank you very much. With your help I succeeded to install these Java programs.
I keep on getting the same error though : Please upgrade to Java 6 Update 7 or newer.

Weird, very weird …

Is there no later version then 1_6_0 ?

I can’t find it.


wba wrote:
> I indeed find this pages very interesting, but is there a way to print
> them so I can read this very important information at ease ?

sure, use a printer!

now, back to your banking problem…i can tell you that MANY bank’s
systems are so tightly setup for security reasons that they will only
serve Windows machines…

i know that is a problem in Denmark (for example) and i believe i
remember another user here somewhere else in Europe also finding it
impossible to get their Linux to work with their bank’s software…

i know i changed banks because i found it completely impossible to use
my fully updated Linux with Den Danske Bank…then, about two years
later my new back ‘upgraded’ their security and suddenly i was also
getting messages that i had to upgrade my java…which was
impossible…i called the bank, told them the problem and they said
they knew that my system would not work with there system so they sent
me a one time use code sheet…so now i sign into the bank with my ID
and password and then the bank’s system sends me a four character
code, which i look up on my code sheet and reply with the single use
response for the code they sent…

works great…

and, two years ago a friend of mine who was a long time user of Den
Danske Bank switched to Linux and found she couldn’t access the
accounts…but, now they gave her a little electronic thing that she
types the code the bank sends, it gives her a reply to send back, and
she is in…

the bottom line is: call your bank and tell them you do not use
windows and their security has locked you out, what can you do…other
than go back to Windows…unless THEY buy you a windows machine :slight_smile: or
change banks…


OK, sir. I’ll post them a message.

But in the meantime I do not understand why I can’t install this more recent version.

Thank you,


I think it is because Icedtea is used as the preferred OS interface.