unable to install "FlasPlayer"

i’m trying to install Adobe Flashplayer under root and i gery the message :
Authorization failed"
Can somebody help me?
thnaks in advance

try using YaST, it should be in the repo list


thanks but it doesn’t work
flash okayer and plugin 9.0 seems to be installed but in fact not
i tried to reinstall without any result
what can i do?

i don’t understand!
flash is working under another user without any specific right and i can’t install it under root

openSuSE has Flash installed by default. For example if you use KDE 4.x and try youtube in Konqueror it will work.

Firefox is a different story as for some reason it looks in the wrong /dir for the plugin. (or points to) and I have never been able to correct this.

I have tried in so many ways and wasted such a lot of time… here is the fast way: download and extract/install Firefox in its own /dir folder. Example download it to /home/mehappyuser/Firefox30 put the plugin named libflashpayer.so in the folder /home/mehappyuser/Firefox30/plugins and you are good to go !

I changed the desktop icon and had it point to, again, /home/mehappyuser/Firefox30/firefox and I have been happy ever since… :wink:

Many thanks!!!
it works

Remember that Firefox was first developed for windows and hence will run autonomously from it’s own /dir.

(open)SuSE has tried to turn it GNU/Linux, without succes. Flash & Java should just work OotB. period.

I read that several developers are turning their backs on GNU/Linux, as after all these years, the main question is still: “How can I turn on sound in my xyz distro on my abc PC ?”

I have been using SuSE since 2001 and each time I install a new version, I need to get the codecs and other sht, before I can start working, however I do it on autopilot these days. New users will think: "Sht, this GNU/Linux is for geeks, doesn’t work, is difficult, not usable, unstable, how happy I am to still have my XP or Vi$ta DVD".

Like that. It is a shame !!

Well, if you have been using SuSE for seven years, then you know the reason why it can’t include some of the proprietary, closed-source codecs that you are referring to. Maybe informing some of the new users before hand will enlighten them; I know it has for those that I have told, and then installed the software for.

And just FYI, I have installed openSUSE 10.1, 10.3, and 11.0, and each time Firefox worked ootb for me with regards to flash. I did, however, select it during the install when prompted to. I don’t know what has prompted your (and the OP’s) problems, and I am glad you fixed them, but it has nothing to do with the original development platform, even if it is Windows.

Sure I know, it is legal here to download install and use the codecs. But it is not legal in the USA so I should suffer ? Explain… pls, why ?

I have done many installs over the years, but never have I been prompted with the question if I wanted to install Flash or Java or codecs.
Do you have a screenshot of that ?

Sure, since my kids aren’t asleep yet, I’ll grab one or two for 'ya.


The first one shows the installation settings from the 11.0 DVD, and if you look down, you can see “Java …” and “Misc. Proprietary packages”. Just since you probably still don’t believe me, here’s a second that you can get if you hit “details” after selecting to change the default software choices (but note that I didn’t change any of the defaults when there).


And those have been there since at least 10.1.

Anyway, a majority of the codecs aren’t illegal, and most can be used freely, which is why some other distros package them in, and then we get posts here like “distro xyz r0xs cause they have dadada by default”. Notice I don’t say all codecs are legal, just most, and some other distros feel perfectly fine trying to navigate the mine field that exists with unenforced patents (see mp3) or closed-source code (see atheros drivers, although not a “codec”, they fit the argument). So I guess the point is that I don’t have to suffer, but I do slightly, and flash/java aren’t part of the suffering.

Note to all: in the preview of the post, it appears that my images are huge. I am not sure how to scale them down at the moment, and I’m not going to try to figure it out, although if someone wants to educate me, that would be fine.

Thanks wnj92996
But uhhh you prove my point, flash & Java are installed by default and one is not prompted to install them (separately).
This is how it should be, the same goes for the ‘codecs’.

For some reason when I do an install as from openSuSE 10.2 Flash works in Firefox but just once or untill I install something else (extentions ?). My solution is to put Firefox in its own /dir/folder add the libflashplayer and this has worked ever since (10.2 - 10.3 - 11.0).

As for the codecs … if I remember correctly they were installed by default untill Novell bought SuSE. Or at least they were in the official repository.
Anyway codecs should be in all distro’s. The whole issue is US patents, a broken system that has nothing to do with us, the rest of the world :wink:

Maybe its an add-on you apply to firefox? As a 32-bit user, I’ve never had a flash problem with firefox, and I have done nothing special.

To my recollection (possibly since SuSE-7.3), Packman have always provided the codecs, and I don’t believe this remembrance of “until Novell bought SuSE” to be accurate. What DID change after Novell took over (as part of openSUSE-10.1) was that proprietary drivers were dropped and “SuSE” changed to “openSUSE” to reflect “open source” having a high importance in the openSUSE distribution.

I don’t believe the US is the only country … and I think the US is too large to be ignored … Anyone who has been using a distribution for a short time typically has no problems with codecs, … its only the newbies who struggle … and efforts are being made to try make that easier.

On an off topic subject, if you want to see something funny, you should see me struggle and fume with MS-Windows codecs … (probably a direct result of my using Linux as my primary home OS since 1998, missing out on the home experience with Win98, 98SE, 98ME, XP and now Vista, so when I do go in those OS, I’m a frustrated user).

Guess I misunderstood you. When you referred to wanting them to work “out-of-the-box”, and then asking for a screenshot of them being offered at install time, I thought you were stating that they weren’t being offered…which I thought was a pretty fair interpretation of your statements, but whatever…guess I was wrong.

As oldcpu states, the entirety of the problem does not rest on the US, although they do screw it up pretty badly. Hopefully the situation will get straightened out in the next 5 years or so.

Flash works out of the box with every openSUSE install I’ve ever tried.

For a good understanding, Flash has always worked for me in Konqueror, Firefox is the troublemaker.
Another strange habit of Firefox is that whenever I install/update/upgrade anything through YaST Firefox crashes…

To clarify, Java and Flash are proprietary packages that openSUSE is distributing with permission. They are included in the non-OSS repository because they are non-OSS. But both Sun and Adobe have approved Novell/openSUSE distributing their products on their behalf.

The codecs are a separate issue. It’s not an issue of distribution rights. It’s an issue of patents, and royalty payments. I won’t argue the merits of software patents, since I don’t believe there are any. But they exist, regardless.

It’s not just the US that exerts patent influence. Countries like Germany were exerting judicial influence over MP3 patents, for instance, and prohibiting unlicensed players. The whole thing is a mess right now, and while various governments sit around scratching their heads on how to address the problem, it puts commercially-backed distributions at a disadvantage.

Sure, there are distros that distribute codecs and such, but they are community efforts that don’t present a realistic target for litigation, or they are distros like Linspire or Turbolinux that have obtained the proper licensing.

Anyways, to the original point, Flash and Java availability have nothing to do with codecs. It’s a completely different topic.

Just my 2c…