Unable to install cclive - dependency hell

I have a default and updated KDE openSUSE 12.1 installation and the community codec packages.

zlinux-cmbm:/usr/lib # zypper install cclive
Loading repository data…
Reading installed packages…
Resolving package dependencies…

Problem: nothing provides libquvi0 >= 0.2.0 needed by cclive-0.7.8-1.1.i586
Solution 1: do not install cclive-0.7.8-1.1.i586
Solution 2: break cclive by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):

I tried option 2 but it still complains about missing libquvi library. Installing libquvi6 and lua did not help.

Weird. I used this http://software.opensuse.org/ymp/openSUSE:Factory:Contrib/openSUSE_12.1/cclive.ymp?base=openSUSE%3A12.1&query=cclive , installs straight away. Where did you get the package from? BTW the one-click doesn’t care about 32/64bit , it will install for your architecture.

Report the problem in https://bugs.links2linux.org/

Installing via the link seems to work but:

arcabela@linux-cmbm:~/Videos> cclive <youtube_url>
[1] 4040
[2] 4041
[3] 4042
[2]- Done list=UUtez7sR636aZSQ-oigV0ZIQ
[3]+ Done index=1
arcabela@linux-cmbm:~/Videos> libquvi: error: lua util scripts not found

[1]+ Done cclive <youtube_url>
arcabela@linux-cmbm:~/Videos>

Thanks for the help. I will file the bug as indicated

https://bugs.links2linux.org/browse/PM-22

The bug report has been marked as “Resolved”.

How is the new package distributed? Do I wait for its release with the next batch of fixes?

The cclive appears to have been updated.

arcabela@suse:~> zypper info --requires cclive
Loading repository data…
Reading installed packages…

Information for package cclive:

Repository: Packman Repository
Name: cclive
Version: 0.7.8-2.1
Arch: i586
Vendor: PackMan :: Startseite
Installed: Yes
Status: up-to-date
Installed Size: 428.0 KiB
Summary: Command Line Video Extraction Utility
Description:
cclive is a command line video extraction utility similar to clive but focuses
on low requirements. Its features are few and essential.

cclive is intended for users who prefer lightweight and “snappy” programs. It
was written in C and depends on libcurl. cclive sports much of the same
features but some compromises were made along the way to keep the
prerequisites low.
Requires:
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.4)
libpthread.so.0
libpthread.so.0(GLIBC_2.0)
libstdc++.so.6
libstdc++.so.6(GLIBCXX_3.4)
libstdc++.so.6(CXXABI_1.3)
libgcc_s.so.1
libgcc_s.so.1(GCC_3.0)
libstdc++.so.6(GLIBCXX_3.4.9)
libgcc_s.so.1(GLIBC_2.0)
libstdc++.so.6(GLIBCXX_3.4.11)
libstdc++.so.6(GLIBCXX_3.4.15)
libcurl.so.4
libboost_system.so.1.46.1
libboost_filesystem.so.1.46.1
libboost_program_options.so.1.46.1
libpcrecpp.so.0
libquvi.so.6
libquvi.so.6(VER_0.1.0)
arcabela@suse:~>

I would like to report that cclive only worked after I also installed quvi, even though it is not listed as dependency.

Do it -> https://bugzilla.novell.com/

The problem is in the quvi package. Ask its maintainer to make libquvi6 require quvi.