Unable to install ATI driver in openSUSE 11

while installing, its generatng an error file which contains package generation has failed…no other details… I have tried many ways of installation…

from the ati website i found the reqmnts as given below…

POSIX Shared Memory (/dev/shm) support is required for 3D apps

glibc version 2.2 or 2.3

Linux kernel 2.6 or higher

XOrg 6.7, 6.8, 6.9, 7.0, 7.1, 7.2, or 7.3

how do I check this???

How to page
ATI - openSUSE

I’ve been refering the same link… since I don’t have an internet connection at home, I downlaoded the ATI driver for Linux from ATI website …

Did you have a look at the instructions for the installer?


There’s a bunch of other programs that have to be installed before the installer will work:

The following packages must be installed in order for the Catalyst™ Linux driver to install and work properly:

* XFree86-Mesa-libGL
* libstdc++
* libgcc
* XFree86-libs
* fontconfig
* freetype
* zlib
* gcc 

You can insert your install disc and then go into Yast and search for each one and and install it (some don’t exist in Suse) or, an easier method is to go to YAST and go to the drop down menu that says “Filters” and choose “Patterns”. Then check the box that says “Linux Kernel Development” and install those packages from your install disc.

Either way you choose, the installer will run properly once you do that.

Also keep in mind there are two ways to use the installer, you can have it generate a driver in RPM from for you or you can use the “automatic” install. I prefer the “automatic” install.

Finally, when the installer is done, be sure to run this command from the terminal

aticonfig --initial -f

Once you reboot the driver should load, To check 3d acceleration run this command


You should get spinning gears, but if not, there is still some problem with the configuration. Good luck!

The download should work. Make sure you first uninstall/remove all the ATI related items, reboot and retry.
There are different ways to remove the drivers, as described here you should be ok: ATI - Prepare kernels for new Drivers
Then reboot and install by running the driver script.

A couple of questions to get us in the right context:

-What version of openSUSE are you running?

-Is it 32 of 64 bit?

-Have you checked that all packages mentioned ATI - openSUSE have been installed?


openSUSE 11.0… 32 bit…

I didn’t check that… Can I find those packages in openSUSE DVD it self??

You can use YaST > Software Management

There you can use the search function and by searching for each package ( e.g. kernel-source , qt3, gcc , …) you can see if the package is installed on the system, or is still available to be installed. If it’s not installed, tick/select it to be installed and then search for the next package. At the end you can apply what you have selected to install all at once.

After that you can retry the cleanup of ATI drivers and reinstall.

thanks guys…let me try and I will let u know the results…

problem solved by installing all packages… another problem I have is with my ALPS touchpad …its too slow and not detecting any double taps… is der any driver that needs to b installed??

Good you got that going! :slight_smile:

The touchpad should have the correct driver installed. Which DE are you using (GNOME, KDE 3 or 4, ?)?

I have KDE 3.5 and 4.0 installed… my laptop is a Dell studio 15 …

problem solved… added a maxtaptime entry in /etc/X11/xorg.conf…