unable to hear sound

hi everyone
im using Dell studio laptop and using suse 10.3 os
im unable to hear the volume.
when i checked with gstreamer
there plugin - autodetect
Device - unsupported
pipeline - autoaudiosink

do i need to install or configure anything
please let me know
any details regarding this is greatly appreciated

Dependant on the Dell Studio laptop, its possible your kernel is too old to support the laptop and an update to a newer version of openSUSE may be your only solution. …

However, to check out if that is the case, we need more information:

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Try those speaker-tests as both a regular user, and with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-10.3, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and copy and paste the following into that terminal/konsole

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh

The second time that will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation (as opposed to a guess).

You also could try working your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

i am using sled 11 and i am having the similar porblem.

it shows sound card is detected but unable to here the sound.

i did the sound test u stated above. i got no sound and the out

was as below

anthosh@linux-k0en:~> speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.18

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 262144
Period size range from 32 to 131072
Using max buffer size 262144
Periods = 4
Unable to set hw params for playback: Invalid argument
Setting of hwparams failed: Invalid argument


santhosh@linux-k0en:~> speaker-test -c2 -l5 -twav

speaker-test 1.0.18

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

Playback open error: -111,Connection refused
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

Playback open error: -111,Connection refused
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

Playback open error: -111,Connection refused
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

The one was repeating.

now the out puts of ur commands i am showing below

Your ALSA information is located at http://www.alsa-project.org/db/?f=609e6a6725712a67225d45afeae6c8dbbd54f26b

Please inform the person helping you.

santhosh@linux-k0en:~> rpm -qa | grep alsa

santhosh@linux-k0en:~> rpm -qa | grep pulse

santhosh@linux-k0en:~> rpm -q libasound2

santhosh@linux-k0en:~> uname -a
Linux linux-k0en #1 SMP 2009-02-28 04:40:21 +0100 i686 i686 i386 GNU/Linux

santhosh@linux-k0en:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

I have to run to work, and can’t reply in detail now. You might have better luck if you start a new thread and put “unable to heard sound in SLED” in the title.

I note your PC has an IDT 92HD73C1X5 on SLED-11 with the kernel. Is that the default kernel with sled? Is it an updated kernel that one can get with SLED? Did you try any model options to force the alsa configuration upon boot? Also, IDT 92HD73C1X5 can be tricky to get to work as it is fairly new.