Unable to get wireless working

Suse 12.1, Netgear 614 router, Netgear WG111v3 adapter, dual boot Vista. I have got the driver with ndiswrapper from Vista, have the firmware, have Networkmanager installed. Yast shows driver installed. WEP set up. Networkmanager says "Connected to network “Home” signal strength maxed. It will ping the router but nothing else. I just stumbled my way through Yast. I’m sure it’s set up all wrong. Networkmanager also displays “Access Point UNKNOWN”.

I think I’m close to getting it work but I don’t know how to set up Yast “network device” and other settings. Appreciate any help.

Here is a reply from “/usr/sbin/iwlist scan”

linux-wt4o:~ # /usr/sbin/iwlist scan
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:22:3F:32:15:F6
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=70/70 Signal level=-38 dBm
Encryption key:on
ESSID:“Home”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s
Bit Rates:9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=000000051a2bb181
Extra: Last beacon: 275ms ago
IE: Unknown: 0004486F6D65
IE: Unknown: 010882848B960C183048
IE: Unknown: 03010B
IE: Unknown: 2A0100
IE: Unknown: 32041224606C

Results of “/usr/sbin/iwconfig”

linux-wt4o:~ # /usr/sbin/iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:“Home”
Mode:Managed Frequency:2.462 GHz Access Point: 00:22:3F:32:15:F6
Bit Rate=18 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:1A64-8C9F-E2
Power Management:off
Link Quality=70/70 Signal level=-18 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:1 Missed beacon:0

/usr/bin/lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0846:4260 NetGear, Inc. WG111v3 54 Mbps Wireless [realtek RTL8187B]
Bus 001 Device 003: ID 03f0:5d11 Hewlett-Packard PhotoSmart C5200 series
Bus 001 Device 005: ID 058f:6377 Alcor Micro Corp. Multimedia Card Reader
Bus 002 Device 002: ID 0461:4d63 Primax Electronics, Ltd

Is it really necessary to use ndiswrapper with this
HCL:Network (Wireless) - openSUSE

I don’t know. That’s what I read I should do. It doesn’t work anyway. I’ve read so much in the past couple of days my eyes are crossed. I still can’t get it to work.

I can tell you that I have seen recommendations to use the v.2 of that device
USB Wireless Device that works OOTB?

They do work
But I have devices that work better
Tenda Wireless-N150 USB Adapter | Ebuyer.com

Sometimes it’s just not worth messing with stuff that doesn’t work well

It has the same driver. It works on 3 Windows computers, 2 XP and Vista. If I thought it would make a difference I’d buy a different one. My Network Manager says I’m connected to “Home”, signal “Ultimate” but it won’t ping anything. I don’t have a clue how to set it up in Yast.

It has the same driver. It works on 3 Windows computers, 2 XP and Vista
So.

See post #6

On 11/28/2011 02:56 AM, caf4926 wrote:
>
>> It has the same driver. It works on 3 Windows computers, 2 XP and VistaSo.
>
> See post #6

The lsusb scan shows the device to be an RTL8187B. Those devices have worked
“out-of-the-box” since kernel 2.6.30, or so, it needs no external firmware, AND
your device is in the tables. I have no idea why it failed for you. Perhaps your
messing with ndiswrapper screwed something up.

I deleted ndiswrapper and WG111 from Network Devices and rebooted to clean everything out. It found the adapter and loaded the driver. Still won’t work. I’m not thinking it’s a hardware issue, I’m thinking I’m not setting it up right. Here are the results from "iwconfig>ip link set wlan0 up>iwlist wlan0 scan>>>
I can’t copy the scan because of this>"You have included a total of 5 images and/or videos in your message. The maximum number that you may include is 4. Please correct the problem and then continue again.

Images include use of smilies, the BB code tag. The use of these is all subject to them being enabled by the administrator."

???

On 11/28/2011 01:06 PM, raysr11 wrote:
>
> I deleted ndiswrapper and WG111 from Network Devices and rebooted to
> clean everything out. It found the adapter and loaded the driver.
> Still won’t work. I’m not thinking it’s a hardware issue, I’m thinking
> I’m not setting it up right. Here are the results from "iwconfig>ip
> link set wlan0 up>iwlist wlan0 scan>>>
> I can’t copy the scan because of this>“You have included a total of 5
> images and/or videos in your message. The maximum number that you may
> include is 4. Please correct the problem and then continue again.
>
> Images include use of smilies, the BB code tag. The use of these
> is all subject to them being enabled by the administrator.”

Do not make an image. Copy and paste the text inside “code” tags.

If your AP shows up with the command “iwlist wlan0 scan”, then you only need to
configure correctly. Are you using KDE or Gnome? NetworkManager or ifup? I see
you have WEP encryption. Are you using the hex key?

What does that error mean? And why do I keep getting those stupid “smilie faces” in my posts?

Some character sequences are interpreted as codes for smilies. If you put them inside a code block, then the original characters will be seen instead of the smiles.
code ]
text for code block
/code ]
except omit the spaces to make the code block work.

On 11/28/2011 09:06 PM, raysr11 wrote:
>
> What does that error mean? And why do I keep getting those stupid
> “smilie faces” in my posts?

The answer to both is that you do not put your computer output inside

....

tags.

OK, I’ve got a “Tenda” Wireless USB adapter. Will someone please help me set it up? I really have no clue.

Thanks

OK
But which one?

This will help you identify
http://forums.opensuse.org/network-internet/wireless/410319-getting-your-wireless-work.html

lsusb -v
should list your usb devices, we just need the Tenda info

The “Tenda” adapter is “W311U” “lsusb-v” command not found.

I was able to run “lsusb -v”, I didn’t put a space after the ‘b’. But the string is too long and I can’t post it all.

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 9 Hub
bDeviceSubClass 0 Unused
bDeviceProtocol 0 Full speed (or root) hub
bMaxPacketSize0 64
idVendor 0x1d6b Linux Foundation
idProduct 0x0002 2.0 root hub
bcdDevice 3.01
iManufacturer 3 Linux 3.1.0-1.2-desktop ehci_hcd
iProduct 2 EHCI Host Controller
iSerial 1 0000:00:02.1
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 25
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0xe0
Self Powered
Remote Wakeup
MaxPower 0mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 1
bInterfaceClass 9 Hub
bInterfaceSubClass 0 Unused
bInterfaceProtocol 0 Full speed (or root) hub
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0004 1x 4 bytes
bInterval 12
Hub Descriptor:
bLength 11
bDescriptorType 41
nNbrPorts 10
wHubCharacteristic 0x000a
No power switching (usb 1.0)
Per-port overcurrent protection
bPwrOn2PwrGood 10 * 2 milli seconds
bHubContrCurrent 0 milli Ampere
DeviceRemovable 0x00 0x00
PortPwrCtrlMask 0xff 0xff
Hub Port Status:
Port 1: 0000.0503 highspeed power enable connect
Port 2: 0000.0100 power
Port 3: 0000.0100 power
Port 4: 0000.0503 highspeed power enable connect
Port 5: 0000.0100 power
Port 6: 0000.0100 power
Port 7: 0000.0100 power
Port 8: 0000.0100 power
Port 9: 0000.0503 highspeed power enable connect
Port 10: 0000.0100 power
Device Status: 0x0003
Self Powered
Remote Wakeup Enabled

Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 1.10
bDeviceClass 9 Hub
bDeviceSubClass 0 Unused
bDeviceProtocol 0 Full speed (or root) hub
bMaxPacketSize0 64
idVendor 0x1d6b Linux Foundation
idProduct 0x0001 1.1 root hub
bcdDevice 3.01
iManufacturer 3 Linux 3.1.0-1.2-desktop ohci_hcd
iProduct 2 OHCI Host Controller
iSerial 1 0000:00:02.0
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 25
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0xe0
Self Powered
Remote Wakeup
MaxPower 0mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 1
bInterfaceClass 9 Hub
bInterfaceSubClass 0 Unused
bInterfaceProtocol 0 Full speed (or root) hub
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes

On 12/08/2011 02:26 PM, raysr11 wrote:
>
> I was able to run “lsusb -v”, I didn’t put a space after the ‘b’. But
> the string is too long and I can’t post it all.

Do not use the -v switch on the lsusb command. The plain version provides what
we need.

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 001 Device 003: ID 03f0:5d11 Hewlett-Packard PhotoSmart C5200 series
Bus 001 Device 005: ID 058f:6377 Alcor Micro Corp. Multimedia Card Reader
Bus 002 Device 002: ID 0461:4d63 Primax Electronics, Ltd