Unable to get wifi working in my dell inspiron 1440

I am a newbie in linux and have installed opensuse 12.1 and the installation went successfully. No I am having difficulty in getting my wifi work.
I’ve installed the driver of broadcom adapter.

linux-shwo:~ # /sbin/lspci -nnk | tail
Kernel driver in use: ahci
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
Subsystem: Dell Device [1028:02cf]
Kernel driver in use: i801_smbus
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
Subsystem: Dell Device [1028:02cf]
Kernel driver in use: r8169
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]
Kernel driver in use: b43-pci-bridge

linux-shwo:~ # uname -r
3.4.28-2.20-default

linux-shwo:~ # ifconfig
eth0 Link encap:Ethernet HWaddr 00:25:64:4A:A3:92
inet addr:192.168.0.11 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::225:64ff:fe4a:a392/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:463394 errors:0 dropped:0 overruns:0 frame:0
TX packets:268821 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:683019767 (651.3 Mb) TX bytes:21556177 (20.5 Mb)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:174 errors:0 dropped:0 overruns:0 frame:0
TX packets:174 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:20090 (19.6 Kb) TX bytes:20090 (19.6 Kb)

linux-shwo:~ #

This is driving me crazy…:frowning: Someone please help me…:frowning:

Did you do

sudo /usr/sbin/install_bcm43xx_firmware

You need an active wired connection
If you don’t have a wired connection, let me know.

The above command has caused a system crash (it’s a known bug) but nothing to worry about. Just wait a minute and force a reboot.

linux-shwo:~ # uname -r
3.4.28-2.20-default

Is 12.2 not 12.1

Apart from the fact that caf4926 is already trying to help you (yes, there are some nice people here), please next time try to improve on your thread by:
. using the most appropriate forum for your problem, Wireless looks as the best one to me. And in the first few “sticky” threads there you will find a lot of help already and also what technical information you are required to post to make you helpers helping more efficient.
. using CODE tags around your computer texts to make them better readable and to let them stand out amongst the story telling of a post. Use the # button in the toolbar above the post editor.

Enjoy.

Hi, thanks for your help. I’ve run the following command and rebooted the system

sudo /usr/sbin/install_bcm43xx_firmware

Still wifi is not working… Do I need to activate something ? The network settings are now controlled by “Networkmanager” and my wired connection is working fine. But when I try to turn on wifi using the wifi switch in keyboard, only bluetooh gets activated.

Please try the following:

sudo /sbin/modprobe -rv b43

sudo /sbin/modprobe -v b43

If it still doesn’t work, post result of

rpm -qa | grep broadcom

And now also
Please install rfkill, like this

zypper in rfkill

Then post result of

/usr/sbin/rfkill list

Hi,

fixed the issue… cheers…!!!:):):slight_smile:

Welcome :smiley: