Unable to get sound from microphone

Hello. I am a new user to openSUSE.

I am having difficulty getting sound from my microphone. The input level does not show anything in the Phonon device configuration. Additionally, I get no sound when I attempted to record with Audacity or use a VOIP program.

What I have tried so far:
Promoted “Mic Capture” to top of list under device preferences in Phonon
(no effect, and the changes revert the next time I open up Phonon)

KDE Control Module also crashes whenever I close Phonon…might be worth mentioning

Any advice where to start troubleshooting this?

I am running openSUSE 12.1 KDE 64-bit
My sound card is a Sound Blaster Audigy 2 Value
I am using the analog mic input
Sound output works just fine
Mic works in Windows XP on the same computer (I dual boot)
I am using “analog stereo duplex” as my sound profile

It’s worth mentioning that I’ve never tried the mic with previous distros I’ve used (could be an issue with Linux in general and not just openSUSE). Any help would be greatly appreciated.


I would like to help. Unfortunately I am really really busy at work (which pays my salary) as opposed to the openSUSE volunteer efforts.

With your PC connected to the internet, can you please run the diagnostic script noted below, and post the uRL/webaddress it provides with the harware/software audio configuration of your PC ? Select the SHARE/UPLOAD option. Ensure before running the script you have your mic configured to record best you can. I’ll look at this when I find some time.


Here is the output of the script:

Thank you for offering to look into this.

Thanks for providing the diagnostic script output. This is what I see :


**** List of CAPTURE Hardware Devices ****
**card 0**: Audigy2 [SB Audigy 2 Value [SB0400]], **device 0**: emu10k1 [ADC Capture/Standard PCM Playback]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
**card 0**: Audigy2 [SB Audigy 2 Value [SB0400]], **device 1**: emu10k1 mic [Mic Capture]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 0**: Audigy2 [SB Audigy 2 Value [SB0400]], **device 2**: emu10k1 efx [Multichannel Capture/PT Playback]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

From this, i can see that you have 3 capture devices: hw:0,0 (ADC-Capture) , hw:0,1 (Mic Capture) , hw:0,2 (multichannel capture) .

I prefer to use a simple terminal command to check the mic. Something like:

arecord -vv -f S16_LE -c 2 -D hw:1,0 new.wav

where I chose the format ‘S16_LE’, and I chose 2 channels with ’ -c 2 ’ . You may need to use a different number of channels. And in this example I chose hardware device hw:1,0 . It will save to the file new.wav. To stop the recordig press . One needs to play back new.wav to see if the mic worked. Pay attention to arecord error messages as they give a lot of good information.

Now if you are using a different application than arecord, and assuming pulse is still installed, then I recommend you install the application pulse audio volume control (pavucontrol) and use that to help tune your mic. Note pavucontrol will not work with arecord, as arecord is at a lower level.

Lets look at your mixer next:

!!Amixer output

**!!-------Mixer controls for card 0 [Audigy2]**

Card hw:0 'Audigy2'/'SB Audigy 2 Value [SB0400] (rev.0, serial:0x10011102) at 0xcf00, irq 20'
  Mixer name	: 'SigmaTel STAC9750,51'
**Simple mixer control 'PCM',0**
  Front Left: Playback 100 [100%] [0.00dB] **Capture 0 [0%]** -99999.99dB]
  Front Right: Playback 100 [100%] [0.00dB] **Capture 0 [0%]** -99999.99dB]
**Simple mixer control 'Synth',0**
  Front Left: Playback 50 [50%] -20.00dB] **Capture 0 [0%]** -99999.99dB]
  Front Right: Playback 50 [50%] -20.00dB] **Capture 0 [0%]** -99999.99dB]
**Simple mixer control 'Line2',0**
  Front Left: Playback 0 [0%] -99999.99dB] **Capture 0 [0%]** -99999.99dB]
  Front Right: Playback 0 [0%] -99999.99dB] **Capture 0 [0%]** -99999.99dB]
**Simple mixer control 'Mic',0**
  Front Left: Playback 0 [0%] -99999.99dB] **Capture 0 [0%]** -99999.99dB]
  Front Right: Playback 0 [0%] -99999.99dB] **Capture 0 [0%]** -99999.99dB]
**Simple mixer control 'Mic Boost ( 20dB)',0**
  Mono: Playback **[off]**
**Simple mixer control 'IEC958 Optical',0**
  Front Left: Playback 0 [0%] -99999.99dB] **Capture 0 [0%]** -99999.99dB]
  Front Right: Playback 0 [0%] -99999.99dB] **Capture 0 [0%]** -99999.99dB]
**Simple mixer control 'Aux2',0**
  Front Left: Playback 0 [0%] -99999.99dB] **Capture 0 [0%]** -99999.99dB]
  Front Right: Playback 0 [0%] -99999.99dB] **Capture 0 [0%]** -99999.99dB]
**Simple mixer control 'Analog Capture Boost',0**
  Mono: Playback **[off]**
**Simple mixer control 'Analog Mix',0**
  Front Left: Playback 0 [0%] -99999.99dB] **Capture 0 [0%]** -99999.99dB]
  Front Right: Playback 0 [0%] -99999.99dB] **Capture 0 [0%]** -99999.99dB]
**Simple mixer control 'Audigy CD',0**
  Front Left: Playback 0 [0%] -99999.99dB] **Capture 0 [0%]** -99999.99dB]
  Front Right: Playback 0 [0%] -99999.99dB] **Capture 0 [0%]** -99999.99dB]

there are many different capture controls, and EVERY one has the capture at 0%. That guarantee’s no recording. Please open your mixer and move the PCs capture levels to something high. Also move up the boost.

If you can’t get kmix to work, you can try ‘alsamixer’ (run that in a terminal). Or take the time to learn the syntax of ‘amixer’ .