Unable to get into Windows X P after OpenSUSE 11.2 installation

Hi Guys,

I’m new to Linux, I’ve been trying OpenSUSE Linux on live CD and I grew more and more fond of it and finally decided to install it onto an old computer that’s running Win X P.

I followed the installation Quickstart guide using the default options, including the proposed partition shrinking scheme.

After that, Iwas able to get in to OpenSUSE smoothly. (Yay! now I dont need to setup wireless connections everytime I log in).

But when Irebooted, I found that I’m no longer able to get into WinXP. I can choose to boot into Windows from the OpenSUSE boot splash screen (the GRUB?) … and when I choose Windows, I can see the windows splash screen (the logo with the animated progress bar), and then the mouse cursor shows up and I was able to move the mouse but the windows login screen does not appear. There’s only the mouse cursor on a black background… It doesnt get past this point no matter how long I wait. Does anyone know what seems to be the problem?

For background info, my system is:
Windows XP SP2
Pentium 4 2.4GHz
768 MB RAM
40 GB hard drive

Original partition before installing OpenSUSE was:
C: around 19+GB, 2.5GB free
D: around 18+GB, 16GB free (I defragged this drive successfully before installing OpenSUSE). When I looked at this drive there’s no files in it, and yet the free space does not tally with the total space, about 2GB different, I’m guessing this is WinXP’s virtual memory/paging file?

Partition structure after installing OpenSUSE:
C: around 19+GB, 2.5GB free (no change)
D: around 6 GB, its still empty, but shrunk
F: around 9 GB, where OpenSUSE now resides
G: around 1 GB, used for the ‘swap’ files? (as proposed by the default installation)

Can anyone advise me please what do I need to do to get into Win X P? Any help is much appreciated,

Thanks! :slight_smile:

To me this one seems a little unusual,The only boot to windows problems I have encountered have been where it does not make it to the windows bootloader (It won’t chainload). What install method was used.There are a number available.

Ok only Redmond OS’s name partitions as drives A-Z

It may help to see the output of fdisk -l

open a console/Konsole in Suse type

then the root password (note: this does NOT echo to the screen)
this makes you root
fdisk -l (that is a lower case L not a one)
post out put here to copy highlight with the mouse select edit-copy from the console menu. Paste here

The fact that XP starts it’s boot is troublesome.
Note also that 9gig for suse is very very tight.

Hi gogalthorp,

Thanks for replying:) The fdisk -l printout is as follows:

Disk /dev/sda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x2b432b42

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        2332    18723757    c  W95 FAT32 (LBA)
/dev/sda2   *        2551        4864    18587205    f  W95 Ext'd (LBA)
/dev/sda3            2332        2550     1759086+  82  Linux swap / Solaris
/dev/sda5            2551        3511     7711200    b  W95 FAT32
/dev/sda6            3511        4864    10875942   83  Linux

Partition table entries are not in disk order

Sorry the disk sizes are a bit off from my previous posting, I was not exactly sure of the sizes in the prev post. But now we got the exact sizes :slight_smile: Any idea what went wrong?

Is 10GB a bit too tight for OpenSUSE? Uh-oh I hope I wont have any problems running it in future… So far it works perfectly…


now as root let’s see your menu.lst

cat /boot/grub/menu.lst

this shows the grub menu and what it does.

I’m concerned that the windows partition may have been damaged because you do say that Windows starts but then crashes. It is conceivable that you had something on the removed partition that was needed by Windows, but I could not guess what. An install should not touch sda1 partition (Windows). Did you have any false starts in the install? ie did you stop the install at some point or otherwise have problems?

Sure, here’s what I got from cat /boot/grub/menu.lst :

# Modified by YaST2. Last modification on Sun Mar  7 19:24:52 SGT 2010
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader          
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader                                                                             

default 0
timeout 8
gfxmenu (hd0,5)/boot/message
##YaST - activate           

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.2                                                     
    root (hd0,5)                                                        
    kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-ST340014A_3JX1YHN4-part6 resume=/dev/disk/by-id/ata-ST340014A_3JX1YHN4-part3 splash=silent quiet showopts vga=0x348                                                      
    initrd /boot/initrd-                                    

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows                                                             
    rootnoverify (hd0,0)
    chainloader +1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
    rootnoverify (fd0)
    chainloader +1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.2
    root (hd0,5)
    kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-ST340014A_3JX1YHN4-part6 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x348
    initrd /boot/initrd-

… is there anything unusual / unexpected? I wonder what is it telling us… :stuck_out_tongue:

The boot mechanism works because windows commences the boot and the windows logo starts.

Windows has been damaged by the installation of openSUSE. I suggest that you use the windows installation CD to run the microsoft program “chkdsk” on the first fat32 hard drive (where windows lives). To do that, boot of the windows install cd, let the preamble finish and select to “repair using recovery console press R”. Log into c: and run this command

chkdsk c: /p

This is just a left field thought, might help, can’t hurt, might not help.

Hi swerdna,

I tried chkdsk c: /p and i get the following message:

The volume Serial Number is 6c56-852b

The volume appears to contain one or more unrecoverable problems.
20472816 kilobytes total disk space.
 2572768 kilobytes are available.

   16384 bytes in each allocation unit.         
 1279551 total allocation units on disk.
  160798 allocation units available on disk.

Mmm this looks bad, isn’t it? But the good thing is (I dunno if this is a good thing, I’m just hoping it is) … I can still see the files on C: … all the windows files and folders are still there but it still doesnt boot properly… the boot up would stop once the mouse pointer is displayed… the login screen doesnt appear at all…

Are there other options to try? I dunno maybe BOOTCFG / FIXBOOT / FIXMBR ? I’m not familiar with all those… so I didnt venture in and try …

…and oh, yes… chkdsk D: /p is fine btw…

The volume Serial Number is d0bc-1ed5
CHKDSK is checking the volume..
CHKDSK has finished checking the volume.
  7707392 kilobytes total disk space.
  6617424 kilobytes are available.
    16384 bytes in each allocation unit.
   481712 total allocation units on disk.
   413589 allocation units available on disk.

Should I try BOOTCFG / FIXBOOT / FIXMBR? If yes, what is the exact command to execute? Thanks! :slight_smile:

If you want to produce a good chance of killing openSUSE, too (depending on where the bootloader was actually installed) then go ahead.

As XP is starting to boot and then fails, you don’t have a bootloader problem but a problem with your windows installation.

I’m trying to get a lead on what happened and what can best be done. Here’s a few questions:

  1. Drive C is 20 GB approx. What size was it before installing openSUSE?
  2. Did you run the Defrag utility in windows before running the openSUSE installer?
  3. The second FAT32 partition (drive D) wasn’t there before openSUSE was installed. Can you remember how it came into existence?


Should I try BOOTCFG / FIXBOOT / FIXMBR? If yes, what is the exact command to execute? Thanks!

That’s not the problem. The problem is the filesystem structure on C. There is a possible solution for fixing the windows installation, 50:50 chance of success and risky.

Oh, and here’s another question: it might be possible to repair windows but it entails cleaning off everything but C drive first, then fixing windows (maybe), then reinstalling openSUSE. Is that acceptable?

  1. Before installing OpenSUSE i had C: approx 20GB and D: approx 20GB too (They’re from one hard drive of size 40GB). The C:is for Windows and D:is for data mainly. Now come to think of it, it was laballed E: instead of D: previously. The D: was for CDRom… but now after installing OpenSUSE, Windows recognize that as D: and not E: … hmm… does this mean anything?

  2. Yep. I defragged both E: (the data drive)and C: (the windows drive) before installing OpenSUSE… The end result for E: was perfectly neat, I only saw blue and white … 100% not fragmented. The end result of the C: defrag was quite bad though… almost half are in Red, actually it didnt look like Windows did much tidying up in the defrag, but Windows stopped defragging nevertheless and it said Defragging completed.

  3. Pls see #1. It was recognized as E: before, and I used it to store all data files…

Hmm so looks like the file system structure in C:is messed up huh…? Can you share more abt the solution that you mentioned? 50-50 chance is still better than none I reckon :slight_smile: I’ve been asking here n there but no one seems to have anysolution…

I tried the so-called ‘non-destructive’ repair by re-installing WinXP from its CD … but I got an error message saying there may be unrepairable damage on C: (or something like that, cant remember the exact error message) …

Actually I kinda tend towar+ds ditching WinXP alltogether and setup a dualboot (OpenSUSE + Ubuntu) instead… but not exactly sure how to do this… is this difficult to do? Have you come across any useful step-by-step tutorials about it?


Did you try this: boot the windows xp install cd and wait for the final screen 'welcome to setup", choose “to setup press ENTER” then it will find C drive as a previous xp install. At this point you press R to repair it.

That might be what you called “non destructive repair”

In the case of that failing, you have to reinstall XP (get the data off first) or forget about it and install Ubuntu/openSUSE (get the data off XP first).

It’s no big drama to get the data off of xp and wipe the drive and then install Ubuntu and openSUSE.

What do you want to do?

PS given the error messages, you need to check the drive integrity too.

PPS it’s really weird that the first and second NTFS partitions have a space of cylinders between them, from 2332 to 2550, inexplicable – move on and forget about it I suppose.

Afterthought: to test the hdd integrity, boot off the Ubuntu install CD and select “check disk for defects”

Hey Guys,

I’ve killed WindowsXP and am now a happy user of OpenSUSE Ubuntu :smiley: Thanks for the help and infos guys, really appreciate that :slight_smile:

However, I now got another problem… I’m trying to hook up another monitor using the displaylink usb adapter … without success… Is anyone familiar with this or can point me out to sources in OpenSUSE? (I’ve searched the net but found Ubuntu guides only so far) but I actually like to use OpenSUSE more than Ubuntu and am really hoping it’ll work in OpenSUSE… so really appreciate if anyone can give a pointer or two…

I know this should fall on another thread, and will continue it there… Thanks!