Unable to get audio to play through PC speakers on Skylake laptop

I’m running Tumbleweed on a Lenovo Thinkpad Yoga 260 (Skylake).


  1. After booting, no audio plays through the PC speakers.

  2. MATE Sound Preferences says there is no audio device.

  3. Running

sudo udevadm trigger

sometimes resulted in audio playing again.

  1. However, more often than not it doesn’t work - instead, audio appears to be routed exclusively through the HDMI port.

I have followed as much of the Intel HDA guide as seems to apply, to no avail.

Here’s the results of the ALSA script: http://www.alsa-project.org/db/?f=f008a05684cc8ad65c82d2e61fa6ea476ff0d794

Any help would be much appreciated.



Update: I tried a variation on Step 2 here:

  1. Delete /etc/modprobe.d/50-sound.conf
  2. Add the sound card manually in YAST (do not configure the autodetected Sunrise Point audio card)

Sound appears to have survived a reboot. Fingers crossed…

I hope it continues to work for you.

Note that there is an application called ‘pavucontrol’ (pulse audio volume control) which gives you control of sound via pulse audio on a per application and per device basis. So if you believe sound is being inappropriately routed to HDMI you can change its routing direction on a per application basis using pavucontrol.

Thanks for the tip. Just wanted to confirm here that adding the ICH10 sound card manually in YAST, rather than configuring the auto-detected sound card, has worked over the past couple of days.

You could configure both, set the ICH10 as the primary sound card ( button in Yast config screen on the bottom right ). And / or, like oldcpu says, install pavucontrol. The latter has been a real tool to me.