Unable to get atheros AR242x wireless card working

I am running suse 11.0 on a toshiba laptop which has an atheros ar242x 802.11 abg wireless PCI Express Adapter which is recognized in the hardware information in Yast.

I have tried installing MadWifi and it seemed to install ok and after running the ‘modprobe ath_pci’ command in root it returned to the next command line like it should, but the wireless card still won’t work.

I have also blacklisted ath5k in the blacklist file.

In yast network settings for the wireless card it displays this and won’t let me edit any settings:

'AR242x 802.11abg Wireless PCI Express Adapter (Not connected)
BusID : 0000:03:00.0

Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.’

I have also tried using ndiswrapper but had no success.

any help would be greatly appreciated!!!

Try the compat-wireless drivers.The devs are working on the atheros drivers at the moment


I have the identical card. I followed the instructions at madwifi, but it still didn’t work.

After upgrading to openSUSE 11.1, it now works out of the box. The problem is that 11.0 uses kernel 2.6.26.x. If you want to continue to use 11.0, one possibility would be to compile a vanilla kernel 2.6.27.x. I did that for Debian and Slackware 12, and the card worked for both of them.

You most likely have a 2417 or 2424 or 2425. Try Atheros’ drivers 5006 and/or 5007, plus variations, like 5006B, or 5007SE, etc.

My Pavilion has a 2417, so v11 tried ath5k, which worked a little, but it was also loading ath_pci. I tried booting with broken_modules = ath_pci, which didn’t work, so I uninstalled ath_pci so that it couldn’t load, and then, somehow, unknown to me, it finally popped up with 5006, which works great.

Details here: < Atheros Communications >

Britt Dickson
San Jose, CA

Before 11.1 I never saw AR242x wireless card working.:open_mouth:
:wink: Now it’s working on:

Operating System:
openSUSE 11.1
CPU Speed:
System Memory:
Number of CPUs:
Default Runlevel:
System Vendor:
System Model:
ESPRIMO Mobile V5515 V1.00
SELinux Enabled
SELinux Policy
Not Installed
SELinux Enforce
Not Installed
Last Modified
2008-12-26 21:19:32

Show Box

The same thing happened to me moving from 10.2 to 10.3, only it was ndiswrapper that began to work (finally).

This HP T2 laptop just got an online update, and my 2417 driver went from ath5k to AR6000G, with no user intervention.

Aren’t these issues fun to solve when they (seemingly) solve themselves?

Britt Dickson