Unable to edit partitions during setup (11.2 x64)

I can’t edit the partitions in the install setup. When I go tyo the Expert Partitioner, I see a hard disk (sda) with no partitions or user devices, and 2 RAID devices:

  • /dev/md126 with 465.76 GB, not encrypted, type RAID1 (no info for chunk size, parity or file system)

  • /dev/md127 with 2.2 MB, not encrypted, RAID_UNKNOWN (no info for chunk size, parity or file system)

I didn’t try to do anything in the RAID part because I wanted to preserve Win 7, but I dared to add a partition in the “hard disk” (sda) and I get an error: “the disk is in use and cannot be modified”.

The behavior of Ubuntu 9.1 x64 installation is much alike.

I have googled with every keyword combination I remembered, but I can’t find anything that gives me a clue to what may be happening.

I have already tried the 3 SATA configurations (the IDE that works with the installed Win 7, AHCI and RAID), but the result is always the same. Now the strangest thing is that fdisk and parted correctly identify the partitions. As far as I remember, parted isn’t able to do modifications and fdisk says that the boundaries of the first, tiny partition, doesn’t match the number of cylinders (or something like it). However, I was able create a partition with fdisk on the empty space and format it, delete it again and repeat the process a couple of times with no errors. The partituions are signed as msdos.

GParted from Ubuntu also shows the partitions, but I didn’t try to do any modifications, namely because I don’t think that it can solve my problem and I don’t want to risk installing windows again.

The hardware is brand new, a Asus M4A785Td-V Evo with an Amd Phenom II X4 965 and a WDC-WD5000ACCS-0 500 Gb HD. My lazyness made me asking the guys from whom I bought it to install Win7 Ultimate 64 in a NTFS partition, leaving half the disk untouched. They assure me that it is a “plain vanilla” (“next, next, next”) installation . I guess I could try to see if I could do the partition setup in the “RAID” part of the Expert partitioner, but I have strong doubts that it solves the problem and it would be quite boring to conclude that I ruined the windows installation for nothing.

Could it be any awkward problem specific of the motherboard / SATA controller?

Any input is welcome.
Regards, Jose

This happens when the installer detects RAID capable hardware and “helpfully” tries to set it up for you. Are you using the RAID in Win7? If not, then go into the BIOS and disable any RAID features and tell it to treat them as just a bunch of disks.

Thank’s for the tip, but, as I wrote, before the behavior is the same no matter SAID/SATA configuration I try on the BIOS. Windows hasn’t any RAID configured and it only boots when the SATA controller is “in IDE mode”.

I am having the same problem.

Ubuntu enabled dmraid by default, despite fakeraid being switched off in my ex58-udp5 bios.

It also had the problem, where it couldnt see my entire SDA drive. When i rescan the drives and get rid of the created raid it is still clearly screwing up reading SDA.

I think possibly passing argument to the installer to disable “mdraid” on SuSe is the answer. I’m trying to figure this out.

Fedora v12 does not have this problem and installed fine to SDA without having to switch off the fakeraid via installer argument. Fedora FTW.

I want ubuntu fedora & suse on my SDA with windows vista, so i can free up the second 500gb drive to firewire to my HP notebook which is a text only server, this way i can do some proper proof of concept testing with larger files.

So yeah, i think at install an argument need to be applied to disable mdraid.

I just installed Fedora v12 to my SDA without this issue happening at all.

I’m guessing if i plugged all my drives through the gigabyte drive controller instead it would be fine however you’d think the intel generic drive controller would be much more likely to work bug free! Its also faster :(.

i just tried passing these lines to the installer


I also unplugged the other drive, it still wants to setup raid.

There is still no raid metadata whatsoever on the drive.

I tried setting raid to AHCI in bios, this did not work either.

This is a **** stupid bug. Why fedora doesnt have an issue but ubuntu and suse does is confusing.

Im pretty sure i tried SUSE first before fedora however im now going to nuke the fedora partitions from ubuntu livecd and see if that lets suse see anything.

Ok i spent the whole of yesterday on this problem,

Its funny because the outcome of this will determine if i study to pwn RHCE or NCLE.

I completely removed Fedora from ubunutu on my other drive, removed that drive. Suse had a fresh drive to install too except only the windows parititon.

same error.

I used vista recovery to fixmbr / fixboot to nuke the grub info.

Set all bios settings to failsafe.

same error.

I then tried with AHCI turned on instead of IDE, Same error.

The only other option is to try to tweakout the hard drive cables with is a PITA as their under my oversize GTX285 gfx, and put them in the gigabyte SATA controller, which is much less standard so im not doing it as it shouldnt work.

Please sir, can i have some more? HELP!!!

I’m having this issue too; I wonder if it’s something to do with the existing partitions, as when I installed 11.2 previously, it worked fine. However, trying to install it over the top of an existing dual boot configuration (ie, wipe the drive and start over) it’s not seeing my disk.

It seems quite erratic.

I’ve got an i5 on Gigabyte P55 UD 3 board with WD Black Edition HD.

The board does have raid capability but I’ve not altered anything on the bios in that regard.

I’ll be very pleased to hear if you’ve made any progress with this issue.

This is not a fix but what I did is use the 11.1 liveCD (not the 11.1 install DVD as that also created raid partitions) to get an installation of 11.1, then I ran the 11.2 install DVD to upgrade the 11.1.

The 11.1 live CD also created raid partitions (that couldn’t be deleted) but put them behind the other partitions so no big deal as they are small partitions.