Unable to edit firewall zones in YAST


New problem - was working previously.

Unable to edit the firewall zones in YAST. Unable to properly assign network interface to a zone.

Previous working edits have disappeared.

YAST seems to create a double entry of the edited zone into /etc/firewalld/zones when editing a zone.

Seeing this behaviour on two separate machines.

It is absolutely unclear what you mean. I tried to change interface zone and it worked. You need to provide more detailed description of steps you used.

I presume you have previous snapshots so you can restore old content. If you can provided step by step description how to reproduce it starting from known good content you should open bug report.

Again, it is absolutely unclear what it means. I edited zone (by adding service) and I do not see any “double entries” anywhere.

Start YAST

Click Firewall

Choose any zone

Edit it by adding a service

Click Accept

Return to Firewall and observe that edits were not saved

Observe that double entry .xml file of edited zone appears in /etc/firewalld/zones

Observe that every zone in YAST > Firewall is exactly the same despite the .xml files in /lib/firewalld/zones having different entries


Can confirm the problem exists in the latest Raspberry Pi image (openSUSE-Tumbleweed-ARM-X11-raspberrypi.aarch64.raw.xz). I was setting up PostgreSQL on Raspberry Pi 4 Model B 4 GB. No firewall setting is persisted in the Yast2 UI.