Unable to do Zypper Refresh

Hello,

I was trying to search for openvpn when I noticed below error. Also why would search look through videolan.org?
I tried doing a ‘zypper refresh’, but no good. I also went into YaST to update repository, still no good. This is openSUSE 13.1

rW@linux-ry0g:~> zypper se openvpn
Download (curl) error for ‘http://download.videolan.org/SuSE/13.1/repodata/repomd.xml’:
Error code: Connection failed
Error message: Failed to connect to 2a01:e0d:1:3:58bf:fa02:0:2: Network is unreachable

Abort, retry, ignore? [a/r/i/? shows all options] (a): a
Repository ‘SuSE’ is out-of-date. You can run ‘zypper refresh’ as root to update it.
Repository ‘backintime-1.0.36’ is out-of-date. You can run ‘zypper refresh’ as root to update it.
Repository ‘Packman Repository’ is out-of-date. You can run ‘zypper refresh’ as root to update it.
Loading repository data…
Reading installed packages…

S | Name | Summary | Type
–±-----------------------------±---------------------------------------------------------±----------
i | NetworkManager-openvpn | NetworkManager VPN support for OpenVPN | package
| NetworkManager-openvpn-gnome | NetworkManager VPN support for OpenVPN | package
i | NetworkManager-openvpn-kde4 | NetworkManager client for KDE 4 | package
| NetworkManager-openvpn-lang | Languages for package NetworkManager-openvpn | package
i | openvpn | Full-featured SSL VPN solution using a TUN/TAP Interface | package
| openvpn | Full-featured SSL VPN solution using a TUN/TAP Interface | srcpackage
| openvpn-auth-pam-plugin | OpenVPN auth-pam plugin | package
| openvpn-down-root-plugin | OpenVPN down-root plugin | package
| plasma-nm-openvpn | OpenVPN support for plasma-nm | package
rW@linux-ry0g:~> su
Password:
su: Authentication failure
rW@linux-ry0g:~> su
Password:
su: Authentication failure
rW@linux-ry0g:~> su
Password:
linux-ry0g:/home/rW # zypper refresh
Download (curl) error for ‘http://download.videolan.org/SuSE/13.1/repodata/repomd.xml’:
Error code: Connection failed
Error message: Failed to connect to 2a01:e0d:1:3:58bf:fa02:0:2: Network is unreachable

Abort, retry, ignore? [a/r/i/? shows all options] (a): a
ABORT request: Aborting requested by user
linux-ry0g:/home/rW # ls
239035_files failed: Invalid argument (22) .cddb Downloads .gphoto .macromedia .recently-used Wallpapers
239035.html.5IMXR2 failed: Invalid argument (22) .clamtk .dvdcss .gstreamer-0.10 .mozilla .skel Windows7Ultimate
239035.html.ixNoWL failed: Invalid argument (22) Component easy-rsa-2.x.tar.gz .gtkrc-2.0 .mplayer .ssh .wine
239035.html.kRn20Y failed: Invalid argument (22) .config easy-rsa-release-2.x .icedtea Music Templates .Xauthority
239035.html.KwNQ0z failed: Invalid argument (22) .cups .emacs .ies4linux .opera .thumbnails .xim.template
.adobe Databases.db .esd_auth ies4linux-2.99.0.1 Pictures .tor .xine
.android .dbus .fonts ies4linux-latest.tar.gz .profile Videos .xinitrc.template
.bash_history Desktop .gimp-2.8 .inputrc Public .viminfo .xsession-errors
.bashrc .directory .gnome2 .java public_html .VirtualBox .xsession-errors-:0
bin .dmrc .gnome2_private .kde4 .purple VirtualBox VMs .y2log
.cache Documents .gnupg .local .rcc vitutorial .y2usersettings
linux-ry0g:/home/rW # zypper se openvpn
Download (curl) error for ‘http://download.videolan.org/SuSE/13.1/repodata/repomd.xml’:
Error code: Connection failed
Error message: Failed to connect to 2a01:e0d:1:3:58bf:fa02:0:2: Network is unreachable

Abort, retry, ignore? [a/r/i/? shows all options] (a): a
ABORT request: Aborting requested by user
linux-ry0g:/home/rW # zypper update
Download (curl) error for ‘http://download.videolan.org/SuSE/13.1/repodata/repomd.xml’:
Error code: Connection failed
Error message: Failed to connect to 2a01:e0d:1:3:58bf:fa02:0:2: Network is unreachable

Abort, retry, ignore? [a/r/i/? shows all options] (a): a
ABORT request: Aborting requested by user
linux-ry0g:/home/rW # update
If ‘update’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf update
linux-ry0g:/home/rW # exit
exit
rW@linux-ry0g:~> ls
239035_files failed: Invalid argument (22) bin Downloads Music Videos
239035.html.5IMXR2 failed: Invalid argument (22) Component easy-rsa-2.x.tar.gz Pictures VirtualBox VMs
239035.html.ixNoWL failed: Invalid argument (22) Databases.db easy-rsa-release-2.x Public vitutorial
239035.html.kRn20Y failed: Invalid argument (22) Desktop ies4linux-2.99.0.1 public_html Wallpapers
239035.html.KwNQ0z failed: Invalid argument (22) Documents ies4linux-latest.tar.gz Templates Windows7Ultimate

Password:
linux-ry0g:~ # zypper refresh
Download (curl) error for ‘http://download.videolan.org/SuSE/13.1/repodata/repomd.xml’:
Error code: Connection failed
Error message: Failed to connect to 2a01:e0d:1:3:58bf:fa02:0:2: Network is unreachable

Abort, retry, ignore? [a/r/i/? shows all options] (a): a
ABORT request: Aborting requested by user
linux-ry0g:~ #

Thanks

On Thu, 18 Dec 2014 17:56:01 +0000, opensuse13 wrote:

> I was trying to search for openvpn when I noticed below error. Also why
> would search look through videolan.org?
> I tried doing a ‘zypper refresh’, but no good. I also went into YaST to
> update repository, still no good. This is openSUSE 13.1

Go into the network configuration and disable IPv6. that should resolve
this for you.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

I think there is a problem with the vlc servers you’re trying to reach.Or at least I have searching for solution brought me here :smiley:

On Thu, 18 Dec 2014 19:26:01 +0000, tcvarbanov wrote:

> I think there is a problem with the vlc servers you’re trying to
> reach.Or at least I have searching for solution brought me here :smiley:

The problem is that he’s trying to resolve an IPv6 address and probably
doesn’t have IPv6 available through his ISP. It’s not an uncommon
problem, and is resolved (per my earlier suggestion) by disabling IPv6,
rebooting, and trying again. That should force it to resovle an IPv4
address, and make things work.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

But it is ill advised to use the vlc repo you should get the vlc stuff from packman. And should never ever mix packman and vlc packages. Far less chance of messing up. But there is also a separate IPv6 issue.

Hi
Also @ opensuse13 use su - if going to become root user… aside from the ipv6 issue…

Jim,

IPv6 has never been enabled. I click on IPv6 Address tab and ‘Method’ & ‘Privacy
Extensions’ are disabled.
IPv4 ‘Method’ is set to Automatic (DCHP).

gogalthrop,

But it is ill advised to use the vlc repo you should get the vlc stuff from
packman.

yes you are correct. I will definiyely not do that again.
I went into YaST and removed ‘http://download.videolan.org/SuSE/13.1/’ repository and performed a zypper refresh, all is well

THanks all!!!

I used to see a similar message from time to time. That was before my ISP provided IPv6. I would wait a day and try again, and then it would usually work (with IPv4).

On Fri, 19 Dec 2014 06:16:01 +0000, opensuse13 wrote:

> IPv6 has never been enabled. I click on IPv6 Address tab and ‘Method’ &
> ‘Privacy Extensions’ are disabled.
> IPv4 ‘Method’ is set to Automatic (DCHP).

IPv6 is enabled by default, so unless you disabled it, then it’s enabled.

If you disabled it, that’s not information that we would have been aware
of without you mentioning it here. :wink:

In any event, I’ve also seen reports that the repo is empty over IPv4, so
it looks like something went wrong with the site.

Disable the repo, and you’ll be able to refresh.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

nrickert,

I think this particular issue was in regards to the ‘http://download.videolan.org/SuSE/13.1/repodata/repomd.xml’ repository.
I just removed it and was able to do a ‘zypper refresh’ and other functions I couldn’t.
But if a connection issue were to resurface, I most definitely will look at the IPv6.

Thanks again

IPv6 is enabled by default, so unless you disabled it, then it’s enabled.
Hi Jim,
Really, I never touched IPv6. Never had a reason, plus I didn’t know what it would do.

If you disabled it, that’s not information that we would have been aware
of without you mentioning it here.
I didn’t mention IPv6, I didn’t know anything about IPv6 or if it had anything to do with my issue.

In any event, I’ve also seen reports that the repo is empty over IPv4, so
it looks like something went wrong with the site.
Disable the repo, and you’ll be able to refresh.
yep, that worked. All good!!! Thanks for your help

On 2014-12-18 21:36, gogalthorp wrote:
>
> But it is ill advised to use the vlc repo you should get the vlc stuff
> from packman. And should never ever mix packman and vlc packages. Far
> less chance of messing up. But there is also a separate IPv6 issue.

The IPv6 issue is… I can’t find the name… ah, a red herring.

When zypper has a problem with a repo, it tries another address in the
list of resolved addresses for that name. If the last one tried is an
IPv6 address, the reported error by zypper is that there was an error
with IPv6, but it does not matter. That’s not the real problem, so
ignore it.

The real problem is that videloan is partially down, so disable it for
now, and retry.

This is what I get on firefox:


http://download.videolan.org/SuSE/13.1/repodata/repomd.xml
404!
The requested file is not available on our mirrors

If you look at


download.videolan.org

There is no /pub, there is no SuSE.

As to the issue of videolan been advisable or not, that’s a different
thing. You may, for instance, use vlc from videolan and other things
from packman, it works just fine, if you don’t mix libraries.

As to the OP question «Also why would search look through
videolan.org?», it searches ALL the defined repos, needed or not.

On the other hand, this trick works till 13.1, to disable IPv6 on zypper
only:


Telcontar:~ # cat .curlrc
#CER: Default config for curl, use only IPv6
--ipv4
# CER - instead, try /etc/zypp/zypp.conf - download.max_download_speed
# --limit-rate 50K
Telcontar:~ #


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

very intereting to know, thank you!!

On Fri, 19 Dec 2014 07:06:01 +0000, opensuse13 wrote:

> IPv6 is enabled by default, so unless you disabled it, then it’s
> enabled.
> Hi Jim,
> Really, I never touched IPv6. Never had a reason, plus I didn’t know
> what it would do.

Well, if you only have IPv4 available, it can result in a zypper refresh
failing, if you end up with IPv6 name resolution.

> If you disabled it, that’s not information that we would have been aware
> of without you mentioning it here.
> I didn’t mention IPv6, I didn’t know anything about IPv6 or if it had
> anything to do with my issue.

You didn’t mention it directly, but the address resolution in the output
you posted was an IPv6 address:

Error message: Failed to connect to
2a01:e0d:1:3:58bf:fa02:0:2: Network is unreachable

That told me that name resolution was coming up with an address you
couldn’t reach, and the most common cause of that is getting an IPv6 name
resolution while not being IPv6 capable - which happens if IPv6 is
enabled but your ISP doesn’t support it.

(I’m explaining this so you understand the thought process I went through
to troubleshoot your issue)

> In any event, I’ve also seen reports that the repo is empty over IPv4,
> so it looks like something went wrong with the site.
> Disable the repo, and you’ll be able to refresh.
> yep, that worked. All good!!! Thanks for your help

Glad to help out. This worked around the issue, but now you should have
an understanding of what at least one underlying issue was (because even
if the site had been working, your address resolution issue would have
produced a failure).

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Understood, Thank you