Unable to disable touchpad

Am running OpenSuSE 11.1 / KDE 3.5 on an Acer Aspire 4730Z. Yast Hardware Info reports touchpad as ALPS/PS2 ALPS Glidepoint. Yast/Hardware/Mouse Model displays info for 4 mice. Mice 2 and 3 are the ALPS Glidepoint. When I uncheck the “Activate this pointer” box, the touchpad continues working. The BIOS has no option for disabling the touchpad. Surely there is a way to disable/remove the touchpad driver. But how?

Try as a normal user this command:
synclient TouchpadOff=1

Also, I wrote a little kmenu script to do that in the GUI:
Disable - Enable Touchpad KDE-Apps.org
Its very easy to use, it allows you to disable/enable with a right click and select the kmenu entry. It must be done at each login, that is it is not a permanent change in your system

Thanks for the response. Am unable to run synclient; get the message “Can’t access shared memory area. SHMConfig disabled?”
Have googled for this latter problem, and so far all suggestions (place some XML in /etc/hal/fdi/policy/shmconfig.fdi, add a tmpfs to fstab) don’t fix it. Also, have completely removed the “Input Device” sections referencing “synaptics” in /etc/X11/xorg.conf. No joy.

Am contemplating taping a piece of cardboard over the touchpad, or at least smearing it with fresh dog **** as an inducement to keep my fat thumbs farther away from it.

Yeah that is a nasty error that does not have a fixed solution. Like you, I googled that error again and again and try a bunch of proposed solution and found absolutely nothing working.

I get that error message sometimes on my laptop too. But only sometimes. Most of the times I dont get it and I can disable to touchpad normally.
Try rebooting and giving the same command again. When I get that error I reboot and in most cases it works (weird enough that error is not deterministic for me, it seems to appear randomly).

It is really annoying indeed. I have never gotten that error with my two old laptops. With my current, I got pi**ed off with having to reboot from time to time, so… some weeks ago I taped a thick cardboard patch on the touchpad. It is kinda gross but with this laptop there seem to be nothing else that works, even the edits that are supposed to permanently disable the touch pad did not work (while they did work on old laptops and old Opensuse versions).
The cardboard patch is awfully ugly but it works and it has saved me further frustrations.

PS: What my ugly laptop touchpad looks like now http://img263.imageshack.us/img263/5870/dscn4079y.jpg :X

Install the RPM gsynaptics. It works for me in KDE to disable the touchpad on my HP laptop. It won’t appear in the KDE Kickoff menu so make a “launcher” = “link to application” on the desktop and assign it the command “gsynaptics”.

Hey GONZO, I fixed your laptop – now it’s got the correct decal:


Hahaha you’re right, this is soooo much better :smiley: I never bothered to remove that horrible sticker but I think I better take that off :X

I installed gsynaptics a couple of months ago. For me, it works when the command synclient TouchpadOff=1 is also successful, while when the error message is displayed upon giving the command, gsynaptics does not work either and even unchecking the checkbox “Enable touchpad” gives no results (maybe it implements that very command synclient TouchpadOff=1, just from GUI). But still gsynaptics is worth trying out, and it is a neat app.

I discovered (with help from the Acer web site) that I can disable the touchpad by holding down the Fn key and pressing F7. This key combination toggles the touchpad on/off on my Acer 4730Z. BTW, it came loaded with Vista, which I threw on the floor. Installed OpenSuSE 11.0 and everything worked fine (after a driver download from the wireless manufacturer’s site). OpenSuSE 11.1 includes native support for the wireless, so things just worked.

Thanks to all for the many interesting suggestions.

That is nice! :slight_smile:
I guess it is a feature of the specific brand or laptop as it does not work for instance with my toshiba laptop.