Unable to create repository

hi team i tyed to install the latest suse on my pc.
But I get the following error:

(mBox form Yast2)
Unable to create repository
from URL ‘cd:/?devices=/dev/disk/by-id/ata-_NEC_DVD_RW_ND-2510A’

Valid metadata not found at specified URL(s)
-Can’t hardlink/copy /var/adm/mount/AP_0x00000001/media.1/media to/var/cache/zypp/raw/cd-8cdaff0fnu0T/g
-Can’t provide /media.1/media

Try again?

when i try again and say him its an DVD i get same error only one change in this line:
Unable to create repository
from URL ‘dvd:/?devices=/dev/disk/by-id/ata-_NEC_DVD_RW_ND-2510A’

here u can see the image i made from this error:
ImageShack® - Online Photo and Video Hosting

Could u please help me in this Issue? Im sure the iso isn’t broken and im also sure that the dvd is ok couse i downloaded it a second time and burned it a sec time to dvd but without any changes

(mBox form Yast2)
 Unable to create repository
from URL 'cd:/?devices=/dev/disk/by-id/ata-_NEC_DVD_RW_ND-2510A'

Hello as I see in message, you must check your media.

See the picture


Im not sure that this is a soution. I get this error with 2 separeted dvds both isos are from different downloads. But i will try this today.

It is not the solution, but we check all possibilities and efforts to solve this problem. So try to check your media.

ok i get the following error:
Error reading sector 614608 This DVD is broken

So you have a bad download or a bad burn. Check the checksums of the ISO as instruction on the download page. Burn the iso image as slow as you can on quality media.

ok i mean its a bad idea of downloading it compleetly couse i whasted 2 dvds now.
At least i did aNetwork installation of Suse and it works now.