Unable to create repository...

Let me preface this with letting you know it’s a rant so feel free to ignore.

Ok, so I’ve tried downloading, burning it to a DVD, and installing twice now and both times I get to the Unable to create repository from UR cd:/// blah blah blah. I’ve done google searches on this issue and it seems to be very common dating back to releases of Opensuse last year.

Since it takes hours to download and a fair bit of time to burn it to a DVD and get to the point in installation where this error message appears, I find this to be a very troubling experience. My searches on the web and on these forums lead to people being told that they are using cheap DVDs, or that they need to go through complex verification processes before they should burn the iso to a DVD.

I would assume a fair number of people never have this problem, but my searches have shown it to be common enough that it really needs to be fixed. I’m still testing out distros and deciding if I can get myself to “like” Linux. I’m willing to spend excessive amounts of time getting it to run the way I want after it is installed. But spending several hours, over several days, just trying to get a functional ISO and installation DVD, is ridiculous. This type of problem has never happened to me with Mepis, Ubuntu, or Mandriva.

Rant over, feel free to advise, flame, or ignore me. I just had to get that off my chest. I honestly would like to give OpenSuse a shot, I just can’t do that without being able to install it.

Send me a PM with your location.

Maybe your DVD hasn’t been burned correctly. If you startup from your DVD you might to a media check which is an option in the list which you get upon booting from the DVD. If you get errors, your DVD is faulty.

If the validation succeeds, some other unknown issue has bitten you.

Yeah, I ran the test on it. The DVD is a verified coaster. I tested the ISO on Virtual PC with the same results. Had I known this type of problem was so common I would have used Virtual PC first. In the future, that’s what I’ll be doing to avoid coasters.

I have the same problem.
But i tried to install from hdd:

I downloaded openSUSE-11.0-DVD-i386.iso, checked md5, when start from hdd openSUSE11_0_LOCAL.exe. Rebot, lanch installation, when choose “from hdd”, after also get message “Unable to create repository”.
I have two ide hdd, and fund in forums people discuss similar problem connecting that to having two hdds.

Update: I placed iso to another hdd and left eng lang (used russian lang before) and i was finnaly able to continue instalation(don’t know what helped me).

But now got stuck with partioning. Opensuse is not my choise. Going back to Mandriva. :frowning:

Ok, after turning two DVDs into coasters I’ve just stuck with testing every ISO image out on a virtual PC before burning everything. I’m up to 4 ISOs now. 3 were downloaded directly from the ftp, one was downloaded through a torrent. All of them have been OpenSuse 11 and every single one has failed. The test always says the DVD is Broken. By using Virtual PC and mounting the image I’m removing the possibility of a bad DVD or a poorly burned DVD from the picture.

For some reason every single image I download is crap. Can anyone explain to me why this keeps happening? I have one last image downloading from the ftp now and it is the last attempt I can make at this. Each download takes several hours, followed by another hour of checking running it on virtual PC to find out the image doesn’t work.

0 for 4 is pretty horrible numbers and I see plenty of others on this forum complaining about failed installations as well. Surely OpenSuse couldn’t have developed this community if everyone had this problem. Is there some secret trick you guys know that actually works to get a decent ISO?

Have you tried using the metalink, there is a howto at Released Version - openSUSE

Did you pm harryc56 He might send you a working dvd.iso

Thank you all for your advice. Since it’s really frustrating to solve this prob, I have just installed a 10.2 version instead. Future upgrade to 11.0 might be easier hopefully.


Ok, i am really new at installing operating systems, and i have a windows vista that i am trying to install 11.0 on it. I had it downloaded through torrent, and i installed it to my pc. I had it mounted on daemon tools but i think it doesnt work that way when you reboot it. Next i rebooted the system and it gave me the choice of windows or opensuse and i went back to windows for more info on it. I rebooted it again because there were windows updates, now whenever i turn it on it stll gives both options, but it still automatically trys to install linux the rest of the way and it does that every time even if i dont choose that option. It will not allow me to go back to windows. I then assumed my only way to go now was linux. I had the dvd burnt right and checked it but i dont know how to change settings and things, and i dont quite have os jargon down. sorry. Heres the error message.

unable to create repository for ‘dvd///’ (thats not the whole thing i would have to turn on the pc rignt now to see the whole message but i think i can just get a perfect dvd once and it wont matter)

I think i have two coasters but i dont know if they are the right kind of dvds to do this with and i dont know about burning software. One of the dvds is just plain broke, because it has cracks in it that i can see.
Can someone give me the names of programs and dvds i can write an iso to that has little room for faliure or that worked for them? Also, i see that IE internet cannot download this iso, but it would be better if i used a different browser? Or does it not matter what browser if youre using utorrent? If someone whould give me specific directions that would be great but its ok if you cant. I have one other pc along with my laptop i am using now.
Thanks, i see this problem in the past posts has not quite been solved yet.

ok i just fixed it. I downloaded using cdlive and it worked almost perfectly. The only thing is i dont know if i had the partrition drive settings right, and i am very new to this os

OpenSUSE automatically creates a default partition setup, which in most cases works fine. It will allocate the space you have available and divide it up between three partitions: the /home, the swap and the /, or root partition. The swap partition takes up as much space as you have of RAM. IE: if you have 1GB of RAM, the swap partition will be around or close to 1GB. The root partition is created with as much space as YaST predicts necessary to your system, and the bulk of the space (usually more than 50%) is left for the /home partition, which will store all your personal information, such as documents, images the rest of the files that each user on your system may have.

If you want to change the setup for your partitions, when you install OpenSUSE, there will be a sections (called Disk on the left-hand column) that shows you the partition setup that YaST (Yet another System Tool, the backbone to the system configuration and package installation for OpenSUSE) has suggested for you. To change this setup, press the Edit Partition Setup… button to open the partition editor, which will show you all the information on your current partitions. To change the size of your partition, select a partition by clicking it and press the Resize button on the right-hand side of the cluster in the center of the screen to open the resizing window. Here, you can move the scale-looking button (similar to the volume control button on your desktop) in the center of the new window to either make the partition smaller or bigger. You can also enter an exact integer into the menu to the left of the scale. Once you have made the changes you want, press the OK button in the resize window, and then the Next button in the Expert Partitioner screen to save the changes. Once YaST2 refreshes the setup you have created, the box in the top-center of the screen should say (or similar to the following)…

create swap partition /dev/sda1 (xxx.xMB)
create root partition /dev/sda2 (x.xGB) with ext2
create partition /dev/sda3 (x.xGB) for /home with ext3

Just replacing the Xs with numbers.

Sorry for the really long post.

Hope that helps you.:slight_smile:

no, really… thanks for that. i think it is partritioned correctly but now i see another thing that i dont know about. Are you supposed to be able to “go back” into windows? at the startup there are options opensuse, windows 1, windows 2, and opensuse failsafe or something like that. When i go to the Windows 1 it always has tried to go through the dvd version of installation of opensuse and will not go to windows. (as i think i kind of messed it up with that) it froze the last time i chose windows 1. Windows 2 is the recovery for windows i think, but i dont know if i can ever get back to windows or not or fix things about it. I have files and progs on there that i would like to have on this (opensuse) but i cannot insall anything for lack of internet on it. I really dont know how to configure the network with my other vista (main pc hooked up to internet). it would be wireless,(opensuse pc) but i dont know how to set it up. It was set up before i tried to install opensuse, but i cannot use the same hardware. im using a netgear wireless-g adapter wg311. i dont think opensuse can run its software either. they are made for windows only it says on the box but idk.
ps: i have all vista’s. One main pc, a laptop (im using now) and the one with opensuse now installed (also used to be vista). Thanks for the help.

Can I just clarify…

The bootscreen you have described is when you are booting from the harddrive NOT the liveCD?

When you choose the openSUSE option it takes you through to the openSUSE desktop ok?

When you choose windows1 it resumes the DVD install you had previously tried?

In openSUSE open a terminal, login as root by typing in su, enter, then your root password. Then type in fdisk -l. Post the results here.

yes to the questions, and heres the results in the terminal…

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x1549f232

Device Boot Start End Blocks Id System
/dev/sda1 * 1 28657 230179320 7 HPFS/NTFS
/dev/sda2 28657 59562 248252413+ f W95 Ext’d(LBA)
/dev/sda3 59563 60801 9952267+ 7 HPFS/NTFS
/dev/sda5 28657 28918 2104452 82 Linux swap/Solaris
/dev/sda6 28919 31529 20972826 83 Linux
/dev/sda7 31530 59562 225175041 83 Linux

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 8225280 bytes
Disk identifier: 0x1549f232

Device Boot Start End Blocks Id System
/dev/sda1 * 1 28657 230179320 7 HPFS/NTFS
/dev/sda2 28657 59562 248252413+ f W95 Ext’d (LBA)
/dev/sda3 59563 60801 9952267+ 7 HPFS/NTFS
/dev/sda5 28657 28918 2104452 82 Linux swap / Solaris
/dev/sda6 28919 31528 20972826 83 Linux
/dev/sda7 31530 59562 225175041 83 Linux

Thanks. Someone with more expertise on partitioning might help here but I have a openSUSE/Windows XP setup and dont have the partition you have on sda3. Perhaps its a vista thing?

The next thing that might help is to see your grub menu. The easiest way to get it is YaST > System > Boot Loader > Other > Edit Configuration Files. Then from the drop down list view /boot/grub/menu.lst. Copy the file contents and post.

ahh i see, i dont know how to edit it (if thats what i should or could do) to get back onto windows without the dvd setup loading. (if thats what you can even do.) lol! theres so much i dont know about this system or multiple systems for that matter.

One other think about the internet, and network. I dont know how to set it up between my main pc and the opensuse.

Just copy the contents and paste them into a post here and we’ll have a look

Modified by YaST2. Last modification on Fri Jul 18 09:10:42 EDT 2008

default 0
timeout 8
gfxmenu (hd0,5)/boot/message

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.0
root (hd0,5)
kernel /boot/vmlinuz- root=/dev/disk/by-id/scsi-SATA_WDC_WD5000AAKS-_WD-WCAS83271633-part6 resume=/dev/sda5 splash=silent showopts vga=0x31a
initrd /boot/initrd-

###Don’t change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
rootnoverify (hd0,5)
chainloader (hd0,0)+1

###Don’t change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
rootnoverify (hd0,5)
chainloader (hd0,2)+1

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.0
root (hd0,5)
kernel /boot/vmlinuz- root=/dev/disk/by-id/scsi-SATA_WDC_WD5000AAKS-_WD-WCAS83271633-part6 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe vga=0x31a
initrd /boot/initrd-