Unable to create Raid 5 disks

I’ve got 3 extra disks on OpenSuse 11.2 - all the same size. I’ve created a partition on all of them as type 0xFD.

If I then try and add raid in yast I get " There are not enough suitable unused devices to create a RAID."

What am I missing?

Post a screenshot of the stage where you got stumped.

Here’s a pic of my drive setup and one of the error

Your links don’t work, they just go to the home page of freeimagehosting.net.

Sorry - fixed.

Maybe because you pre-created the partitions?? Try letting the partitioner create the partitions.

Yes, I think gogalthorp has got it. RAID partitions aren’t just a special partition ID, they have a special block with metadata. So just delete those partitions and let the installer create them. The installer is quite capable, no need to “prepare” the disk with another program ahead of time.

You may even need to zero out the partition table (at least LVM wants this as a security against unwanted usage of a complete disk).

Still doesn’t work - I’ve deleted the partitions and run yast again - still get the same error when adding under raid.

Looks like it might be a bug or something when doing it via yast.

I used the command like tool mdadm and it created it fine.

mdadm --create /dev/md0 --level=5 --raid-devices=3 /dev/sdb /dev/sdc /dev/sdd

Very odd - but its created and I"m now busy formatting, so all looks good.

You should report this so it will get fixed.

Submitting Bug Reports - openSUSE

Thanks - I’ve submitted it.

Problem solved - I’ve upgraded to the latest version of the yast partitioner and its now all working as expected.

So it was a Yast bug. Good to know. Thanks.