Unable to connect with OpenVPN -Please assist


How do I connect to OpenVPN in SUSE 12.1?

I tried running

 sudo /usr/sbin/openvpn [path-to-conf-file]

But I can’t load any pages after I insert my username and password.

I also tried running NetworkManager as root from the terminal, but with the same result.
I would prefer to get this working with NetworkManager but I definitely want this working in whatever way possible.

Please assist.


EDIT: It connected fine in Ubuntu


Do you have your cert-file (USERNAME.crt) in the same directory as your config-file or does the config-file point to the right file?
Same goes for your “USERNAME.crt” file.

cd /etc/openvpn
sudo /usr/sbin/openvpn CONFIGFILE.ovpn

I keep all config-files, keys and other openvpn-whatnot in “/etc/openvpn/” and I have to execute the command there or change the config-file to use absolute paths to cert/key.

Here is an example of a working config-file but you probable have other config options:

proto udp
dev tun
ca ca.crt
dh dh2048.pem
cert USERNAME.crt
key USERNAME.key
remote servername.xxx 1191
cipher DES-CBC
verb 2
mute 20
keepalive 10 120
resolv-retry infinite
ns-cert-type server

Kind Regards Thermal…

Hi Thermal. :slight_smile:

I have two files in my /etc/openvpn folder.
The .conf and the .ca.crt.

My VPN-provider said I must enable VPN through NetworkManager but that didn’t work. Starting NM with root privileges helped but ran into the same problem as with the CLI.

Do I need anymore files in that folder with the other two? Thermal mentioned a USERNAME.crt file.
Thanks. :slight_smile: