unable to connect via Konsole

I have a static ip + proxy setup.I am unable to connect to the internet via Konsole. The ping command works but wget or svn or git does not seem to work.:frowning:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

So that’s a good start, but can you give a bit more information? There’s
nothing here to really troubleshoot with. ‘ping’ uses ICMP packets, which
are not the same (not even the same layer) as TCP/UDP packets. Also you
didn’t specify how you did your ping or wget. Was your ping to something
local and your wget to google.com? Was your ping to an IP address and
your wget to a DNS name? Did you do your wget right after booting and
your ping an hour later once you’d fixed the network? Some of the answers
to these may be obvious to you but others are not. If you are, for
example, able to ping ‘www.google.com’ but cannot use ‘wget’ to the same
then the problem is probably a proxy issue since routing and name
resolution work, but whether or not wget understands proxies in your setup
is something you’ll need to verify.

Post the output to the following for starters:

ip addr sh
ip route sh
cat /etc/resolv.conf
ping 74.125.67.100
ping google.com

Good luck.

thisisravi wrote:
> I have a static ip + proxy setup.I am unable to connect to the internet
> via Konsole. The ping command works but wget or svn or git does not seem
> to work.:frowning:
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQIcBAEBAgAGBQJJ2jdeAAoJEF+XTK08PnB5uXUP/0cQPcU1nYNuukjIRnFtkq6T
aHXRGrKLC6KP5AekrFLVZOe8s5GIDa8YtOw7Kd2VbgMQAH3e07E1m2B9b9AI8cTQ
iCbuGU20NCcqPCJn27vnCiljMmjLRDXcyzD7J+TD+btdOyYHuIL/3l9RowQorDTa
HxcV2vrshRg+lN7xGd+DMDmnQqeZhL+M9W6tGB1YjIG7FMjriIzuEfQ4qvoPMQRx
NJu06A+uMJHmRmkORnNIClBLrvA/JaYgWqaqsIj1AXJbnBWR7kjTXZmOptKhPtVA
4hTe2v2eSVJcKRfaA/CoCbS9jvgJrMi3NJ49JiDTAhXDQlbyy6HVGPbcmtlOMxkC
OV3TXf4APKYBgrskboyLo3Hpjx6U4rfMRtRY0+cIkUic+ZrGumsBS4f3zYfu8qy5
Do+H7yiHPg0u3lbezV4banEklgl4Mc/F14yIFKZloLVSFId9pN+SWK0S/dT0UwJg
csfHAoo3QQFm+Htbm0O99V9Rkxfe8xI54uT1UadlQRDvnMhaa1ydFOq4bFHudmS1
sGj6iNbRqf8MVwv2J2j9uUBNawrOFCYQnAssVwDk/Ce0SDw1wQY11cILRpzNoNkj
En+YGfD8enfLaSke/bOKV+UTXpe+53BLan+FUZKNvc1P8fyCIwScWMp+YlsMj4T4
pc0gCg8Xky3MM2nQo9I2
=pujI
-----END PGP SIGNATURE-----

wget http://www.google.com]Google is stuck at:


--2009-04-06 22:54:53--  http://www.google.com/
Resolving www.google.com... 209.85.143.99, 209.85.143.147, 209.85.143.104
Connecting to www.google.com|209.85.143.99|:80...

The outputs of other commands:
ip addr sh:


1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
    inet 127.0.0.2/8 brd 127.255.255.255 scope host secondary lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:16:d3:ba:71:e5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.14.94/16 brd 192.168.255.255 scope global eth0
    inet6 fe80::216:d3ff:feba:71e5/64 scope link
       valid_lft forever preferred_lft forever
3: wmaster0: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ieee802.11 00:1b:77:8c:f6:72 brd ff:ff:ff:ff:ff:ff
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:1b:77:8c:f6:72 brd ff:ff:ff:ff:ff:ff
5: pan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN
    link/ether 66:f6:1c:90:71:ba brd ff:ff:ff:ff:ff:ff

ip route sh


192.168.0.0/16 dev eth0  proto kernel  scope link  src 192.168.14.94  metric 1
127.0.0.0/8 dev lo  scope link
default via 192.168.3.254 dev eth0  proto static

cat /etc/resolv.conf


### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search iiitb
nameserver 192.168.3.254

ping 74.125.67.100


PING 74.125.67.100 (74.125.67.100) 56(84) bytes of data.
64 bytes from 74.125.67.100: icmp_seq=1 ttl=242 time=307 ms
64 bytes from 74.125.67.100: icmp_seq=2 ttl=242 time=305 ms
64 bytes from 74.125.67.100: icmp_seq=3 ttl=242 time=511 ms
64 bytes from 74.125.67.100: icmp_seq=4 ttl=242 time=303 ms
64 bytes from 74.125.67.100: icmp_seq=5 ttl=242 time=305 ms
64 bytes from 74.125.67.100: icmp_seq=6 ttl=242 time=433 ms
^C
--- 74.125.67.100 ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5023ms
rtt min/avg/max/mdev = 303.164/361.051/511.383/81.917 ms

ping google.com


64 bytes from gw-in-f100.google.com (74.125.67.100): icmp_seq=1 ttl=242 time=311 ms
64 bytes from gw-in-f100.google.com (74.125.67.100): icmp_seq=2 ttl=242 time=549 ms
64 bytes from gw-in-f100.google.com (74.125.67.100): icmp_seq=3 ttl=242 time=306 ms
64 bytes from gw-in-f100.google.com (74.125.67.100): icmp_seq=4 ttl=242 time=302 ms
64 bytes from gw-in-f100.google.com (74.125.67.100): icmp_seq=5 ttl=242 time=307 ms
64 bytes from gw-in-f100.google.com (74.125.67.100): icmp_seq=6 ttl=242 time=303 ms
64 bytes from gw-in-f100.google.com (74.125.67.100): icmp_seq=7 ttl=242 time=306 ms

I guess the problem is with the proxy as ping http://www.google.com]Google works but not wget http://www.google.com]Google. But i am able to add repositores,install software etc correctly. They must all use the same proxy(in my case=192.168.3.254) right?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Yes, good analysis at this point. wget, as you can see from your other
post, even resolves the IP address but then something fails during the
connection. If you have a system-wide proxy server setup then it is
likely that Yast and other applications can see those, but wget is not
getting that far (it’s a simple command and as a result is great for
testing without a proxy user, or using one if specific, but may not know
how to get the system setting).

Checking the man page for wget I can’t figure out how to specify a proxy
server though I do see options that look fairly intuitive for ‘curl’ so
you may want to try that.

Good luck.

thisisravi wrote:
> I guess the problem is with the proxy as ping
> http://www.google.com]Google works but not wget
> http://www.google.com]Google. But i am able to add repositores,install
> software etc correctly. They must all use the same proxy(in my
> case=192.168.3.254) right?
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQIcBAEBAgAGBQJJ2kGlAAoJEF+XTK08PnB5NUcP/Rsw6gKrG/fDhJylPeVs9Bh2
g0jeL11a1sX/CNSdc3jsdQPwunuEDdEBiXJQbb1hL5Q0vAwxTRQmuv7480dEUUl1
EU9VBt8jOHtVR6R+G6/3GQIbZLrqnZZUpRswwmsS3dbaZLE7P/KkzbMv9mFuwT+A
zqcOAj7C+7+31kKum4cNyb2THDVMmho5Z1tCVjNE63GJz9ZDznIAMneh+Kk4fEgk
Crm1rcdMD0i5MIdV/MWSev2nxCCmboVFx8UY5WwBw/aNCXNsqPE9Q1hHCBHJpb4H
l+Vp21OnMrzik2OSZj3pGGh1ptQI0HlgNx1YCK3vlomnnNkxaymDGx3CgL+aN56K
i3Ij3aXCTev/FMYhcIBsMi9niCNjt4rk7GOjlMierk+MT5yHoeU/ibOIV+u53CGK
L3RXAAsMStRiBaCwmJeLRjvtZF9X4RfXwx7tiDxqJ1+XBC2I8Lr0f+iU8hu38Dzp
osHwmXdyWnFefyfhi0Kl/B5K5jvJh6wmNOJ1XeQMDfqYiqjiTnK4NQeeTC7rgxAi
TzP57nPML7UBSxQkBmCV8hiXNoBWZ3hNWMFrrj5aOE7hW/Y6p5tJwi01tC/biwS3
zGaUtlkq91WardaI7pO1u5GvnX93a52qpEyfGmm5cdyBUp2iUgLRFPBp97fQG+ir
vv1O/NCVd9zdFmfxrvSx
=fqCW
-----END PGP SIGNATURE-----

thisisravi wrote:
> I have a static ip + proxy setup.I am unable to connect to the internet
> via Konsole. The ping command works but wget or svn or git does not seem
> to work.:frowning:

The programs you mention honour the http_proxy environment variable and
others. Configure them system wide via YaST / Network Services / Proxy.

Kind regards,
Andreas Stieger

@Andreas,
Yes, I had done that, which is why the other programs worked.

I found that the commands work fine when i invoke a root shell. But it fails in the normal shell or even if i type ‘su’ and become root from a normal shell.

Help please!Really getting bugged now.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

How is your environment different in each case? Compare the output of the
‘env’ or ‘set’ command.

Good luck.

thisisravi wrote:
> I found that the commands work fine when i invoke a root shell. But it
> fails in the normal shell or even if i type ‘su’ and become root from a
> normal shell.
>
> Help please!Really getting bugged now.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQIcBAEBAgAGBQJJ211uAAoJEF+XTK08PnB5zOsP/1c02puD2OJofXWI2NCak9FK
8wD5bmR1c3xr8R1F86PT1+hnIsAWg+P3a/qBHbSDmmjCFpNelH57tWhlPswqWwlP
i9p6gz5E5tb0I+jP4NchYTZ3NSJZSYzqWtVT6kL7/X9/vVqvITNmmIeaim9t+eZr
gAJqBmWjZ/bt8KL2OzMekc5Rg2hqhSMLbErzXiUEbiCKXvG/eox8WGt87KWakJwg
Xf5I3JUrf+O9xGoIeI5UdrlVREpWD2OgNWLw+b52V3DE6W0rUC5VCU3ALgxDO1pS
E9DXauBqLWIAsX1XeQ0UxokM9H7jyg9Q3wJzOEQ1aNvlSjLNxxEna75IXLpbc/w2
E4325wLm0yUl6yvr0lHwYOiUF65IxwbvoxKW5DKpwatcIhjWZH0OtZLtESsBomJG
9RVfOKkMOj6OIVv0PlGupafPXdEkVGtvozyApw2lkOFCmoJyBGPCunp+y6xF1c5i
RCr8b+NZkXVgj2HTF+vNTWQSWfETlSTmS4u247nnTzF2o7B+zQQ1o6lW8BCvTNPk
rf9poQN3VlLs/QFxRgMprPMc9Ukb1625yWYOssB1IxvdaphMT19cn16y8QkR3BgG
sHDCz1Xe/UDYnaIEB17wnJTk1fR9sP3XgPhYYCTGAG0kJw5r+AIxKKPbajrauUrf
s69UjTRT4yVKDPOF13Xc
=wPLi
-----END PGP SIGNATURE-----