unable to connect to wireless network after kernel update

Hi all,

I am new to opensuse. So bare with me if i sound stupid.

I was able to connect to my wireless network b4 updating ( updated using the command “sudo /usr/bin/zypper update”)
But now I am unable to connect to my wireless network… however I am able to connect to the public wireless networks (which do not require any authentication)

dmesg | grep firmware
firmware: requesting b43/ucode13.fw
firmware: requesting b43/b0g0initvals13.fw
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)

iwlist scan output (only part of it)
Cell 01 - Address: 00:20:A6:53:33:B4
ESSID:“STFrancis 302E Bb”
Mode:Master
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=53/100 Signal level:-88 dBm Noise level=-73 dBm
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=00000113bfda1037
Extra: Last beacon: 40ms ago
Cell 02 - Address: 00:1E:C7:DE:41:B9
ESSID:“2WIRE758”
Mode:Master
Channel:4
Frequency:2.427 GHz (Channel 4)
Quality=58/100 Signal level:-82 dBm Noise level=-73 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=0000000d439c9181
Extra: Last beacon: 376ms ago

I am not sure what the problem is but i think it has to be something related to the network management applet ( correct me if i am wrong) ,

Any help in this regard is greatly appreciated.

Thanks

Bhargava

I thought this information might help
uname -a
Linux conundrum 2.6.27.21-0.1-default #1 SMP 2009-03-31 14:50:44 +0200 i686 athlon i386 GNU/Linux

Thanks

Bhargava

bhargavalinux wrote:
> Hi all,
>
> I am new to opensuse. So bare with me if i sound stupid.
>
> I was able to connect to my wireless network b4 updating ( updated
> using the command “sudo /usr/bin/zypper update”)
> But now I am unable to connect to my wireless network… however I am
> able to connect to the public wireless networks (which do not require
> any authentication)

I think you are suffering from the bug that was introduced when a security hole
was plugged in dbus.

What do you see if you enter the command


ls /var/run/dbus/at_console/

There should be one entry for your login name. If you see one for root, delete
it. Does that help?

If there was no root entry, or if removing it didn’t help, please try the
following command:


sudo dbus-send --system --print-reply \
--dest=org.freedesktop.NetworkManagerUserSettings \
/org/freedesktop/NetworkManagerSettings/Connection/0 \
org.freedesktop.NetworkManagerSettings.Connection.Secrets.GetSecrets

If this command generates an error, then the dbus security is the problem.

Larry

Thanks for ur reply larry,
There was no entry of the root
(ls /var/run/dbus/at_console/)

"sudo dbus-send --system --print-reply
–dest=org.freedesktop.NetworkManagerUserSettings
/org/freedesktop/NetworkManagerSettings/Connection/0
org.freedesktop.NetworkManagerSettings.Connection.Secrets.GetSecrets

when I tried the above command i got the following messege
“Error org.freedesktop.DBus.Error.UnknownMethod: Method “GetSecrets” with signature “” on interface “org.freedesktop.NetworkManagerSettings.Connection.Secrets” doesn’t exist”

so what does that mean and what should i do to solve it ( if thats a problem)

Thanks

Bhargava

bhargavalinux wrote:
> Thanks for ur reply larry,
> There was no entry of the root
> (ls /var/run/dbus/at_console/)
>
>
> "sudo dbus-send --system --print-reply
> --dest=org.freedesktop.NetworkManagerUserSettings
> /org/freedesktop/NetworkManagerSettings/Connection/0
> org.freedesktop.NetworkManagerSettings.Connection.Secrets.GetSecrets
>
> when I tried the above command i got the following messege
> “Error org.freedesktop.DBus.Error.UnknownMethod: Method “GetSecrets”
> with signature “” on interface
> “org.freedesktop.NetworkManagerSettings.Connection.Secrets” doesn’t
> exist”
>
> so what does that mean and what should i do to solve it ( if thats a
> problem)

That is the error. It means that NetworkManager cannot get your WPA secret, thus
it fails to authenticate.

The next things to try are a little more complicated:

As root, edit /etc/dbus-1/system.d/knetworkmanager.conf. In that file, whenever
you see a “deny”, change it to “allow”. There should be three of them. Then try
the “sudo dbus-send” command again. If that still gives an error, then edit
/etc/dbus-1/system.d/NetworkManager.conf and change the first deny to allow. If
that still doesn’t work change all the rest.

With each of these changes, we are opening a security holes, but having your
wireless work is probably more important than total security. In addition, the
only hole opened is one where the invader would get your WPA secret, but they
cannot get into your machine without already having that info.

Larry

does openning the hole effect the security to a large extent … does it make my machine vulnerable to malware ,virus or human hackers…

Thanks

Bhargava

bhargavalinux wrote:
> does openning the hole effect the security to a large extent … does it
> make my machine vulnerable to malware ,virus or human hackers…

The only effect that I know about is that someone at your console could use that
db-send command to get your WPA key. There would be little possibility that
someone from the Internet could penetrate your system through this hole UNLESS
you have enabled sshd from the Internet (really bad move), AND your passwords
have been compromised.

FWIW, NetworkManager has always had this hole. The recent updates closed it.

Thank you very much … That was helpful


Bhargava

bhargavalinux wrote:
> Thank you very much … That was helpful

Can I conclude that your WPA connection is working again?

Larry

it worked fine when i did that … but there were some update again and the problem repeated again … i’m trying to repeat the process again i’ll post the result ASAP…

Thanks

Bhargava

I got the wireless network working again (i 'av no idea how???) but the command still shows the same error …
and one more thing i did not have /etc/dbus-1/system.d/knetworkmanager.conf file so i changed the next file that u menationed (/etc/dbus-1/system.d/NetworkManager.conf) there were 6 deny(s) (3 for ppp i guess …) so i changed all of them to allow… the error still persists … but I am able to connect to my wireless network. So what should I do to remove the error

{ if the k in knetworkmanager is for kde then i should tell u i am using gnome}

Thanks
–Bhargava

bhargavalinux wrote:
> I got the wireless network working again (i 'av no idea how???) but the
> command still shows the same error …
> and one more thing i did not have
> /etc/dbus-1/system.d/knetworkmanager.conf file so i changed the next
> file that u menationed (/etc/dbus-1/system.d/NetworkManager.conf) there
> were 6 deny(s) (3 for ppp i guess …) so i changed all of them to
> allow… the error still persists … but I am able to connect to my
> wireless network. So what should I do to remove the error
>
> { if the k in knetworkmanager is for kde then i should tell u i am
> using gnome}

Yes, the k is for KDE. What files are in /etc/dbus-1/system.d on a Gnome-based
system?

As long as it connects, we can ignore that the dbus-send command errors. Perhaps
the Gnome connection is different; however, I thought that came from
NetworkManager, not the applet.

Larry

ls /etc/dbus-1/system.d/
avahi-dbus.conf nm-dhcp-client.conf
bluetooth.conf nm-dispatcher.conf
ConsoleKit.conf nm-system-settings.conf
cups.conf org.freedesktop.ModemManager.conf
gdm.conf org.freedesktop.PackageKit.conf
hal.conf org.freedesktop.PolicyKit.conf
NetworkManager.conf org.gnome.ClockApplet.Mechanism.conf
newprinternotification.conf org.gnome.GConf.Defaults.conf
nm-applet.conf org.opensuse.yast.SCR.conf
nm-avahi-autoipd.conf wpa_supplicant.conf

bhargavalinux wrote:
> ls /etc/dbus-1/system.d/
> avahi-dbus.conf nm-dhcp-client.conf
> bluetooth.conf nm-dispatcher.conf
> ConsoleKit.conf nm-system-settings.conf
> cups.conf org.freedesktop.ModemManager.conf
> gdm.conf org.freedesktop.PackageKit.conf
> hal.conf org.freedesktop.PolicyKit.conf
> NetworkManager.conf org.gnome.ClockApplet.Mechanism.conf
> newprinternotification.conf org.gnome.GConf.Defaults.conf
> nm-applet.conf org.opensuse.yast.SCR.conf
> nm-avahi-autoipd.conf wpa_supplicant.conf

It appears that there is no Gnome equivalent of knetworkmanager.conf. I too have
a copy of nm-applet.conf in which there is a “deny” that was changed to an
“allow” - at least I have a …orig with a deny in the “at_console” stanza.

Larry