Unable to connect to network printer with IPP protocol

I’m trying to connect to a Canon ImageRunner (can no longer remember the exact model number…) network printer.

First I had to look for background regarding the topic; and I read that the most common protocols used for network printers are AppSocket/JetDirect and IPP, of which the second one was more recent and more “suggested” unless printer didn’t support it.

This MF box does support IPP and is indeed enabled. But before even attempting to install it, I wanted to test the IPP connection beforehand. I read this was done with

ipptool ipp://<ip_addr>/ipp <any>.test

But no matter how I tweak with the command, I always get error “Operation now in progress”.

Also I noticed in the printer settings that the IPP section has user and password fields…

Is it that IPP actually works with authentication? Or is the problem something else?

Thanks beforehand.

Assuming the network printer is on the same network (broadcast domain), check if it is discovered using…

sudo lpinfo -v

*You may need to check that your firewall is disabled (or suitably configured) first before trying the above.

Thanks very much sir!
The firewall was the issue; just needed to temporarily disable it.

If applied here as well, someone please mark the thread as “solved”.

Good, that is what usually trips users up.

If applied here as well, someone please mark the thread as “solved”.

We don’t typically do that here, but you’re welcome to reflect that in the title on your last post.