Unable to connect to Linksys WRT200N Router

I have two wireless routers (DlinkVWR that originally was bought to support my Vonage line and Linksys WRT300N V1.1 I bought for ‘N’ capability). I have both set up with WPA2 encryption (same passphrase). On the PC I have a Hama Wireless N PCI card based on the rt2860 (btw, openSuse is the first distro I have tried that worked right out of the ‘box’). I can connect with no problems whatosever to the Dlink router, but am unable to connect to the Linksys! In other distros (Ubuntu and Mint) I have successfully connected to the Linksys using NDISWrapper.

Any thoughts?

Thanks, Marc

You may try this first:

My wireless doesn’t work - a primer on what I should do next - openSUSE Forums

Oops, too fast. The problem is not your wireless card, but detecting the AP, right?

Did you try ‘iwlist wlan0 scan’ without quotes, as root? Are both AP’s broadcasting on different frequencies (they should be different, as apart as possible)?

Thanks to your post, I stumbled across the answer to the problem. When I looked at the output from “iwlist ra0 scan”, I noticed there was a difference in the output for the two routers. After comparision of the router settings, I noted on the Linksys, there is an option to set Wireless security to AES only or AES/TKIP (which I guess the default setting). On the DLinkAES/TKIP not an option. I changed the setting to “AES only” on the Linksys, and voila…connected right away.

Cheers, Marc