Unable to configure dual display

I’m unable to configure dual display setup on my MSI GT60 laptop with dual graphic intelHD4600 & nvdidia. I’m able to set only one display active (either via HDMI or laptop display)

/sbin/lspci | grep -E "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK104M [GeForce GTX 870M] (rev a1)

Opengl configuration also seems to be issue & i notice error ‘Unable to initialize opengl’ error when i access opengl from kde info center. I did remove libvdpau_va_gl1 & confirmed that ‘vdpau-video’ is not installed. I’m not noticing any major error message in Xorg log but i believe my Xorg.conf file may not be setup correctly for dual display configuration. Not sure how to fix the issue

Thanks in Advance for your reply!

here is my list of repo

#  | Alias                         | Name                               | Enabled | Refresh
---+-------------------------------+------------------------------------+---------+--------
 1 | download.nvidia.com-opensuse  | nVidia Graphics Drivers            | Yes     | Yes    
 2 | download.opensuse.org-non-oss | Main Repository (NON-OSS)          | Yes     | Yes    
 3 | download.opensuse.org-oss     | Main Repository (OSS)              | Yes     | Yes    
 4 | ftp.gwdg.de-suse              | Packman Repository                 | Yes     | Yes    
 5 | google-chrome                 | google-chrome                      | Yes     | Yes    
 6 | libdvdcss repository          | libdvdcss repository               | Yes     | Yes    
 7 | openSUSE-13.2-0               | openSUSE-13.2-0                    | No      | Yes    
 8 | packman-essentials            | packman-essentials                 | Yes     | Yes    
 9 | repo-debug                    | openSUSE-13.2-Debug                | No      | Yes    
10 | repo-debug-update             | openSUSE-13.2-Update-Debug         | No      | Yes    
11 | repo-debug-update-non-oss     | openSUSE-13.2-Update-Debug-Non-Oss | No      | Yes    
12 | repo-source                   | openSUSE-13.2-Source               | No      | Yes    
13 | repo-update                   | openSUSE-13.2-Update               | Yes     | Yes    
14 | repo-update-non-oss           | openSUSE-13.2-Update-Non-Oss       | Yes     | Yes

Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen1" 0 0
        #Screen     1  "Screen1" RightOf "Screen0"
        InputDevice    "Mouse0" "CorePointer"                                                                                                                                                                                                
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection


Section "Files"
        ModulePath   "/usr/lib64/xorg/modules"
        FontPath     "/usr/share/fonts/misc:unscaled"
        FontPath     "/usr/share/fonts/Type1/"
        FontPath     "/usr/share/fonts/100dpi:unscaled"
        FontPath     "/usr/share/fonts/75dpi:unscaled"
        FontPath     "/usr/share/fonts/ghostscript/"
        FontPath     "/usr/share/fonts/cyrillic:unscaled"
        FontPath     "/usr/share/fonts/misc/sgi:unscaled"
        FontPath     "/usr/share/fonts/truetype/"
        FontPath     "built-ins"
EndSection


Section "Module"
        Load  "glx"
        Load  "vnc"
EndSection


Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection


Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection


Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection


Section "Monitor"
        Identifier   "Monitor1"
        VendorName   "Benq"
        ModelName    "GL2460"
        HorizSync     26-81
        VertRefresh   24-75
    # 1920x1080p @ 23.976Hz (EIA/CEA-861B)
        ModeLine      "1920x1080_23.976" 74.11 1920 2557 2602 2750  1080 1084 1089 1124 +hsync +vsync
        ModeLine "1920x1080_24"     74.250 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync
    #Modeline "1920x1080_25"    74.25  1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
    #Modeline "1920x1080_60"    148.35 1920 2008 2052 2200 1080 1084 1089 1125 -hsync +vsync
        Option       "DPI" "96 x 96"
EndSection


Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"                  # <bool>]
        #Option     "Rotate"                    # <str>
        #Option     "fbdev"                     # <str>
        #Option     "debug"                     # <bool>]
        Identifier  "Intel Graphics"
        Driver      "intel"
        option      "AccelMethod"       "sna"
        BusID       "PCI:0:2:0"
EndSection


Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"                  # <bool>]
        #Option     "Rotate"                    # <str>
        #Option     "fbdev"                     # <str>
        #Option     "debug"                     # <bool>]
        Identifier  "NVIDIA Corporation"
        Driver      "nvidia"
        BusID       "PCI:1:0:0"
EndSection


Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
          Depth     24
        EndSubSection
EndSection


Section "Screen"
        Identifier "Screen1"
        Device     "Card1"
        Monitor    "Monitor1"
        SubSection "Display"
          Depth     24
        EndSubSection
EndSection

hi,

have you tried the command

systemsettings5

then setting the monitors up from the Display and Monitor icon

hth it worked for on 64bit PC and laptop

cheers

assuming you are using plasma5 not kde4

Uninstall the nvidia driver and remove the nvidia repo!

You have an Optimus system, the nvidia driver doesn’t support that. Installing it even breaks OpenGL on the intel chip where the desktop runs… (therefore the error message)

If you want to use the nvidia card, you need to install Bumblebee:
https://en.opensuse.org/SDB:NVIDIA_Bumblebee

One exception: if you are able to disable the intel graphics in the BIOS, the standard nvidia driver should work.

And you should remove your Xorg conf and configure the dual display setup in “Configure Desktop”. KDE will ignore and override the Xorg config, unless you disable the KScreen service.

@keellambert:
He didn’t mention anywhere that he is using Plasma5…
Most probably Plasma5 wouldn’t even start correctly on this broken system. :wink: (intel driver + nvidia libglx)

I’m still unable to setup the secondary display properly after installing bumblebee. After removing xorg.conf the Xdisplay manager failed to start (stuck @ boot) & i had to recreate the xorg.conf file to boot into kde session.

optirun --status
Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.


shankar@linux-ya15:~> optirun glxspeheres
  265.686702] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.


  265.686730] [ERROR]Aborting because fallback start is disabled.

It seems like bumblebee is installed but i can’t configure the secondary display now. Do i need to disable KMS by adding ‘nomodset’?

#  | Alias                         | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                          | Service
---+-------------------------------+------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------+--------
 1 | Bumblebee                     | Bumblebee                          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/Bumblebee/openSUSE_13.1/      |        
 2 | X11_Bumblebee                 | Bumblebee project (openSUSE_13.2)  | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/Bumblebee/openSUSE_13.2/      |        
 3 | download.opensuse.org-non-oss | Main Repository (NON-OSS)          | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                 |        
 4 | download.opensuse.org-oss     | Main Repository (OSS)              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                     |        
 5 | ftp.gwdg.de-suse              | Packman Repository                 | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/                     |        
 6 | google-chrome                 | google-chrome                      | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                          |        
 7 | libdvdcss repository          | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                                         |        
 8 | openSUSE-13.2-0               | openSUSE-13.2-0                    | No      | Yes     |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-Corsair_Voyager_AA40000000000275-0:0-part2 |        
 9 | packman-essentials            | packman-essentials                 | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_13.2/Essentials/                       |        
10 | repo-debug                    | openSUSE-13.2-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.2/repo/oss/               |        
11 | repo-debug-update             | openSUSE-13.2-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2/                              |        
12 | repo-debug-update-non-oss     | openSUSE-13.2-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2-non-oss/                      |        
13 | repo-source                   | openSUSE-13.2-Source               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.2/repo/oss/              |        
14 | repo-update                   | openSUSE-13.2-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                    |        
15 | repo-update-non-oss           | openSUSE-13.2-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/                            | 
shankar@linux-ya15:/var/log> rpm -qa | egrep "nvidia"

nvidia-bumblebee-32bit-346.72-1.1.x86_64
nvidia-bumblebee-346.72-1.1.x86_64
shankar@linux-ya15:/var/log> sudo hwinfo --gfx
root's password:
10: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.328]
  Unique ID: _Znp.YNWO7NxmmgB
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Device Name: "Onboard IGD"
  Model: "Intel Haswell Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x0416 "Haswell Integrated Graphics Controller"
  SubVendor: pci 0x1462 "Micro-Star International Co., Ltd."
  SubDevice: pci 0x1106 
  Revision: 0x06
  Driver: "i915"
  Driver Modules: "drm"
  Memory Range: 0xf7400000-0xf77fffff (rw,non-prefetchable)
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
  I/O Ports: 0xf000-0xf03f (rw)
  IRQ: 45 (205 events)
  Module Alias: "pci:v00008086d00000416sv00001462sd00001106bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown


23: PCI 100.0: 0300 VGA compatible controller (VGA)
  [Created at pci.328]
  Unique ID: VCu0.zkW0yM8FdGE
  Parent ID: vSkL.Cq5bkuLnWa5
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia VGA compatible controller"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x1199 
  SubVendor: pci 0x1462 "Micro-Star International Co., Ltd."
  SubDevice: pci 0x1106 
  Revision: 0xa1
  Driver: "nvidia"
  Driver Modules: "nvidia"
  Memory Range: 0xf6000000-0xf6ffffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  Memory Range: 0xf0000000-0xf1ffffff (ro,non-prefetchable)
  I/O Ports: 0xe000-0xefff (rw)
  Memory Range: 0xf7000000-0xf707ffff (ro,non-prefetchable,disabled)
  IRQ: 16 (53 events)
  Module Alias: "pci:v000010DEd00001199sv00001462sd00001106bc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"
  Driver Info #1:
    Driver Status: nvidia is active
    Driver Activation Cmd: "modprobe nvidia"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #9 (PCI bridge)


Primary display adapter: #10

Should i remove libvdpau_va_gl1 since intel vaapi driver is already installed?

And what exactly is in your xorg.conf? The same as before?
You should not need it.

Please post the complete Xorg.0.log, and maybe also one from a failed boot without an xorg.conf.
For the latter, remove/rename xorg.conf again. When the boot fails, put it back and reboot. The log from the failed boot should be in /var/log/Xorg.0.log.old then.

It seems like bumblebee is installed but i can’t configure the secondary display now. Do i need to disable KMS by adding ‘nomodset’?

No, you must not do that in any case.
This will disable the intel driver. Since your desktop will run on intel with Bumblebee, you’d only get a fallback driver (fbdev, vesa) that doesn’t support multiple displays (or OpenGL) at all.

 1 | Bumblebee                     | Bumblebee                          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/Bumblebee/openSUSE_13.1/      |        

Why did you add the Bumblebee repo for 13.1? Remove it!

shankar@linux-ya15:/var/log> rpm -qa | egrep "nvidia"

nvidia-bumblebee-32bit-346.72-1.1.x86_64
nvidia-bumblebee-346.72-1.1.x86_64

That’s ok.
But did you exactly follow the tutorial?
What bumblebee packages do you have installed? Maybe the ones for 13.1?
Try to remove and reinstall them.

And check that bbswitch.service is enabled.

Should i remove libvdpau_va_gl1 since intel vaapi driver is already installed?

libvdpau_va_gl1 is a VDPAU “driver” for intel (actually it redirects to VAAPI).
Some people had problems with it, so uninstalling it might be necessary, but that only applies for watching videos with hardware acceleration.
It doesn’t affect your system in other situations at all.

Thanks for detailed clarification & pointing out the error in the repository. I have removed & reloaded the repository from yast…here is the line entry in 'etc/modprobe.d/50-bbswitch.conf ’

options bbswitch load_state=1 unload_state=1

Here is the error in Xorg log file when i do not have ‘/etc/X11/xorg.conf’ file

   592.765] (EE) No devices detected.
   592.765] (EE) 
Fatal server error:
   592.765] (EE) no screens found(EE) 
   592.765] (EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org

When i h’v the xorg.cong file, the system does boot into kde session & the xorg log file is pasted below. I’m not sure how to resolve this

   5.723] (II) xfree86: Adding drm device (/dev/dri/card1)
     5.724] (--) PCI:*(0:0:2:0) 8086:0416:1462:1106 rev 6, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
     5.724] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
     5.724] (II) LoadModule: "glx"
     5.725] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
     5.734] (II) Module glx: vendor="X.Org Foundation"
     5.734]    compiled for 1.16.1, module version = 1.0.0
     5.734]    ABI class: X.Org Server Extension, version 8.0
     5.734] (==) AIGLX enabled
     5.734] (II) LoadModule: "vnc"
     5.734] (II) Loading /usr/lib64/xorg/modules/extensions/libvnc.so
     5.751] (II) Module vnc: vendor="Constantin Kaplinsky"
     5.751]    compiled for 1.16.1, module version = 1.0.0
     5.751]    Module class: X.Org Server Extension
     5.751]    ABI class: X.Org Server Extension, version 8.0
     5.751] (II) LoadModule: "fbdev"
     5.751] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
     5.752] (II) Module fbdev: vendor="X.Org Foundation"
     5.752]    compiled for 1.16.1, module version = 0.4.4
     5.752]    Module class: X.Org Video Driver
     5.752]    ABI class: X.Org Video Driver, version 18.0
     5.752] (II) FBDEV: driver for framebuffer: fbdev
     5.752] (++) using VT number 8


     5.756] (II) Loading sub module "fbdevhw"
     5.756] (II) LoadModule: "fbdevhw"
     5.756] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
     5.758] (II) Module fbdevhw: vendor="X.Org Foundation"
     5.758]    compiled for 1.16.1, module version = 0.0.2
     5.758]    ABI class: X.Org Video Driver, version 18.0
     5.758] (**) FBDEV(0): claimed PCI slot 0@0:2:0
     5.758] (II) FBDEV(0): using default device
     5.758] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
     5.758] (==) FBDEV(0): RGB weight 888
     5.758] (==) FBDEV(0): Default visual is TrueColor
     5.758] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
     5.758] (II) FBDEV(0): hardware: inteldrmfb (video memory: 8100kB)
     5.758] (II) FBDEV(0): checking modes against framebuffer device...
     5.758] (II) FBDEV(0): checking modes against monitor...
     5.758] (--) FBDEV(0): Virtual size is 1920x1080 (pitch 1920)
     5.758] (**) FBDEV(0):  Built-in mode "current"
     5.758] (==) FBDEV(0): DPI set to (96, 96)
     5.758] (II) Loading sub module "fb"
     5.758] (II) LoadModule: "fb"
     5.758] (II) Loading /usr/lib64/xorg/modules/libfb.so
     5.762] (II) Module fb: vendor="X.Org Foundation"
     5.762]    compiled for 1.16.1, module version = 1.0.0
     5.762]    ABI class: X.Org ANSI C Emulation, version 0.4
     5.762] (**) FBDEV(0): using shadow framebuffer
     5.762] (II) Loading sub module "shadow"
     5.762] (II) LoadModule: "shadow"
     5.763] (II) Loading /usr/lib64/xorg/modules/libshadow.so
     5.763] (II) Module shadow: vendor="X.Org Foundation"
     5.763]    compiled for 1.16.1, module version = 1.1.0
     5.763]    ABI class: X.Org ANSI C Emulation, version 0.4
     5.763] (==) Depth 24 pixmap format is 32 bpp
     6.892] (==) FBDEV(0): Backing store enabled
     6.894] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
     6.894] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
     6.894] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
     6.894] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
     6.894] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument

setting as in display manager

DISPLAYMANAGER_XSERVER="Xorg"
DISPLAYMANAGER="kdm"
DISPLAYMANAGER_STARTS_XSERVER="yes"
DISPLAYMANAGER_AUTOLOGIN="shankar"
DISPLAYMANAGER_KDM_LOCALARGS=""
DISPLAYMANAGER_SHUTDOWN="auto"

Can you please post the whole file? (upload it to http://susepaste.org or similar and post a link, if it’s too big)
This doesn’t tell anything.

When i h’v the xorg.cong file, the system does boot into kde session & the xorg log file is pasted below. I’m not sure how to resolve this

...
     5.758] (**) FBDEV(0): claimed PCI slot 0@0:2:0
     5.758] (II) FBDEV(0): using default device
     5.758] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
     5.758] (==) FBDEV(0): RGB weight 888
     5.758] (==) FBDEV(0): Default visual is TrueColor
     5.758] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
     5.758] (II) FBDEV(0): hardware: inteldrmfb (video memory: 8100kB)
     5.758] (II) FBDEV(0): checking modes against framebuffer device...
     5.758] (II) FBDEV(0): checking modes against monitor...
     5.758] (--) FBDEV(0): Virtual size is 1920x1080 (pitch 1920)
     5.758] (**) FBDEV(0):  Built-in mode "current"
     5.758] (==) FBDEV(0): DPI set to (96, 96)
     5.758] (II) Loading sub module "fb"
     5.758] (II) LoadModule: "fb"
     5.758] (II) Loading /usr/lib64/xorg/modules/libfb.so
     5.762] (II) Module fb: vendor="X.Org Foundation"
     5.762]    compiled for 1.16.1, module version = 1.0.0
     5.762]    ABI class: X.Org ANSI C Emulation, version 0.4
     5.762] (**) FBDEV(0): using shadow framebuffer
     5.762] (II) Loading sub module "shadow"
     5.762] (II) LoadModule: "shadow"
     5.763] (II) Loading /usr/lib64/xorg/modules/libshadow.so
     5.763] (II) Module shadow: vendor="X.Org Foundation"
     5.763]    compiled for 1.16.1, module version = 1.1.0
     5.763]    ABI class: X.Org ANSI C Emulation, version 0.4
     5.763] (==) Depth 24 pixmap format is 32 bpp
     6.892] (==) FBDEV(0): Backing store enabled
     6.894] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
     6.894] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
     6.894] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
     6.894] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
     6.894] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument

So you are actually using the generic fbdev driver (which doesn’t support multiple displays at all), neither intel nor nvidia/nouveau.

Again, a full Xorg.0.log (or Xorg.0.log.old) should give more insight what goes wrong.

If at any time you installed the regular NVIDIA drive and did not full remove all packages things may remain broken. Go to Yast search for NVIDIA remove ALL packages that have NVIDIA in the name then add nvidia-bumblebee again

Thank you wolfi323 & gogalthorp…I already feel the move from ubuntu to Suse is smoother than i thought & thanks for making this happen. I would like to help any way i can in return!
Please find the xserver log without the xorg.conf file @ http://susepaste.org/44129186 . I removed all driver related to nauveau & nauveau2 as shown in http://susepaste.org/45771783 before successfully booting to kde without xorg.conf file. I was not sure removing nauveau driver was the right thing to do but i wanted to see the whether i can boot without it, which worked!

I’m still not able to setup dual display via HDMI (‘Display configuration’) & Opengl configuration also seems to be an issue. i notice same error '**Unable to initialize opengl’ error when i access opengl from kde info center. The desktop effects is not allowing me to set the composting to ‘opengl’ & qt graphics as ‘Raster’

So it does boot now without xorg.conf?

I removed all driver related to nauveau & nauveau2 as shown in SUSE Paste before successfully booting to kde without xorg.conf file.

It should not be necessary to remove xf86-video-nouveau, and you MUST NOT remove libdrm_nouveau2!
You have this in the Xorg log now:

     5.450] (EE) AIGLX error: dlopen of /usr/lib64/dri/i965_dri.so failed (libdrm_nouveau.so.2: cannot open shared object file: No such file or directory)
     5.450] (EE) AIGLX: reverting to software rendering
     5.453] (EE) AIGLX error: dlopen of /usr/lib64/dri/swrast_dri.so failed (libdrm_nouveau.so.2: cannot open shared object file: No such file or directory)
     5.453] (EE) GLX: could not load software renderer
     5.453] (II) GLX: no usable GL providers found for screen 0

Which means GLX is completely broken now.

So install libdrm_nouveau2 again, and at least your intel card/display should fully work including OpenGL.

I’m still not able to setup dual display via HDMI (‘Display configuration’) & Opengl configuration also seems to be an issue. i notice same error '**Unable to initialize opengl’ error when i access opengl from kde info center. The desktop effects is not allowing me to set the composting to ‘opengl’ & qt graphics as ‘Raster’

That’s likely because of the above.
Re-Installing libdrm_nouveau2 should fix that.

For some reason, the nvidia card is not mentioned at all in your Xorg log though.
I’m no expert at all with hybrid systems, and especially not with using multiple monitors.
But it would seem to me that the nvidia card is somehow turned off. Have you checked the BIOS if you can enable/disable gfx cards or switch between them?
Or maybe it’s just disabled by bumblebee…
Try if optirun works now.

A second detected output is mentioned: eDP1, that’s probably your monitor.
Try to go into systemsettings (“Configure Desktop”)->Display and Monitor and look if you see both displays, maybe try to drag one around, it might “hide” the other (which means the display is “unified”).

wolfi323 donned his tin foil hat and penned:

An aside here wolfi

I have never messed with a hybrid system myself but as I understand it, when
the machine changes from one graphics to the other it switches of one???

If that is the case then I cannot see any way to use “both” outputs at the
same time, please correct me if I am wrong.

:slight_smile:

Mark
Nullus in verba
Caveat emptor
Nil illigitimi carborundum

Well, the intel is never turned off because the desktop is running on it.

But the nvidia card is indeed turned off when it is not in use to save power. That’s the point of Optimus.

If that is the case then I cannot see any way to use “both” outputs at the
same time, please correct me if I am wrong.

That depends. You can have more than one output on each card, i.e. both displays can be connected to the intel chip e.g.
If you want to use the nvidia card, it should not be turned off of course.

But even if one output is directly connected to the nvidia card (which means you don’t need Bumblebee to switch, but can use the nvidia card directly), you stilll cannot use the proprietary nvidia driver, as it breaks intel to which the laptop display is most likely connected.
The only hope in that case is that you can switch off intel/switch to nvidia completely in the BIOS.

Thanks… looks like i c’not get the dual display work easily with bumblebee. As strange it can be, the optirun is rendering polygon via Nvidia card

shankar@linux-ya15:~> optirun glxspheres 
Polygons in scene: 62464
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: GeForce GTX 870M/PCIe/SSE2
168.450882 frames/sec - 187.991184 Mpixels/sec
172.165320 frames/sec - 192.136497 Mpixels/sec
171.818035 frames/sec - 191.748927 Mpixels/sec

All other issues are resolved now except that I still don’t see trace of Nvidia on Xorg. I guess it is disabled from the ‘Driver info’ section of hwinfo command ouput pasted in my second post. Is there anyway to get this to work? Probably have Nvidia enabled & integrated intel graphics disabled? I don’t see an option in BIOS to disable Intel or Nvidia graphics

Ok, so Optimus/Bumblebee is working, and you can switch between intel and nvidia on the internal display I suppose.

Some more background information: there are three ways an output can be connected.

It can be connected directly to a card, in this case Xorg should detect when a monitor is connected and you can use that monitor without Bumblebee or similar. If an output is connected directly to the nvidia card, you have to connect a monitor to that output then to use the nvidia card.

Some systems have a switcher (muxer) that can connect an output either to the intel or the nvidia card. In this case you should be able to switch between them in the BIOS. Again, no need for Bumblebee in this case.

Last but not least, Optimus. In this case, the output is only connected to the intel chip, directly. The intel chip supports “passing through” nvidia’s output though. So you can use the nvidia for graphics, the output goes over the intel chip to the monitor/display that’s connected to the intel chip.
In this case you can/have to use Bumblebee and its optirun to run applications on the nvidia card. It is not usable directly.

A real hybrid graphics system now can have any mixture of these three types of connectors.

Your internal display is definitely of the third type I’d say.
The eDP1 output, whatever that is (DisplayPort maybe?), seems to be connected to the intel chip as well.

But here’s where my knowledge ends.

If you connect the external monitor to the eDP1 output, whatever that is (DisplayPort maybe?), it should definitely be possible to use both on the intel chip, and probably even run applications on the nvidia one.

Do you have several display connectors?
If one/some of those are directly connected to the nvidia card, you should be able to use that card as separate display too.
But as I already mentioned, you cannot install the proprietary video driver for that, you’d probably should install xf86-video-nouveau, I’m not sure that fbdev is of any use to you in such a constellation.

Could you maybe post a Xorg.0.log again to see the current situation?

Probably have Nvidia enabled & integrated intel graphics disabled?

If you don’t have an option in the BIOS, your hardware doesn’t seem to support this.

wolfi323 donned his tin foil hat and penned:

>
> baskitcaise;2712977 Wrote:
>> I have never messed with a hybrid system myself but as I understand it,
>> when
>> the machine changes from one graphics to the other it switches of
>> one???
> Well, the intel is never turned off because the desktop is running on
> it.
>
> But the nvidia card is indeed turned off when it is not in use to save
> power. That’s the point of Optimus.
>
>> If that is the case then I cannot see any way to use “both” outputs at
>> the
>> same time, please correct me if I am wrong.
> That depends. You can have more than one output on each card, i.e. both
> displays can be connected to the intel chip e.g.
> If you want to use the nvidia card, it should not be turned off of
> course.
>
> But even if one output is directly connected to the nvidia card (which
> means you don’t need Bumblebee to switch, but can use the nvidia card
> directly), you stilll cannot use the proprietary nvidia driver, as it
> breaks intel to which the laptop display is most likely connected.
> The only hope in that case is that you can switch off intel/switch to
> nvidia completely in the BIOS.
>
>

Thanks for the info, I have not messed with an Optimus system so it was
confusing me a little bit, Sunday afternoon, good lunch, therefore brain
slower than normal,

Chhers


Mark
Nullus in verba
Caveat emptor
Nil illigitimi carborundum

PS: An option might be to try PRIME instead of Bumblebee.
See here e.g. for setting up multiple displays:

But again, you won’t be able to use the nvidia driver this way, and have to stick to nouveau.

Before you try that though, maybe have a lookt at the output of xrandr what displays it lists. And try “optirun xrandr” too.

PS, that article says this about Bumblebee:

Unfortunately, it only allows two displays to be used at the same time, and limits you to the display ports directly accessible from the Intel GPU.

Thanks again for the detailed explanation. Yes… In the MSI GT60 laptop there are 3 external ports, 1 HDMI & 2 display ports. I guess i will give it a try with the Display port cable (need to get it from work) & post the Xorg.log output

The intel by-pass via HDMI seems to be working fine in Windows but i’m not able understand why the monitor is not detected in Xorg log when connected

Well here is the true problem with Optimus. NVIDA on Linux does NOT support Optimus. The nvidia-bumblebee driver is a kludge. The Windows driver does support Optimus. Write a nice but firm letter to NVIDIA asking for Optimus to be supported by their Linux drivers. It is their hardware idea in the first place but their official drivers do not support it.

  • eDP is embedded DisplayPort … http://en.wikipedia.org/wiki/DisplayPort#eDP v.s. http://en.wikipedia.org/wiki/Low-voltage_differential_signaling

  • You should be able to figure out the output configuration/typology, by running:
    [LIST=|INDENT=1]

  • /sbin/lspci -nnk | grep ‘VGA|3D|Display’ -A2 … to get the PCI ID info (essentially done already) and then

  • ls -la /sys/class/drm/card? … and match the PCI IDs to the card enumerations and then

  • ls /sys/class/drm/*/status | xargs -I {} -i bash -c “echo -n {}: ; cat {}” … to see the output configuration and their connection status

[/LIST]

Just to refine the useful commands given above… video cards usually identified by class 03

/sbin/lspci -nnk | grep '\03' -A2
ls -la /sys/class/drm/card*