Unable to change Nvidia settings

Greetings,
I’m having the following problem with SUSE 11.3 and my
Nvidia Geoforce 7300 GT.
I have the driver installed but am unable to change the resolution in the Nvidia configuration X-Server.
It seems it is limited to the following 640x480 and 320x200.
Please help me fix this as it looks awful and I know that I should have greater resolutions.

Please find my xorg.conf listed below

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 256.53 (buildmeister@builder97.nvidia.com) Fri Aug 27 20:55:22 PDT 2010

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0”
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
EndSection

Section “Files”
EndSection

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”
EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Unknown”
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Depth 24
EndSubSection
EndSection

Thanks
Jeff

‘Modes …’ is missing in SubSection “Display”
Assuming the wishes resolution is 1440x900 (it’s an example), try to add the line in red :

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1440x900"
EndSubSection
EndSection

… and restart X.

Thanks I added the above.
But there is still a problem, now after reboot the screen layout is even bigger.
I have to pan around to look at things.
I have also tried adding the “1024x768” with the same result.
The icons and screen layout is huge and I have to pan around to get to anything.
Any other sugestions to fix this.

Please see latest xorg.conf

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 256.53 (buildmeister@builder97.nvidia.com) Fri Aug

27 20:55:01 PDT 2010

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 256.53 (buildmeister@builder97.nvidia.com) Fri Aug

27 20:55:22 PDT 2010

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “Files”
EndSection

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “CRT-1”
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce 7300 GT”
EndSection

Section “Screen”

Removed Option “metamodes” “nvidia-auto-select @1024x768 +0+0”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "TwinView" "0"
Option         "metamodes" "nvidia-auto-select @800x600 +0+0"
SubSection     "Display"
    Depth       24
EndSubSection

EndSection

Thanks
Jr223

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “CRT-1”
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option “DPMS”
EndSection

HorizSync 28.0 - 33.0 can’t possibly be correct for any modern monitor. I had the same problem with the Nvidia x-configurator. Have you tried running without xorg.conf, it’s in most cases not needed nowadays?

Yeah it has the wrong information somehow?
Ok how do I run without xorg.conf?

And if so what do I need to do
Thanks

Just rename /etc/X11/xorg.conf to /etc/X11/xorg.conf.old or something and reboot, the system is supposed to do without it.

That’s a bit of a rough way to put it. If the X-server finds an xorg.conf, it will use that. If it doesn’t it will rely on autodetection and -configuration. :wink:

Hi,

I did exactly what was suggested.
I renamed the /etc/X11/xorg.conf to xorg.conf_Backup
Then restarted the system with a compltete shutdown and power up.
When I logged in no graphical display was available, just the console.
I even tried to startx server again this failed.
One other item, even rescue mode from boot up menu failed to load the GUI.

Please let me know what I need to configure for the new none xorg configuration of the system.

can you run nvidia driver w/o xorg.conf? i thought that was always created by the driver installation and necessary with that driver. (not really sure though, that’s why i ask.)

to get your system working again you’ll have to put the old xorg.conf back, of course, and i’d say get exact refresh rates and possible resolutions from your monitor’s manual, if necessary online. putting these values into xorg.conf should work.


phani.

I missed a very important step.
So I did all of the above with the extra step of re-installing the NVidia drivers, then I did the rename of the xorg.conf and rebooted

Yeah,
Maybe in future releases the xorg.conf will be completely removed or it will ask you when you do the install.
My feelings are that the Nvidia driver install did the creation of the xorg.conf.
When I looked at the Nvidia settings panel there are a lot of options, one of them was pointing to the xorg.conf in ./etc/X11