Unable to change KDM theme.. Opensuse 11.1

Morning Everyone,
I have been having trouble changing my KDM theme. Regardless of what I select in the mananger the default opensuse kdm theme is used. When I try to apply a theme I get this error:

Command '/usr/bin/kcmshell4 kdm --lang en_US' not found

Perhaps you should change your KDM from openSUSE to upstream.

Not sure that is recommended…

Look at any version and note the Suse folder, might want to read the readme.


That didn’t do the trick… During the installation the opensuse branding was removed and upstream installed. during the next reboot KDM defaulted to the very classic KDM manager. I checked kdmrc and the settings appear correct, even manually editing the theme line doesn’t help

Go to YaST, System, /etc/sysconfig editor, Desktop, Display Manager, DISPLAYMANAGER_KDM_THEME= and set it to whatever you want. That was the only way I could get it to change. You’ll need to restart KDM after changing the value. Mine is set to oxygen. Hope that helps!