unable to change icons in 11.4 -- should be simple, right?

Hello. Sorry for this long post but I want to be clear as to what I have tried so far.

I just completed a clean install of 11.4 – using KDE 4.6.

It’s absolutely a love-hate relationship so far after upgrading from 11.1 and KDE 3.5.

With 11.1 it was incredibly easy to change my icons whether they were on the desktop, or in a Konqueror folder, or on the bar at the bottom of the screen. I simply right clicked on the icon, up would pop a configuration screen, I browsed to where the icons were stored, selected one, clicked “apply” and it was done.

But not in 11.4… >:(

For the icons I’ve dragged onto the bottom bar (e.g., YaST, Personal Settings, Dolphin, GIMP) if I right click on any of them and then click “icon settings” I get a screen where I should be able to see and change the icon, but instead I see a grayed-out gear, and all of them seem to be controlled by root. Under 11.1 and KDE 3.5 I could change these icons, but not with 11.4.

Another example… Under System Settings>File Association>inode>directory. Here you see a plain blue folder icon.

Upon left clicking that icon I can then browse to my icons, choose one, click it, and then “apply,” and the icon does change here in the “inode/directory” screen. But the change does not carry over to anywhere else. Under KDE 3.5 and 11.1 it would change every folder everywhere in my home directory.

I would do the same thing in “file associations” with some applications (e.g. Word, Powerpoint, and Excel which I run with Crossover Office), and by changing the icon under “file associations” it would change every similar document in my home directory.

But not in 11.4.

Am I missing something?

In the first case with icons on my desktop I am unable to change them (seemingly locked to root).

In the second case with icons I see in “file associations” I can change them in that screen, but the changes do not then apply globally.

This should be so easy.

Thanks for your help.
socref

After you right click and select Icon settings, look on the general tab, on the right across from Type: is a little wrench. Select the wrench and a new popup window appears. Now on the new general tab you can select the program icon on this window and change it to something else. Changes here will be global I think.

Thank You,

James, thanks for this reply.

I followed your instructions exactly, and upon clicking “apply” the icon did change in the screen you pointed me to.

However, nothing changed on the bar at the bottom of the screen.

This is exactly the same thing happening as I described in my first post when I was in “file associations” and was successful getting the icon to change in the configuration screen but unsuccessful getting it to “stick” and apply anywhere outside the icon configuration screen.

Any other ideas?
Thx
socref

socref wrote:

>
> jdmcdaniel3;2363441 Wrote:
>> After you right click and select Icon settings, look on the general
>> tab, on the right across from Type: is a little wrench. Select the
>> wrench and a new popup window appears. Now on the new general tab you
>> can select the program icon on this window and change it to something
>> else. Changes here will be global I think.
>>
>> Thank You,
>
> James, thanks for this reply.
>
> I followed your instructions exactly, and upon clicking “apply” the
> icon did change in the screen you pointed me to.
>
> However, nothing changed on the bar at the bottom of the screen.
>
> This is exactly the same thing happening as I described in my first
> post when I was in “file associations” and was successful getting the
> icon to change in the configuration screen but unsuccessful getting it
> to “stick” and apply anywhere outside the icon configuration screen.
>
> Any other ideas?
> Thx
> socref
>
I just followed James instructions also. Have same results as you. I
notice the icon in the panel is root:root for owner and group. This used
to work.

If you find a solution please post it. Later today I will boot up 12.1 ms2
and see if it works there. I’ll do the same. Is there a bug filed on this?


Russ
openSUSE 11.4(2.6.37.6-0.5-desktop)|KDE Platform Version 4.6.5 (4.6.5)
“release 8”|Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce 8400GS (NVIDIA-Linux-
x86_64-270.41.06)

Have you tried doing it in the KDE Menu Editor?

Right-click the application launcher button and click Edit Applications

Not sure if it’ll change panel or desktop icons already created doing it that way but it should affect any you create thereafter

Russ, thanks for reply. I do not know if a bug has been filed on this.
socref

Ecky, thanks for your reply.

I tried it and you are correct. Doing it this way will not change any icons already on the screen. But you do get the new icon when dragging a new one to the bar at the bottom.

Next I have to see if I can do the same thing in the file associations configuration screen. Stay tuned.

Thanks again.
socref

I have successfully changed all of the icons I need to on the bar at the bottom of the screen. I added a second bar at the top and did the same.

Thanks!

But no matter what I tried, I still cannot get changes to icons in “file associations” to stick anywhere but the icon in the configuration screen.

Deep sigh…

socref

Ecky wrote:

>
> Have you tried doing it in the KDE Menu Editor?
>
> Right-click the application launcher button and click Edit
> Applications
>
> Not sure if it’ll change panel or desktop icons already created doing
> it that way but it should affect any you create thereafter
>
Tried above and it created new entry fine but did not place it in the
panel. I right clicked icon in menu and choose add to panel. that works
but every time I click it the address book comes up but it continues to
try and start something else until the start times out. Addressbook works
fine.

thanks


Russ
openSUSE 11.4(2.6.37.6-0.5-desktop)|KDE Platform Version 4.6.5 (4.6.5)
“release 8”|Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce 8400GS (NVIDIA-Linux-
x86_64-270.41.06)