Unable to boot VPS after 12.1 updates.

I just updated a Thrust::VPS Xen HVM vps having opensuse 12.1 installed. Just a normal zypper ref,zupper update, reboot… type action. Now the vps will no boot. I get messages like “Could not find /dev/disk/by-id/ada-QEMU_HARDDISK_QM0001-part2” type message and also “BUG: softlockup - CPU#0 stuf for…” type messages. If I boot of the opensuse 12.1 Net install ISO image, I can see that the /dev/disk/by-id values match that in /boot/grub/menu.lst.

I’d like to know what causes this and if my system is screwed up beyond repair. Should I just save data and reinstall? I updated 2 opensuse 12.1 Oracle Virtual box images at home at the same time and did not have this problem.

Any help appreciated,

Not that I understand your exact setup but it would be best if you posted a copy of your fstab file and gave us the output of a fdisk -l. You can start by placing a remark sign # in front of each entry in your fstab like the QENU you talk about. Basically, perminant fstab entrys that don’t load are a problem if you do not use the load option called “noauto”, without the quotes. Boot from any bootable Linux image and give us a copy of the** /etc/fstab** file if you can and a fdisk -l command and post it into a message here. You could edit the fstab file and add the **noauto **load option to see if it will help.

Thank You,

Thanks for getting back. Here is what I get for fdisk -l, /etc/fstab, and /boot/grub/menu.lst. I though I’d add menu.lst

fdisk -l

Disk /dev/sda: 32.2 GB, 32212254720 bytes
255 heads, 63 sectors/track, 3916 cylinders, total 62914560 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000936d2

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63     3068414     1534176   82  Linux swap / Solaris
/dev/sda2   *     3068415    27342629    12137107+  83  Linux
/dev/sda3        27342630    62910539    17783955   83  Linux


/dev/disk/by-id/ata-QEMU_HARDDISK_QM00001-part1 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-QEMU_HARDDISK_QM00001-part2 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-QEMU_HARDDISK_QM00001-part3 /home                ext4       acl,user_xattr        1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0


# Modified by YaST2. Last modification on Fri May 11 14:38:55 MST 2012
# For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 12.1 - 3.1.10-1.9
    root (hd0,1)
    kernel /boot/vmlinuz-3.1.10-1.9-desktop root=/dev/disk/by-id/ata-QEMU_HARDDISK_QM00001-part2 resume=/dev/disk/by-id/ata-QEMU_HARDDISK_QM00001-part1 splash=silent quiet showopts vga=0x314
    initrd /boot/initrd-3.1.10-1.9-desktop

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 12.1 - 3.1.10-1.9
    root (hd0,1)
    kernel /boot/vmlinuz-3.1.10-1.9-desktop root=/dev/disk/by-id/ata-QEMU_HARDDISK_QM00001-part2 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x314
    initrd /boot/initrd-3.1.10-1.9-desktop


Can you also post the contents of /boot/grub/device.map ?

A thing that could have happened, but that’s merely a guess, is that mkinitrd has not finished properly.

Here it is


(hd0)	/dev/disk/by-id/ata-QEMU_HARDDISK_QM00001

If I have to run mkinitrd in the rescue environment, could you show me of a know example that works? I’ve seen some posted, but I think people were saying that there were problems.


If possible, boot it from a liveCD, open a terminal window, become root, and take over the installed system, in your case /dev/sdaX is /dev/sda2:

mount /dev/sdaX /mnt
mount --bind /dev /mnt/dev
chroot /mnt
mount /proc
mount /sys

now you can start yast in ncurses mode to, for example, reinstall the bootloader, downgrade the kernel, check logs etc.

I’ve met it once or twice, that the new initrd after a kernel upgrade had not succeeded, I ran it manually by invoking “mkinitrd”.

Thanks I did that, ran the mount and chroot commands. When I ran mkinitrd I did notice the following message:

modprobe: Module piix not found.
WARNING: no dependencies for kernel module 'piix' found.

When I boot, its the same old ****, I can’t boot in. Could the warning about piix indicate the problem?

Well, maybe a better explanation is that after booting again when I did the mkinitrd I get the same error messages as I described in the first post. I think the piix comes from ata_piix (or some package with a similar name) and that this is a sata driver that the kernel needs. Question: If you can get a network connection manually, can I just mount the installed system, chroot, and then run yast (curses mode) or zypper to install/reinstall any packages.

Thanks, any help appreciated.

Yes either can be run from command line if you get to a terminal.

Yep, you can run “yast” from the prompt, reinstall anything, downgrade the kernel, whatever you want. As for the networking, just ping an IP or URL to see if it’s available, otherwise start the networking through yast or any method you’re familiar with

I have tried to rebuild the initrd but I keep getting the same errors regarding module piix. I reinstalled, the machine booted, but when I ran updates, the VM won’t reboot. I am beginning to think that the current updates from SuSE are unstable. I wish I knew how to fix this, but I am about ready to give up and try something like Fedora 16/17 instead. I’d like to not have to do this. But I guess I don’t know enough to successfully get this thing to reboot after upgrades. Any help appreciated.

Thanks for the help I got. The mount commands helped me to learn how to rebuild an initrd, great hands-on learning experience that will pay off in the future.

I tried a fresh install of opensue 12.1 and ran updates. The VM will still not boot. I noticed there is no piix issues as ata_generic is all that there is in /etc/sysconfig/kernel INITRD_MODULES. I guess that Thrust::VPS Xen HVM is not setup correctly to work with SuSE 12.1 or the current updates for opensuse 12.1 are messed up. I noticed that on a Desktop install of opensuse 12.1 I have at home, the nvidia repository had all their files missing (they are there now). You don’t learn anything by giving up, but I have exhausted my time. I’ll give Fedora a try. If that does not work, I may ditch Thrust::VPS and go with Linode. I like Linode, but they don’t have Xen HVM and you can’t upload your own iso. You are stuck with slightly older distributions. I do not get Fedora to work, I will post back to the forum because then it may be the hosting provider.

Thanks, greenaj