Unable to boot Tumbleweed USB ISO on Lenovo Z70


Ok, to clarify, yes, the Z70 is in UEFI mode, I can boot to the EFI / Grub screen, however I suspect the initrd on the USB doesn’t have a necessary driver

I have verified that the media works on another (desktop) computer and did a successful install onto my new 2Tb disk. But that wasn’t in UEFI mode, so although I could boot the Z70 with that disk
I had to put it into Legacy Mode in the BIOS - and I’d prefer not to do that

The laptop itself, on my old HDD, runs tumbleweed anyway, but I want a fresh install on the 2Tb disk, so there isn’t a particular hardware incompatibility in tumbelweed itself, just on the install media

After starting udev, it just sits there with

Starting udev... ok
Loading basic drivers...

Switching tty to tty4 I see

usb-2-2: reset high-speed usb device number 2 using xhci_hcd
EDD information not available

every 60 seconds or so

So, a couple of questions.

  1. I assume I can extract the ISO into a folder on my HDD, and then mount it in a chroot, and re-build the initrd ? and Then do something to write those back onto a partition on the USB drive, and hopefully that might have a working driver?

  2. Is there and option on the EFI grub screen that will allow me to get a working shell so I can make a more informed guess about what is going on?

The only real error I see is about EDD, so I’ve tried setting edd=off (and also nomodeset nofb)

Does this mean that although it boots from usb, it then tries to load a driver to mount a filesystem from it, and it can’t?

Did you try without those two settings, just add


to the end of the boot command?


Yes, I’ve tried just nomodeset on it’s own.

I’ve also tried putting the laptop into Legacy mode, and this hs allowed me to see a little more. From observing what happens when booting on another computer, the installer loads up YAST.

On the Z70, in Legacy mode, it tries to load yast but at this point it can no longer access the USB disk, and asks where the media contiaining YAST is located.

This is what leads me to suspect it’s a USB driver problem on the install USB.

NB I also tried the current Leap install USB,and that does the same.

I’ll fire up another computer, and put this one into Legacy Mode and post some actual details of what the Installer is tryi ng to do when it fails.

And maybe I’ll see if I can burn a DVD, but then again, that only appears in the Legacy menus as a boot option, not in UEFI.

So, on my netbook, the Z70 is in BIOS Legacy Mode, with UEFI first, and attempting to boot from USB (in EFI mode)

And with just nomodeset after removing splash=silent

What I can see that seems relevant is

device not found (err = 0): *label/OEMDRV

which it then fails to mount.

However, it looks as though we now have victory, as about 10 minutes in, while I was starting this post, and
trying to read off the Z70 screen, the install finally tried something else to mount the disk, and has started YAST2

So, I’ll get my 1Tb disk out of ther laptop, put the 2Tb disk in, and see if I can get through the whole install process.

Perhaps I can put the Z70 back in pure UEFI mode, and just need to wait 10 minutes or so?

I will update when I find out.

Just to confirm, it looks as though it takes 4 re-scanning of devices (about 10minutes) before the installer can actually find the relevant device so it can load AutoYast

This is still with the Z70 in Legacy Mode, but with boot from UEFI first

We’ll see what happens in pure UEFI mode if I wait long enough - got to go to work, now…

So it looks as though a Lenovo Z70 probably has a buggy BIOS / UEFI

Iv’e got Tumbleweed (with XFCE4) installed, and after several arguments with the disk partitioner in the installer have a working system.

In this case it looks as the opensuse forums - literally - provided the solution, as if I wasn’t booting up another netbook, so I could write up error messages, I wouldn’t have waited 10 minutes or so for the Installer to re-scan devices enough times to acutally succeed, load AutoYaST and then get into the install process.

I can confirm that setting the Z70 purely to UEFI did NOT work. It’s only if I had Legacy Support enabled - even if booting UEFI - that I was able to get past the

Loading basic drivers....


So I must give credit to the suse dev teams for setting the installer to retry and retry (re-scan) devices until something worked…

Now just got some 600Gb of data to transfer…

Luckily I have a CD drive caddy thing that allows me to plug a 2nd HDD in instead of the DVD drive…

A bit of an update here

I happened to be installing another laptop - Dell Inspiron 15 5570 - with Linux Mint, and so I tried that “Live USB” with my Lenovo, all set in UEFI mode, and it booted from the USB within seconds. no Faffing, no having to change BIOS settings, no waiting for 10 minutes for it to be able to load AutoYaST from the USB drive…

So I think there is definitely a problem on some hardware and hardware detection possibly to do with USB drivers on your Tumbleweed and Leap installers.