Unable to boot since AMD Proprietary Driver Install

I have AMD Radeon HD5700 card, and it has worked well till openSUSE 12.3 with proprietory drivers. This time, on openSUSE 13.1 however, when i installed Catalyst beta 13.11 V9.4 (1-click, also through building rpm, manually blacklisting the driver and all that) as explained in the guide, the system refuses to boot… noticed that the display goes blank after these two messages show up at bootup: “Starting AMD(or ATI) event” and then “Started AMD (or ATI) Event.” Sometimes, after about a minute of this blank screen, the monitor goes into sleep mode and then i have been able to get to GUI by pressing “Ctrl+Alt+Backspace”, however, it doesn’t work always as the monitor just stays blank mostly. And every time, when i shut down the system, it goes to the blank screen again and remains like that.
Have tried adding plymouth.enabled=0 while booting and that hasn’t helped much. Any ideas what needs to be done?


There is many reasons why is not working, but you can “boot” to command line environment, when grub menu show up, pres ‘e’ key add ‘3’ at the end of line started from ‘linux …3’ like this example

linux    /vmlinuz-3.11.6-4-desktop root=/dev/mapper/VG--system-sys--root   resume=/dev/VG-system/sys-swap splash=native  quiet showopts elevator=cfq 3

now you can able log in in console, inspect logs, even uninstall FGLRX driver, as ‘root’ or ‘sudo -s’

zypper rm fglrx(arch)_xpic_SUSE131-13.25.18-1.x86_64.rpm 

(arch) means 64 or 86, after removing ADM propriety check your ‘/etc/X11/xorg.conf’ do not refer to fglrx driver.

I have build driver myself using scrip posted by Lizards ‘amd-fglrx-beta’ from https://lizards.opensuse.org/tag/amd/ and its work well for me.


Czeslaw M.