Unable to boot LiveUSB on Lenovo IdeaPad MIIX 720

I have been trying to install openSUSE Leap next to windows on a Lenovo IdeaPad MIIX 720 but it refuses to boot from the LiveUSB in UEFI mode.
After a lot of experimenting with different USB stick configurations I found out that the device is only able to UEFI boot a GPT formatted USB stick and writing the openSUSE provided ISO onto an USB stick using rufus (dd mode) results in an MBR formatted stick which is just not able to boot on this device.
When I use rufus to format the USB stick in GPT format and then copy the openSUSE ISO contents onto the usb partition I am able to boot from the stick in UEFI mode, but then the openSUSE installer fails to recognise the installation media
If I try to write the ISO using rufus ISO mode in GPT format then rufus complains that the ISO is not an EFI bootable ISO image.

Does anyone know what I should do the have a GPT formatted USB stick containing openSUSE installation media recognized by the installer ?

Yes only GPT works booting any EFI.

EFI does not work on DOS format

If you copy the ISO to the USB device (not a partition) it should make it GPT since your place all the ISO image at the start of the disk and the image should be GPT

@OP: welcome !!

First: LiveUSB? There are no Leap 42.3 live images, only install media. From Leap 15 on ( in beta stage ) there will be KDE and GNOME live images.

The issue might very well be the hybrid filesystem of the install image. Please try ‘imagewriter’, or, if you can, to create the USB install disk

No, it doesn’t. The ISO image is an MBR structure, not a GPT structure.

This is not just openSUSE. I see MBR structured iso images as typical.

I seem to recall a GPT structured iso. I think it was a beta release for openSUSE 12.3, or maybe for 12.2. It worked. But it sure messed up the USB flash drive. Until the GPT structure was removed (the “zap” function in “gdisk”), it caused problems. So I’m glad that they are using MBR structured iso images.

The install media is in fact a live image. It can start a fully functional linux environment… From which you can rescue an existing system or start the installer. Indeed it has no desktop environment but that doesn’t make it no live image. Also on the download page of leap and tumbleweed the link to the instructions of how to write the image te an usb stick all speak about creating a LiveUSB… (see for ex. the actual instructions I initially used :https://en.opensuse.org/SDB:Create_a_Live_USB_stick_using_Windows)
So I copied the terminology used there hoping to be as clear as possibe stating the problem i experience.

I have tried a few writers, also imagewriter… But I keep ending up with this mbr formatted stick.

Searching around the net I now found minitool partition wizard which promises to be able to convert MBR to GPT without dataloss… So I tried that… And it seems to have just worked… I converted the stick with the iso written on it using rufus dd mode to gpt and it booted without problem now.
Media check fails due to checksum mismatch but installation in UEFI mode worked perfectly… Finally… Even with secure boot turned on.

So. The problem is solved, however… If anyone knows another way to end up with GPT formatted uefi bootable opensuse install media, I would gladly like to hear about it, (especially a way to do this using Linux) as I assume more and more machines will only be supporting gpt uefi in te future…
Maybe opensuse should start creating a pure gpt uefi install media and a seperate legacy bootable?
Or at least provide instructions on how to convert the current mbr hybrid media to a pure gpt uefi media.

In theory yes… But up to now most biosses supported booting efi from mbr…
Which opensuse used to create this hybrid legacy/uefi boot media…
Until now, when machines start to show up indeed only booting pure uefi media in gpt format…