Unable to boot into KDE

Long story:

I run an Unraid server for virtualization. I updated tried updating my Tumbleweed VM early in December and it failed. I used the Yast prompt and KDE failed to launch at the next boot. No worries - rolled back and waited a few days.

Tried once more and the update failed again - I had no network (couldn’t ping any of my local servers). Tried to rollback to the previous rollback, but this failed - Filesystem was read only.

Restored from a copy of my VM and carried on.

Tried again at the start of the week using Zypper. Update worked despite failing to connect to the OSS repository - Carried out a zypper dup and confirmed there were no outstanding updates with a repeat zypper update. Still no KDE after boot. I couldn’t see any errors in dmesg journalmsg. Restored VM from backup once more (as I had work to do) and carried on.

Downloaded a new version of the Tumbleweed ISO and created a new VM. Used VNC graphics to totally eliminate nVidia passthrough from the equation, and the same result. No KDE on startup. If I call sddm manually, I see the error “Could not start the Display server on vt 7” This message only appears if I manually try to run sddm. There is nothing in journalctl from a standard boot, nor can I see any errors in dmesg. Please bear in mind this is now a fresh installation with no nVidia involvement.

Any ideas on what to check/try?

Hello and welcome to the forums.

It is a bit confusing what all you did. But one thing is for sure: you should not use zypper up (or YaST) to update Tumbleweed. You should only use

zypper dup

So when you say “I updated” and that means using zypper up, you can easily break things.

For people here to be able to follow what you do, see and get, better descriptions are needed. So please start with describing from your fresh installation. E.g. you talk about KDE, but with that imply that you did an installation where you choose to install KDE. Most here do not like “implying”, that like hard facts ;). So explain what you installed, what happened at your first boot after install.

Wayland or X???

If there is a NVIDIA card there is NVIDIA involvement. KDE+Wayland+NVIDIA is at best hit or miss. X should work with or without NVIDA driver

Try booting using nomodeset to use fall back drivers. Might want to try a different DM

Might want to mention your hardware, Cutting edge hardware can be a problem.

OK, I’ll try and be a little clearer.

Hardware isn’t an issue. My Tumbleweed is a Virtual machine on a KVM virtualisation server (unraid). I’ve been running the Tumbleweed VM as my daily driver for the last year without any issues.

Since the last update in early December, I cannot get this system to launch KDE. To carry on working, I restored a backup of my VM and I’m typing this response on it right now. (One of the reasons I run a virtualised system). This VM only fails when I apply the latest updates.

As a test, I have created a new Virtual Machine and installed Tumbleweed from the 211212 ISO. I have not passed the graphics card to this VM so it knows nothing about my nVidia card. I use VNC to access the VM. This test VM also fails to launch KDE.

I can create a VM and install an older version of the Tumbleweed ISO (20210916) and this runs perfectly - KDE launches on start-up as it has always done.

Something changed in the December update to cause this issue and I’m trying to find out what it was

I tried booting with nomodeset and that made no difference

When x is not started, log in as root in the CLI (I assume that you see that log-in, but you gave not a real clear description on what you see happening) and look at

jouirnalctl -b

I guess that the last part of it, where x should be started, is mots important, but the problem could be signaled earlier, e.g. on the mounting of the file systems.

I can see two error messages from sddm:

Failed to read display number from pipe
Could not start Display server on vt 7

The full extract is here: https://cloud.perrett.me/s/YWpCgftrztrRjDx

I’ve had a look at the xorg log and the last sections are:

     4.445] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/event1)
     4.445] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "evdev pointer catchall"
     4.445] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "libinput pointer catchall"
     4.445] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "vmmouse"
     4.445] (II) LoadModule: "vmmouse"
     4.445] (II) Loading /usr/lib64/xorg/modules/input/vmmouse_drv.so
     4.446] (II) Module vmmouse: vendor="X.Org Foundation"
     4.446]     compiled for 1.21.1.1, module version = 13.1.0
     4.446]     Module class: X.Org XInput Driver
     4.446]     ABI class: X.Org XInput driver, version 24.4
     4.446] (II) VMWARE(0): VMMOUSE module was loaded
     4.446] (II) Using input driver 'vmmouse' for 'ImExPS/2 Generic Explorer Mouse'
     4.446] (**) ImExPS/2 Generic Explorer Mouse: always reports core events
     4.446] (EE) 
     4.446] (EE) Backtrace:
     4.446] (EE) 0: /usr/bin/Xorg.bin (xorg_backtrace+0x85) [0x55563e9ea715]
     4.446] (EE) 1: /usr/bin/Xorg.bin (0x55563e814000+0x1d8215) [0x55563e9ec215]
     4.446] (EE) 2: /lib64/libc.so.6 (0x7f34dbc88000+0x56430) [0x7f34dbcde430]
     4.446] (EE) 3: /usr/lib64/xorg/modules/input/vmmouse_drv.so (0x7f34dc53e000+0x24f6) [0x7f34dc5404f6]
     4.446] (EE) 4: ?? [0x555640da62b0]
     4.446] (EE) 
     4.446] (EE) Segmentation fault at address 0x0
     4.446] (EE) 
Fatal server error:
     4.446] (EE) Caught signal 11 (Segmentation fault). Server aborting
     4.446] (EE) 
     4.446] (EE) 

Is this a symptom or a cause?