Unable to boot from live USB on HP dv4-1428ca laptop

Hey all, here’s my situation.

A few weeks ago I installed Fedora Linux 64-bit on my HP laptop which was running Windows 7. At that time I created a Live USB using the fedora-live usb tool and it booted fine.

A couple days ago I decided to try out openSUSE, so I downloaded the 64-bit live-cd image and tried to create a live usb using the SUSEStudio ImageWrite provided in the documentation. The tool kept giving me an error message, so I decided to try unetbootin instead. However, when i tried to boot the live usb on my HP laptop, it presented me with the message

“SYSLINUX 4.04 EDD 2011-04-18 COPYRIGHT (C) 1994-2011 H. PETER ANVIN ET AL”

with a blinking cursor and nothing else.

I’ve tried a variety of alternative programs for creating live USB’s (pendrivelinux, linux live usb creator, unebootin), and verified the checksum of the iso file for openSUSE 11.4 64-bit, and still was not able to get past the “SYSLINUX…” message on my HP laptop.

However, the live USB does boot on the other computers in my house.

Interestingly, if i create a live USB using the tool provided by Fedora, it will boot fine. However the Fedora Live USB tool cannot be used for other distros.

Any thoughts on the matter would be appreciated.

AMD Turion X2 Dual Core
4GB Ram
ATI Radeon 3200 Graphics
320 GB Hard Drive

Due to having the ATI Radeon 3200 Graphics installed, you may need to add the kernel load option nomodeset. You can type in any kernel load command just before you press the enter key and nomodeset is part of the Failsafe mode, along with lots of other things.

Thank You,

If you’re currently running Linux, all you need to do is dd the ISO to the USB drive (this will overwrite all data on the device)

SDB:Live USB stick - openSUSE

Thanks unamanic, your method worked